Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help! Check signal cable on monitor can't detect on new 3k pc


  • Please log in to reply
No replies to this topic

#1 Sunnymelbs

Sunnymelbs

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 05 June 2015 - 06:46 AM

Just got a 3k gaming pc from scorptec with windows 8.

Booted up when connected via hdmi perfectly, could see desktop perfectly.

Installed my norton, xbox pc drivers and what not perfectly.

Issues started when i downloaded steam.

Downloaded, went to the extracting screen and appeared to stop extracting/be stuck on some sort of loop that wouldn't allow me to proceed. Uninstalled and reinstalled steam several times to fix and still got stuck on the loop.

Read an online thread that suggested i boot pc in safe mode whilst giving firewall permission to steam.

Restarted the pc in what i thought would be safe mode.

My lg monitor now states that i need to "check signal cable" and even though pc sounds like its booting and running from the box still no image or windows desktop screen.

Tried out 1 or 2 different hdmi cables and still no connection. Also tried the d sub cable and screen just went black and showed nothing whilst pc whirred round.

Even tried plugging into tv via hdmi and detects nothing.

Tried same monitor via hdmi cord on anothet desktop and it shows pc running perfectly.

I am about to have a fricking meltdown since i spent so much on this pc, does anyone know what to do.

I don't think ive unseated anything as i haven't moved the box enough likely to unseat anything in the first place!

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users