Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Star Craft Hates Me


  • Please log in to reply
15 replies to this topic

#1 ubiquitously

ubiquitously

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 06 July 2006 - 04:59 PM

I've been playing Star Craft since 6th grade (in collage now). I know this game can play decent on dial up. I have high speed now and it seems that everyone's (about 95% of them anyway) latency is too high. I've had this problem for years. But with a little patience I can join that 5%.

A new but MAJOR issue now is that every since I moved and am on a router, I can see the games to join, 95% of them all red latency, and the ones that let me join do something weird. When I click on them it opens the game screen, you know where you can chat and see everyone joining and leaving. But the names stay blank and it give me "the game host has left" when he hasn't at all. Sometimes it will even let the names pop up and I can chat for a few seconds, but then it seems quiet... too quiet and "game host has left".

I also get abruptly disconnected with this router. My D-link wasn't this bad. (Wasn't good though.)

Is this my netgear WG111v2 wireless adapter? Or its router? Or something else?

Please let me know if you have had similar problems and fixed them or just have a solution.

BC AdBot (Login to Remove)

 


#2 aslyfox

aslyfox

  • Banned
  • 12 posts
  • OFFLINE
  •  
  • Local time:03:01 AM

Posted 06 July 2006 - 07:42 PM

You may need to open ports, as your router is most likely not accepting most of the incoming queries.
I've no idea on how to open ports myself, so could someone else help?

#3 ubiquitously

ubiquitously
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 06 July 2006 - 09:29 PM

Please

#4 .Prodigy.

.Prodigy.

  • Members
  • 155 posts
  • OFFLINE
  •  
  • Location:New York
  • Local time:10:01 PM

Posted 07 July 2006 - 01:01 AM

I use a netgear as well, so this should be pretty easy. Go into any broswer and type 192.168.0.1 into the url bar. Press enter and you should be directed to your router's configuration page. Most likely, it will ask for a login and password. The default login for both my Netgear routers was Username: admin Password: password If this doesn't work for you, check the manual that came with your router.

Once your in the configuration screen, look for a link on the left side that says Port Forwarding. In there press "Add Custom Service"

Check the "Enable" checkbox.
For Service Name, put whatever (probably Starcraft or battle.net)
For starting and ending port, put the port range, which can be found on battle.net or blizzard.com for starcraft. I'll try and find these for you in a minute.
For Server IP address, put the address your router assigns your computer (the one you want to play starcraft on.

EDIT: I found this useful website: http://www.lukiland.de/starcraft_broodwar_...ish_version.php which explain battle.net problems behind a netgear router (I have them myself as well)

StarCraft requires port 6112 to be opened (just set both starting and ending ports to 6112)
Diablo II required port 4000
Warcraft III requires ports 6112-6119

Edited by .Prodigy., 07 July 2006 - 01:12 AM.

Posted Image


#5 ubiquitously

ubiquitously
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 07 July 2006 - 03:39 PM

I tried it on the computer with the adapter, 192.168.0.1, I think it fixed the latency issue, which is still pretty bad. I can't join about 60% of the games now. (Used to be about 90% or more before port forwarding.) TY for that fix. BUT...
It still gave me the same main issue with a little twist. It still does the same things (blank recruit screen then "host has left" or a few seconds of normal recruit screen THEN "host has left") but now I can actually play some of these games... but with an intense, consistant lag.

Please help!

Thanks for previous help and any more to come.

#6 Konan

Konan

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:01 PM

Posted 09 July 2006 - 03:11 AM

For playing starcraft you need to open port 6112 TCP/IP and UDP both direction.

#7 ubiquitously

ubiquitously
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 09 July 2006 - 12:57 PM

As stated in my last post, I think I already did that. But it doesn't seem to have fixed anything, except that I'm seeing much less latency. Which is a great fix by the way, but it hasn't fixed the "host has left", with random drop offs issue that keeps kicking me in between the legs. :thumbsup:

#8 ubiquitously

ubiquitously
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 11 July 2006 - 01:39 AM

OLD NEW PROBLEM!?!?!

Okay, I found out Time Warner hooked up my Internet all kinds of retarded. The guy who installed it said the modem right next to my computer was just for the phone. I called today after noticing a cute little ethernet output on it.

So now my computer is hooked up directly to the modem ethernet style. But here's something I forgot to tell you guyz...

Everytime "multiplayer" is selected for Starcraft my CPU usage goes through the roof 100%. I double checked it and it is at the exact moment I select "multiplayer" that my computer does this. My cpu refuses to relax until I go back to the selection screen.

I have 1024Mb memory and I'm beggining to think my computer isn't utilizing it. My computer says;

Phsyical Memory (K)
Total = 1047344
Available = 741392
System cache = 282792

This is unchanged whether or not my CPU usage is riding @ 100% or 0 %. Is that right or not?

I also run Norton Firewall and System Works. I created a rule for port 6112 to be allowed always.

My computer has been doing this for years, I messed with StarCraft's compatibility mode to reduce this significantly, but it still is kicking my compy's booty. Nothing lower than windows NT compatibility will work.

P.S. I now use a no CD hack, which also reduces the problem, but cpu usage is till 100%.

Please help me, I still <3 SC!

#9 yano

yano

    I can see what you post!


  • Members
  • 6,469 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 11 July 2006 - 08:31 AM

I have high speed now and it seems that everyone's (about 95% of them anyway) latency is too high

One must realize that majority of people who play starcraft are on dialup. Cable/DSL users can't play games with dialup users or it will have too much lag (latency), and visa versa.

#10 Elendil

Elendil

  • Members
  • 660 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The US
  • Local time:10:01 PM

Posted 11 July 2006 - 08:36 AM

I have high speed now and it seems that everyone's (about 95% of them anyway) latency is too high

One must realize that majority of people who play starcraft are on dialup. Cable/DSL users can't play games with dialup users or it will have too much lag (latency), and visa versa.


Actually, I play SC constantly and I find no problem with my 2.5 MBPS DSL connection. The majority of games are at 1 green bar lag and I can game with them just fine. Maybe it's just the different location servers... I'm on USEast.
Stanford '14
B.S. Candidate | Computer Science

#11 yano

yano

    I can see what you post!


  • Members
  • 6,469 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 11 July 2006 - 08:39 AM

Could be that, however, what I was trying to explain to ubiquitously was that one can't join a game with the red bars.

Also I'm not saying anything bad about wireless routers, but I've heard several reports of users getting drop packets and problems during multiplayer game, even when it's on a LAN.

#12 ubiquitously

ubiquitously
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 15 July 2006 - 07:44 PM

Yano-
"Could be that, however, what I was trying to explain to ubiquitously was that one can't join a game with the red bars. "

I'm quite aware of that. My computer's only problem now (hopefully) is the CPU usage doing 100% as stated in my last post.

I would appreciate any help with this. I'm completely confused. :thumbsup:

#13 yano

yano

    I can see what you post!


  • Members
  • 6,469 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 15 July 2006 - 07:48 PM

Have you tried to the compatibility wizard on XP when opening it? Set it for Windows 98, because Starcraft originally was released in 1997 so it should be able to run for the configuration of Windows 98.

Another option, try closing out of almost everything in the taskbar (far right), then try Starcraft. If you still get 100% usage then it just might the install of Starcraft itself.

#14 ubiquitously

ubiquitously
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Location:San Antonio
  • Local time:09:01 PM

Posted 16 July 2006 - 02:03 AM

I messed with StarCraft's compatibility mode to reduce this significantly, but it still is kicking my compy's booty.


Also, nothing below windows NT compatibility works with my computer. I don't think it is the CD hack because I tried the compatibility modes on someone else's computer who uses the disc and it gives an error message stating something about not being able to find a directory of some sort, the same error I get when set to anything below Windows NT compatibility. But anyways...

In regards to the taskbar... I have done a clean (after hiding the Microsoft services) boot out of desperation, the results are exactly the same. But I really want my firewall and antivirus running, wich are the only background programs running. I mean, I do have the resources.

In regards to the reinstallation...

My computer has been doing this for years,


I have reinstalled Star Craft several times throughout the years with little variance between installs. And like I said before, I don't think it is the no cd hack.

:thumbsup: !!Please HELP!! :flowers:



#15 Cleeve

Cleeve

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 04 January 2008 - 12:36 AM

I HAD THIS ISSUE WITH VISTA AND FINALLY FIXED IT.

The answer is here:
http://www.petri.co.il/improve_windows_vis...performance.htm

Basically, Vista will run slow networking for some users. The solution is to:

1. Click Start and type CMD. (Don't hit enter yet!)

2. Press CTRL+SHIFT+ENTER to open the command Prompt with Administrative rights.

3. At the prompt in the Administrator: Command Prompt window, type the following command, and then press ENTER:
netsh interface tcp set global autotuninglevel=highlyrestricted

After you hit ENTER, the command prompt will respond with 'OK' if everything worked.

4. Reboot



I has set my router up with the proper ports and still had terrible latency in Starcraft. this fixed me right up.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users