Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dual Boot question


  • Please log in to reply
27 replies to this topic

#1 SuperSapien64

SuperSapien64

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:03 PM

Posted 20 May 2015 - 06:49 PM

Hi I'm dual booting Linux with Windows and Windows is on the 2nd HDD/sba1. But I was told that Windows should be on the first drive and not the second drive is this true? If so what should I do? :scratchhead:



BC AdBot (Login to Remove)

 


#2 paul88ks

paul88ks

  • Members
  • 1,289 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas,Texas
  • Local time:05:03 PM

Posted 20 May 2015 - 07:42 PM

It shouldn't matter if you are using grub2 as the bootloader.If you are using the windows bootloader you have to install Windows first. Also,Windows will only "see" two OS's,whereas Grub2 will "see" multiple installs. I have 7 running on 2 drives. but the first is Windows 7 - and then my Linux installs.

If you are only doing a dual-boot Windows/Linux Iwould recommend that Windows is first.Someone else on the forum will correct me if I am wrong-Paul



#3 SuperSapien64

SuperSapien64
  • Topic Starter

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:03 PM

Posted 20 May 2015 - 08:07 PM

It shouldn't matter if you are using grub2 as the bootloader.If you are using the windows bootloader you have to install Windows first. Also,Windows will only "see" two OS's,whereas Grub2 will "see" multiple installs. I have 7 running on 2 drives. but the first is Windows 7 - and then my Linux installs.

If you are only doing a dual-boot Windows/Linux Iwould recommend that Windows is first.Someone else on the forum will correct me if I am wrong-Paul

So what could happen if Windows is the second drive? I mean I'm using grub from Netrunner OS (Kubuntu).



#4 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 20 May 2015 - 09:07 PM

Windows is on the 2nd HDD/sba1


Are you sure about that? Normally the naming scheme is sda, sdb, sdc, etc. Assuming you meant sda1 that would suggest Windows is on hard-drive one (or depending on the tool used to get this info, Windows is on the drive with the highest boot priority).

I'm dual booting Linux with Windows


Is your computer BIOS or UEFI? Are you putting both Netrunner OS and Windows on the second drive, or will Netrunner OS be installed on the first drive, and Windows remain on the second drive?

 

#5 SuperSapien64

SuperSapien64
  • Topic Starter

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male

Posted 21 May 2015 - 10:04 AM

 

Windows is on the 2nd HDD/sba1


Are you sure about that? Normally the naming scheme is sda, sdb, sdc, etc. Assuming you meant sda1 that would suggest Windows is on hard-drive one (or depending on the tool used to get this info, Windows is on the drive with the highest boot priority).

 

Nope in Grub it list Windows as sdba1

I'm dual booting Linux with Windows


Is your computer BIOS or UEFI? Are you putting both Netrunner OS and Windows on the second drive, or will Netrunner OS be installed on the first drive, and Windows remain on the second drive?

 

 

UEFI and something weird after leaving the UEFI it skips grub and go strait to Windows. Windows is on a 1TB HDD and Netrunner OS is on a 2TB HDD.

I had my local computer store handle the installation of the 1TB HDD and Windows. So I'm not a 100% sure what they did.


Edited by SuperSapien64, 21 May 2015 - 10:06 AM.


#6 Naught McNoone

Naught McNoone

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Great White North
  • Local time:05:03 PM

Posted 21 May 2015 - 10:37 AM

Hi I'm dual booting Linux with Windows and Windows is on the 2nd HDD/sba1. But I was told that Windows should be on the first drive and not the second drive is this true? If so what should I do? :scratchhead:

 

If both systems are running fine, then there is no need to change anything.

 

In a dual boot system, Windows does not normally see the Linux installation.  This is because MS has deemed it unnecessary for Windows to be able to read Linux partitions.  (There are third party utilities that will allow you to see ext partitions in Windows.)

 

Normally Windows will automatically assign C: to the system drive, regardless of where that drive sits in the hardware or partition structure.  You can, however, set up Windows to assign a different drive letter to the system drive, but why?  Most software looks to the C: drive by default, so it can require a lot of tweaking.

 

I am sure that you have a typo or misread the sba1.  If you check you Linux /dev/ directory, you will find a list of all devices available to the system.  Hard drives are normally listed as /dev/sda, /dev/sdb, etc.  Partitions are listed as /dev/sda1, /dev/sda2, etc.

 

Cheers!

 

Naught



#7 SuperSapien64

SuperSapien64
  • Topic Starter

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:03 PM

Posted 21 May 2015 - 11:24 AM

 

Hi I'm dual booting Linux with Windows and Windows is on the 2nd HDD/sba1. But I was told that Windows should be on the first drive and not the second drive is this true? If so what should I do? :scratchhead:

 

If both systems are running fine, then there is no need to change anything.

 

In a dual boot system, Windows does not normally see the Linux installation.  This is because MS has deemed it unnecessary for Windows to be able to read Linux partitions.  (There are third party utilities that will allow you to see ext partitions in Windows.)

 

Normally Windows will automatically assign C: to the system drive, regardless of where that drive sits in the hardware or partition structure.  You can, however, set up Windows to assign a different drive letter to the system drive, but why?  Most software looks to the C: drive by default, so it can require a lot of tweaking.

 

I am sure that you have a typo or misread the sba1.  If you check you Linux /dev/ directory, you will find a list of all devices available to the system.  Hard drives are normally listed as /dev/sda, /dev/sdb, etc.  Partitions are listed as /dev/sda1, /dev/sda2, etc.

 

Cheers!

 

Naught

 

Oops I meant to say dev/sdb1. So why does the UEFI automatically boot Windows when ever I exit it? :scratchhead:



#8 Naught McNoone

Naught McNoone

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Great White North
  • Local time:05:03 PM

Posted 21 May 2015 - 11:36 AM

 . . . .  why does the UEFI automatically boot Windows . . . .

 

That is a function of the BIOS of your system.

 

Most new BIOS systems support the UEFI secure boot, but also allow you to change it to legacy mode.

 

If you are not having any problems booting into either system, then leave it as it is.

 

You may want to edit your GRUB boot loader to allow a longer "time out" before continuing to the default system.

 

Cheers!

 

Naught



#9 SuperSapien64

SuperSapien64
  • Topic Starter

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:03 PM

Posted 23 May 2015 - 09:39 PM

You may want to edit your GRUB boot loader to allow a longer "time out" before continuing to the default system.

 

Cheers!

 

Naught

 

How do I do that? BTW I'm thinking about trying Burg or Chameleon Bootloader instead of Grub.



#10 Rocky Bennett

Rocky Bennett

  • Members
  • 2,598 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:05:03 PM

Posted 24 May 2015 - 11:16 AM

I don't really know if I have a UEFI or a BIOS boot system, but I running both Linux Mint and Windows 10 on a home made computer with an Asus motherboard. When I restart my system it boots straight to a selection screen which lists Linux Mint first and if I do not select anything then it boots straight into Linux Mint.  If I want to boot into Windows, then I simply scroll down to Windows on my selection screen and choose Windows. This is in spite of my system seeing my Windows drive as the C drive. I have it set up this way because I used the GRUB tool as my means of establishing the dual boot set-up. I actually prefer it this way instead of going into Windows by default.


594965_zpsp5exvyzm.png


#11 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:03 PM

Posted 24 May 2015 - 12:34 PM

How do I do that?

Edit your /etc/default/grub settings file and change the time out value.

Here are the settings in mine:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""


My 5 second time out is determined by the line that says "GRUB_TIMEOUT=5". So all you have to do is open that file with root privileges using a text editor, and change that value to whatever you want. Save and close the text editor.

Then update your grub configuration file by running this command:

sudo update-grub
Job done. :)

#12 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,920 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:11:03 PM

Posted 24 May 2015 - 04:26 PM

 

If you are not having any problems booting into either system, then leave it as it is.

If it aint broke don't fix it.


Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#13 Naught McNoone

Naught McNoone

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Great White North
  • Local time:08:03 AM

Posted 25 May 2015 - 01:25 PM

GRUB_DEFAULT=0

 

 

I have used the following as an option for GRUB_DEFAULT.

 

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

 

This will automatically reboot to the last operating system used, if Grub is allowed to time out.

 

If you use this, don't forget to # out the GRUB_DEFAULT=0 and run update-grub.

 

Cheers!

 

Naught



#14 SuperSapien64

SuperSapien64
  • Topic Starter

  • Members
  • 873 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:03 PM

Posted 31 May 2015 - 02:50 PM

I've been experiencing more bugs in Windows lately it started off with small bugs like not showing the right date and time or showing the the trash bin on my thumbdrives even though hidden files aren't enabled and now there becoming more persistent with a new bug causing a double clicking action occasionally. I'm not sure if this is because Windows is dev/sdb1 or something else triggered these bugs. :scratchhead:



#15 paul88ks

paul88ks

  • Members
  • 1,289 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas,Texas
  • Local time:05:03 PM

Posted 31 May 2015 - 03:53 PM

Which version of Windows are you running?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users