Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Repair blocked Ping in Windows Firewall


  • Please log in to reply
10 replies to this topic

#1 jheymann

jheymann

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:34 AM

Posted 17 May 2015 - 06:48 PM

Just thought you should know. I just ran the repair tool. It didn't create (or it removed) a rule in the Windows firewall to permit protocol 1 - ICMP-4 (Ping) thru. That caused almost everything not to work. For example, remote desktop wouldn't connect. When I added the exception, everything started working again.

 

Take care.



BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,116 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:34 AM

Posted 26 May 2015 - 04:39 PM

What "Repair tool" did you run?


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#3 jheymann

jheymann
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:34 AM

Posted 26 May 2015 - 04:55 PM

Sorry, I didn't know they had so many. It was the All In One fix for Windows, that fixes permssions, firewall, etc.



#4 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:01:34 AM

Posted 26 May 2015 - 05:26 PM

ICMP [ping] and RDP are not related at all.  They are different RFCs [792 vs 908].  You don't need ping enabled to do anything on the internet or remote desktop.    

 

Something else was going on.



#5 jheymann

jheymann
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:34 AM

Posted 26 May 2015 - 05:43 PM

You may not be correct. At least using the Microsoft RDP client, it may use an ICMP packet to see if the remote address is there, prior to trying to connect with RDP. In any case, as soon as I explicitly allowed ICMP, the remote desktop started working. When I removed that firewall entry (just to test), it stopped working again.



#6 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:01:34 AM

Posted 27 May 2015 - 08:35 AM

Just giving you the facts jheymann.  We block ping and use RDP to connect 9 sites to a central server room. Ping leaves you exposed/discoverable which is why most of us turn it off.  Since you had to do a big all-in-one recovery if I were you I would still be concerned over your exposure on the internet.



#7 jheymann

jheymann
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:34 AM

Posted 27 May 2015 - 09:34 AM

Are you blocking Ping, or all ICMP?

 

I'm not sure why it wasn't working either with ICMP blocked, but it wasn't.



#8 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:01:34 AM

Posted 27 May 2015 - 12:42 PM

Where are you rdping to?  beyond your router?



#9 jheymann

jheymann
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:34 AM

Posted 27 May 2015 - 12:47 PM

I was actually on another machine on the local network, trying to rdp to the machine I had just run the fix on.

 

It is working now, with the ICMP allowed, so no big deal at this point.



#10 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:01:34 AM

Posted 27 May 2015 - 04:14 PM

And here I would think you have something seriously wrong if you need error reporting protocol icmp enabled for you to rdp locally. sounds more like someone has a door open into your network.  but hey what do I know.  I only run a corporate network spanning two states.  Have a great day and the best of luck.



#11 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,116 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:34 AM

Posted 29 May 2015 - 12:26 AM

For what it's worth you could actually add or edit a rule in the Windows firewall called icmp-4 and give it port number 3389. Then if you "Blocked" that port I bet you wouldn't be able to connect with rdp.  So technically it's plausible but I doubt thats the case here.


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users