Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Getting "Welcome to Nginx!" on web server


  • Please log in to reply
No replies to this topic

#1 Alternative

Alternative

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:38 PM

Posted 17 May 2015 - 05:43 PM

Hi everyone! I hope this is the right place to post this.

 

I have a CentOS 5 VPS that hosts multiple sites. There are three existing sites that are working on it just fine, but I am now trying to add a fourth and always get the "Welcome to nginx on Fedora!" welcome page when I visit the URL. It's probably something really small that I overlooked.

 

What I have already tried:

 

-Verifying the domain info: The domain information on the new domain and the three other domains are exactly the same, including SPF info. The new domain has had about 4 days to propogate.

-Verifying httpd.conf: Here's what I have:

 

<VirtualHost *:80>
    DocumentRoot /home/newsite/www
ServerName <domain>
    ServerName <my server IP>
    ErrorLog /var/log/httpd/<errorLog>
    CustomLog /var/log/httpd/access_log combined
<Directory "/home/newsite/www">
Options +Indexes FollowSymLinks +ExecCGI
Order allow,deny
allow from all
</Directory>
</VirtualHost>
 
Of course the entries in bold are set to my actual information. This is the same exact setup as the other entries in this file that make the other three sites work.
 
-Restarting the server (and /etc/init.d/httpd). No luck.
 
-Trying another machine: I have read that the nginx thing could be the result of a virus or host file. My machines are always clean (constant virus scans, not trusting browser-ran error scans, hahha), and my host file seems clean. Just for kicks I tried going to the site on another computer and I got the same nginx page.
 
-Clearing browser history: Of course this isn't necessary since I tried another machine, but I did it anyway. Google told me to do this and it didn't fix the problem.
 
-Google: It failed me! :o, this is how I learned about the virus thing.
 
-Messing with the directories: I put a test.txt file in /home/newsite/www and tried to go to domain.com/test.txt it and it threw a 403. domain.com/nosuchfile.txt and domain.com/nosuchdir also throw 403s.
 
-Verifying permissions: On my server all the sites are listed in their own folder in the /home/ directory. This is where I put the new site entry in as well. As said before the three other sites work fine so it's not a permission issue with /home/, and I have ensured that home/newsite/www has 755 (just like the other working sites).
 
-Looking at logs: I didn't really find anything in var/log other than the acknowledgement that the web server is getting the HTTP request.
 
-Telling the site verbally to stop showing nginx and to please show my site: No luck.
 
-Poking around in /etc/nginx: I have read there's a sites-available directory there that should help me but I don't see it when I'm logged in as root.
 
I'm a bit at a loss here.

Edited by Alternative, 17 May 2015 - 05:58 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users