Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Quadro FX1800M Stuck in "Low Clock Mode"


  • Please log in to reply
5 replies to this topic

#1 spencer2004

spencer2004

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 06 May 2015 - 04:07 PM

Hi.

 

I have recently bought a second hand HP Elitebook 8540W with a Nvidia Quadro FX1800M installed.

 

I am having a problem where the GPU clock will get stuck at it's power saving clock of 405 MHz whereas it should be running at 560 MHz, the difference between these clocks results in a 217% performance change so I assume that other aspects of the GPU are being throttled down too. I cannot override this by changing the clock in Nvidia control panel or MSI afterburner. The only way I have found to temporary resolve the problem is to restart my laptop.

 

I have confirmed that the clock does not return to normal when 3D applications are open. I have the latest driver installed and I have tried 2 different previous ones (can't remember which). Power management in the Nvidia control panel is set to "Prefer maximum performance".  PCI link state power management in Windows power settings is set to off.

 

The low power mode has turned on and stayed that way after a driver crash but has also happened several times for no apparent reason, my only theory is that when the GPU reaches a certain temperature it will go in to the low power mode to prevent it from catching fire. Obviously it is a good thing that it prevents component damage and system crashes but it is very annoying that it does not return to it's performance mode once the temperature drops.

 

So does anyone have any idea what's going on?



BC AdBot (Login to Remove)

 


#2 YeahBleeping

YeahBleeping

  • Members
  • 1,258 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:13 PM

Posted 06 May 2015 - 05:17 PM

Most laptops will drop the gpu to 'low clock mode' as you put it.. if it is not plugged into the wall.  In other words it will not power up to high clock mode if you are not using the laptops's power cord. Maybe there is something wrong with your power brick?


Edited by YeahBleeping, 06 May 2015 - 05:18 PM.


#3 spencer2004

spencer2004
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 06 May 2015 - 05:32 PM

Thanks for your reply.

 

I have done all the testing and troubleshooting while the laptop is plugged in, in fact I haven't even used the laptop on battery power yet.

 

My power brick is the 120W model, there is a 150W model which is recommended for the quad core variants of my laptop (which it is).

 

Perhaps that is the problem but then again it does work fine for a while before down-clocking the graphics card. In fact it has performed flawlessly for several hours at a time while gaming without under-clocking the GPU so my gut feeling is that it's something else. I would prefer a way to prevent the GPU from going in to power saving mode, at least for testing purposes. If it crashes then I need a better PSU I guess or it's an overheating problem. The main problem though is that it does not return to the higher clock rate until it is restarted.



#4 YeahBleeping

YeahBleeping

  • Members
  • 1,258 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:13 PM

Posted 06 May 2015 - 05:52 PM

You can use some free software out there to monitor temps to see if it is getting too hot.  One is HWmonitor/CPUID.  There are others.  Be sure not to install any third party programs that attempt to install (like browser addons etc.) If it IS heat related .. on a laptop I am not sure what your options are except maybe a laptop cooling pad perhaps may help.

 

I realized your using an Nvidia card .. Nvidia system monitor will also display current temps.


Edited by YeahBleeping, 06 May 2015 - 05:56 PM.


#5 spencer2004

spencer2004
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 06 May 2015 - 06:00 PM

I forgot to mention that.

 

I use HWmonitor to monitor the temperature and I always force the fan to 100% whenever I am gaming. I do not have a cooling pad but the laptop is situated on a table and raised up a little to add a gap between it and the table to aid with air flow.

 

The temperature does not go above 80 C.

 

Still the point is that the GPU remains stuck in it's low clock mode even after the temperature drops and I need a way for get out of it without rebooting.

 

On an unrelated note I cannot add a profile pic on this website for some reason. I have tried it on Chrome, Internet Explorer and Firefox.



#6 spencer2004

spencer2004
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 09 May 2015 - 04:41 PM

OK so this is turning out to be a massive pain in the bleep. I have been Googling for hours and there are plenty of threads on this but no solutions that work for me.

 

I have found a workaround however and I will share it for the poor souls who are also having the same problem for the low low price of 5 Dogecoin (lol jk):

 

1) Download the Windows Driver Kit (WDK) to obtain the Devcon tool https://msdn.microsoft.com/en-us/windows/hardware/hh852365.aspx

2) Open up the command prompt and enter the command "C:\Program Files (x86)\Windows Kits\8.0\Tools\x64\devcon" listclass display

3) The device ID for your graphics card will be shown, use it in this command: devcon restart "<device ID>"

For example: "C:\Program Files (x86)\Windows Kits\8.0\Tools\x64\devcon" restart PCI\VEN_10DE&DE

V_0CBC&SUBSYS_1521103C
4) The GPU driver will magically restart it's self and the clock restrictions will be lifted. Stick it in a bat file to make it easier.
 
This proves that it is indeed a driver problem which, in my opinion, has been missed by the Nvidia driver team and only affects a specific hardware / software configuration.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users