Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

sabertooth 990fx r2.0 cpu led red


  • Please log in to reply
No replies to this topic

#1 kietav

kietav

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:22 PM

Posted 28 April 2015 - 06:44 AM

Hello. Yesterday, I noticed that my PC was under performing, heating a bit more than before. I opened the case, and saw a lot of dust in the case. I cleaned it, but now my PC won't turn on. CPU led is red, and stays lit when turned on. No other led is flashing. I had a similar problem, when CPU led was red, I took CPU out blew on the socket, then put it back in and it worked. Tried that now - didn't work. I check other similar threads on this forum, but I can't find the answer. Any advice on what I can do? I tried to reset CMOS, but that didn't work. All the power should be alright. I don't know wheres the problem.
My specs: 
CPU: AMD FX-8350
GPU: Gigabyte Windforce 760 2gb ddr5
RAM: Hyper X 8gb stick, don't know exact model.
PSU: Cooler Master G550M
CPU Cooler: Cooler Master Hyper 212 Evo
UPDATE: Took out GPU now when I turn on the PC only VGA CARD led stays lit. 
UPDATE 2: Put the GPU back in after taking out battery, CPU led is back up, VGA not anymore. By the way, can't see anything in the monitor.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users