Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Excel 2013 error


  • Please log in to reply
7 replies to this topic

#1 diggi

diggi

  • Members
  • 335 posts
  • OFFLINE
  •  
  • Local time:07:37 PM

Posted 17 April 2015 - 11:05 AM

I'm trying to open an add in in excel 2013 and I keep getting this message

 

Compile error

The code in this project must be updated for use on 64 bit systems

Please review and update Declare statements and then mark them with the PtrSafe attribute

 

I have no clue what to do



BC AdBot (Login to Remove)

 


m

#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,935 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 17 April 2015 - 11:10 AM

Hi,

 

Most likely you have Office 2013 64 bits installed and the add-in only works on Office 2013 32 bits!


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 diggi

diggi
  • Topic Starter

  • Members
  • 335 posts
  • OFFLINE
  •  
  • Local time:07:37 PM

Posted 17 April 2015 - 05:07 PM

I have some other folks with the same software setup (64 bit) but they don't seem to have a problem, we are all running 64 bit windows they are using 8.1 iam using 7 pro

Only one other guy who has 8.1 has this issue :(



#4 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,935 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 17 April 2015 - 05:11 PM

I have some other folks with the same software setup (64 bit) but they don't seem to have a problem, we are all running 64 bit windows they are using 8.1 iam using 7 pro

Only one other guy who has 8.1 has this issue :(

 

The problem isn't windows but Office. What is the folder where your Office is installed? post the full path please.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#5 diggi

diggi
  • Topic Starter

  • Members
  • 335 posts
  • OFFLINE
  •  
  • Local time:07:37 PM

Posted 17 April 2015 - 05:24 PM

C:\Program files (x86)\Microsoft Office



#6 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,935 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 18 April 2015 - 06:21 AM

C:\Program files (x86)\Microsoft Office

 
OK, It's 32 bits can you confirm with your friends if they have Office 32 or 64 bits?
 
According to Microsoft here the problem should happen only when editing the macro.
 
Can you post the name of the add-in you want to use and the website about it if available?

Edited by SleepyDude, 18 April 2015 - 06:24 AM.

• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#7 diggi

diggi
  • Topic Starter

  • Members
  • 335 posts
  • OFFLINE
  •  
  • Local time:07:37 PM

Posted 18 April 2015 - 11:56 PM

I will check with them, I'm trying to use SAP Bex Analyzer. BTW  Thanks for all your assistance with the issue



#8 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,935 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 19 April 2015 - 03:42 PM

I will check with them, I'm trying to use SAP Bex Analyzer. BTW  Thanks for all your assistance with the issue

 

You are welcome.

 

It seems the add-on is 32 bits, make sure you have the latest patches installed because sometimes Microsoft releases patches for Microsoft Office that can break some add-ons functionality, something like this just happen to me the other day.

 

Check the following thread maybe it contains useful information for you.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users