Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop won't charge or power on (HP Pavilion dv7-1005TX)


  • Please log in to reply
1 reply to this topic

#1 sweet-yeezus

sweet-yeezus

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 17 April 2015 - 08:45 AM

Hi folks,

I have a HP Pavilion dv7-1005TX running Windows 7 that's around 3 years old now.

For the last year or so, the power socket seemed to be a little loose - when I plugged the power adapter in, I would usually have to jiggle it for a second before the light would come on and it would charge. However, once it was in, it would stay continuously connected even if I moved the laptop or cord around.

Recently it started taking a bit more jiggling to get it to charge, then suddenly, it just stopped recognising the power adapter altogether. No matter how much I moved it around in the socket, it wouldn't charge at all. Now that the battery has drained, I can't even get the thing to power on.

Things I've tried:

  • Opening up the laptop and replacing the DC-in jack. I immediately thought this was the problem as it seemed like the jack was loose, but it didn't solve the problem. I even tried replacing it twice with two different jacks on the off chance I'd botched it the first time.
  • Using a different AC adapter
  • Pulling the battery out and trying to power it on directly from the AC
  • Doing a hard reset

...all to no avail.

Does anyone have any idea what the problem could be? Short of cutting my losses and salvaging the hard drives I have no idea what to do.

Just to clarify, when I hit the power button everything lights up and the computer starts whirring for half a second, then it goes dead again, as though it's not plugged in. The AC light does not come on when I plug it in.

 

Thanks in advance!! beerchug.gif

- L



BC AdBot (Login to Remove)

 


m

#2 Citizen_WD

Citizen_WD

    Authorized Western Digital Rep


  • Members
  • 138 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:53 AM

Posted 17 April 2015 - 09:58 AM

Hello sweet-yeezus, 
 
You have already tried most of the troubleshooting that I thought of while reading your post. However - you can try to source the same charged up battery, from another laptop and see if it will work. Than you can backup all of your important data and proceed with the troubleshooting. 
 
If you are sure that all of the repairs were done properly and the laptop still dosen't respond to external power - it's likely that you've damaged other components from multiple  jiggling. If your laptop is working properly with a charged battery - it's best to take it to a speciallist, who can check all of the solder points and internal connections. My bet is that it's a loose component, and really hope that the case isn't a more serious one.
 
Hope this was helpful, Citizen_WD

Edited by hamluis, 18 April 2015 - 03:05 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users