Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Acer touchscreen has stopped working after update


  • Please log in to reply
7 replies to this topic

#1 HuleoAmadaeus

HuleoAmadaeus

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mississippi
  • Local time:04:30 PM

Posted 13 April 2015 - 08:26 AM

I have read that HP also has this problem, but I have only found mixed results of success. it happened sometime after March 22nd 2015. I believe an update removed the "HID-compliant touch screen" device from device manager, it has just disappeared entirely, i have tried working with usb generic device's drivers, its not listed in there, i have tried enabling the service for HID compliant device, no luck. I have tried going to acer's website for the driver for that model, it is not there. its like they stopped supporting it. help guys, i'm stuck. i need either that driver, a third-party touchscreen software, or something short of restoring it to earlier state.



BC AdBot (Login to Remove)

 


m

#2 FreeBooter

FreeBooter

  • Members
  • 3,134 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:12:30 AM

Posted 13 April 2015 - 12:28 PM

Open Device Manager and uninstall current monitor driver then reconnect your monitor to install Microsoft monitor generic driver.



Share your knowledge. Its a way to achieve immortality.
- Dalai Lama

 

 


#3 HuleoAmadaeus

HuleoAmadaeus
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mississippi
  • Local time:04:30 PM

Posted 13 April 2015 - 05:43 PM

no luck, i found out that when the touchscreen is touched, the ripple effect graphic is still shown, but the computer otherwise does not accept commands.



#4 FreeBooter

FreeBooter

  • Members
  • 3,134 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:12:30 AM

Posted 14 April 2015 - 03:41 AM

Visit monitor or computer manufacturer website to download/install monitor driver if there is one. Also reset monitor setting to default settings.



Share your knowledge. Its a way to achieve immortality.
- Dalai Lama

 

 


#5 HuleoAmadaeus

HuleoAmadaeus
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mississippi
  • Local time:04:30 PM

Posted 14 April 2015 - 11:08 PM

k, the acer website isnt helping, I'm not sure of the monitor manufacturer, so i havent found that yet, but how do i reset the monitor settings? cuz either i found it and it didnt work, or i didnt find it.



#6 justinkemp99

justinkemp99

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:03:00 AM

Posted 15 April 2015 - 02:10 AM

I had the same issue; My touch screen had stopped working a few times before. After some online research I have come across This solution Please perform following steps


Step 1. Press Windows+X

 

Step 2.  Open Device Manager

 

Step 3.  Open Human Interface Devices

 

Step 4. HID - Compliant Touch screen

 

Step 5. Right Click to Disable

 

Step 6. Right Click again to Enable

 

Additional Steps if you use Google Chrome:

 

1. Open Chrome and in the Address Bar, type: "Chroms://flags"

 

2.  then Press Ctrl+F and search the word "touch"

 

3. Change Settings from Automatic TO Enable on "Enable touch events" (and if you want, enabling "Touch Optimized UI" will make chrome tabs larger to make it easier to use touchscreen and click the right thing... fingers and stylus's tend to be bigger than the mouse on your screen so you may like the bigger tabs...)

 

4. Restart Chrome .



#7 HuleoAmadaeus

HuleoAmadaeus
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mississippi
  • Local time:04:30 PM

Posted 15 April 2015 - 11:03 AM

I had the same issue; My touch screen had stopped working a few times before. After some online research I have come across This solution Please perform following steps

Step 1. Press Windows+X

 

Step 2.  Open Device Manager

 

Step 3.  Open Human Interface Devices

 

Step 4. HID - Compliant Touch screen

 

Step 5. Right Click to Disable

 

Step 6. Right Click again to Enable

 

Additional Steps if you use Google Chrome:

 

1. Open Chrome and in the Address Bar, type: "Chroms://flags"

 

2.  then Press Ctrl+F and search the word "touch"

 

3. Change Settings from Automatic TO Enable on "Enable touch events" (and if you want, enabling "Touch Optimized UI" will make chrome tabs larger to make it easier to use touchscreen and click the right thing... fingers and stylus's tend to be bigger than the mouse on your screen so you may like the bigger tabs...)

 

4. Restart Chrome .

 

 

as i stated before, HID-compliant touch screen is literally missing from the device manager, so this fix will not work.



#8 HuleoAmadaeus

HuleoAmadaeus
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mississippi
  • Local time:04:30 PM

Posted 28 April 2015 - 08:38 PM

After lots and lots of troubleshooting, Acer has been alerted for a warranty claim. I doubt we will ever know at this point what went wrong.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users