Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Secure Connection Failed" (Mozilla Firefox)


  • This topic is locked This topic is locked
14 replies to this topic

#1 4honeys

4honeys

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:29 AM

Posted 08 April 2015 - 04:53 PM

I have noticed after the recent update to Firefox Version 37.0.1 I am getting this message when trying to log into some sites.

Secure Connection Failed

The connection to web4.secureinternetbank.com was interrupted while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

I also tried restarting the computer. I cleared all history, cookies, and cache as well, there was no change, still having the problem. I tried going through IE and everything worked fine, so the problem seems to be with FF only. I tried on a different laptop in the house using FF, same issue. My fiance logged into the website from his work computer at work with no issues. I did it in safe mode with addons disabled, no change. I also just noticed when trying to go to the bank website, next to the web address I have the Triangle icon with the ! in the center. I clicked on it and can screen shot what it says if you need to see that.


What do I need to do to correct this issue. I have not had any problems in the past, it just seems to be an issue since the current update. Any help would be greatly appreciated.

Thanks!!


Edited by hamluis, 13 February 2017 - 08:57 AM.
Moved from Win 7 to Web Browsing/Email - Hamluis.


BC AdBot (Login to Remove)

 


#2 buddy215

buddy215

  • Moderator
  • 13,313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:03:29 AM

Posted 08 April 2015 - 05:51 PM

I think you can use the info in the link below to access that website.

Yesterday I could open mail.biz.rr.com but today I cannot open it. What do I do? | Firefox Support Forum | Mozilla Support

 

QUOTE:

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the domain to this pref. If there are already websites in this list then add a comma and the new the domain (no spaces).

  • security.tls.insecure_fallback_hosts = mail.biz.rr.com  (change this to the address for your bank)

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#3 4honeys

4honeys
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:29 AM

Posted 08 April 2015 - 05:58 PM

I'm not sure if it matters or not but I downgraded to Firefox version 36.0.4, went to attempt to log into the website I have been having the issue with and it worked..HOWEVER of course FF updated back automatically to the most current version 37.0.1 as soon as I closed down FF and restarted it so I am back to the same issue.



#4 coxchris

coxchris

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Atwater
  • Local time:01:29 AM

Posted 08 April 2015 - 06:00 PM

Please Upload the screen shot to this thread or any image sharing websites (photobucket.com, etc)

 

From your description it sounds like the bank has change the certificate to Firefox only and the only way to fix it is to call the bank and have them to reissue the certificate. or Simply stating that with the recent change to Firefox 37.0.1 I am getting a not secure web connection and show the screen shot. Since this is a financial institution I would not rely on Firefox to do your banking until they have correct the issue.

 

We can troubleshoot Firefox 

 

Did you notice anything after the update beside this? 


AA in Computer Networking Technology

BS in Information Technology 

Comptia A+, Project+, L+

Renewable:  N+,S+

CIW Web Design Specialist, JavaScript Specialist,  Database Design Specialist 

LPIC-1, SUSE 


#5 4honeys

4honeys
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:29 AM

Posted 08 April 2015 - 06:03 PM

As far as I can tell that is the only site I have had any issues with so far. Everything else seems to work fine with no problems. What would you like a screenshot of?



#6 buddy215

buddy215

  • Moderator
  • 13,313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:03:29 AM

Posted 08 April 2015 - 06:12 PM

You can stop the auto updating if you would rather use an older version than try the fix I mentioned.


“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#7 4honeys

4honeys
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:29 AM

Posted 08 April 2015 - 06:15 PM

That is actually what I just got done doing. I turned off auto update, reverted back to version 36 of FF and I can use the website just fine now.



#8 coxchris

coxchris

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Atwater
  • Local time:01:29 AM

Posted 08 April 2015 - 06:18 PM

I would go with buddy215 suggestion and let the bank know about this issue if you want to do that. Its looks like Firefox fix a error and the bank hasn't have time to catch up. 


AA in Computer Networking Technology

BS in Information Technology 

Comptia A+, Project+, L+

Renewable:  N+,S+

CIW Web Design Specialist, JavaScript Specialist,  Database Design Specialist 

LPIC-1, SUSE 


#9 4honeys

4honeys
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:29 AM

Posted 08 April 2015 - 06:20 PM

I know that the bank is in the process of updating their website so that could maybe be what the issue is since they are still in the middle of building it possibly? As we have never had an issue till just a few days ago when FF updated.



#10 coxchris

coxchris

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Atwater
  • Local time:01:29 AM

Posted 08 April 2015 - 06:39 PM

It can or it can be that version of FF. They introduce a new feature in 37.0  and they found a security hole. They release the fix 37.0.1 was to disable that new feature. I would wait untill they fix that version 37.0 or wait until the bank has completed the update but its looks like that version has a flaw. Reference FF 37 and 37.0.1:  http://www.eweek.com/security/mozilla-dials-back-on-firefox-opportunistic-encryption.html


AA in Computer Networking Technology

BS in Information Technology 

Comptia A+, Project+, L+

Renewable:  N+,S+

CIW Web Design Specialist, JavaScript Specialist,  Database Design Specialist 

LPIC-1, SUSE 


#11 sceadugenga

sceadugenga

  • Members
  • 99 posts
  • OFFLINE
  •  
  • Local time:03:29 PM

Posted 13 February 2017 - 12:23 AM

I have an identical problem with GMail, I can log into the My Account page but go no further.

And we all know that trying to contact someone at Google is not an option.

Works on my iPad fine, same wifi.



#12 sceadugenga

sceadugenga

  • Members
  • 99 posts
  • OFFLINE
  •  
  • Local time:03:29 PM

Posted 13 February 2017 - 12:57 AM

I closed the modem firewalls and it opened immediately



#13 sceadugenga

sceadugenga

  • Members
  • 99 posts
  • OFFLINE
  •  
  • Local time:03:29 PM

Posted 13 February 2017 - 05:22 AM

OK, gets stranger now, I lost Gmail again, reset the firewalls and it's working.



#14 sceadugenga

sceadugenga

  • Members
  • 99 posts
  • OFFLINE
  •  
  • Local time:03:29 PM

Posted 13 February 2017 - 08:04 AM

Have to reset them every hour or so.

 

 

Attached Files



#15 hamluis

hamluis

    Moderator


  • Moderator
  • 56,276 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:29 AM

Posted 13 February 2017 - 08:44 AM

FWIW:  I believe that the latest version of Firefox is 51, https://support.mozilla.org/t5/Install-and-Update/Find-what-version-of-Firefox-you-are-using/ta-p/1864

 

The Secure Connection Failed message is something that I routinely get when trying to click on certain Google links to websites.  It seems to be a known Firefox bug,  See Here.

 

I just ignore it and either look at the cached entry or copy the URL and paste it in.

 

This topic is closed since it is dated and initiated by a different OP.  If you have any further issues of this type...please start your own topic where they can be properly addressed.  Thank you:).

 

Louis


Edited by hamluis, 13 February 2017 - 08:47 AM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users