Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How do I automatically ALLOW opening link in email, FIREFOX


  • Please log in to reply
11 replies to this topic

#1 cafejose

cafejose

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 06 April 2015 - 12:32 PM

One of the email senders gives me links to posts on a website, and when I click on the link in the email message, Firefox always interrupts reaching the page and gives a gray bar at the top with an "Allow" button and a small x next to it.  I click on "Allow" and I can visit the page.  I do not want this to be necessary.  I want to see the page linked from the email message and not need to click the Allow button.  How do I do this?  Where in what options of Firefox do I use?  This has been happening for more than two years, always with up-to-date firefox and Windows.

 

 

Toshiba Satellite laptop

Windows Vista

Firefoxes Browser for the last two years and currently version 37.



BC AdBot (Login to Remove)

 


#2 RolandJS

RolandJS

  • Members
  • 4,533 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:01:41 PM

Posted 06 April 2015 - 12:40 PM

Do you have any addons or plugins that provide security or monitoring?  If not, you'll have to find an XPI that will bypass FF's built-in allow/disallow.


"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#3 cafejose

cafejose
  • Topic Starter

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 06 April 2015 - 02:20 PM

One of the Adblocks  (not remember which, -Pro, or -Plus or -super) is installed.  I also often use other browsers either SlimJet or Google Chrome with an Adblock-  installed, but the "Allow" interruption does not occur with those chrome based browsers.  I do not know what XPI means.



#4 RolandJS

RolandJS

  • Members
  • 4,533 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:01:41 PM

Posted 06 April 2015 - 02:50 PM

XPI is the extension of add-ons and plug-ins installed within FF.  I've been using FEBE to backup these things for so long that I forgot not everyone recognizes XPI files  :)


"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#5 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 6,032 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:41 AM

Posted 06 April 2015 - 04:33 PM

Is firefox set as the default browser  ?

 

(menu, options,general, ....the very first item will be startup...check the box.)

 

Once you have done this... go to menu > options > advanced > general > warn me when websites try to redirect or reload the page. Uncheck the box.

 

 

 

 

edited: Spelling


Edited by Condobloke, 06 April 2015 - 04:39 PM.

Condobloke ...Outback Australian  fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

 GcnI1aH.jpg

 

 


#6 cafejose

cafejose
  • Topic Starter

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 06 April 2015 - 07:13 PM

I still do not know what to do with XPI or where to find it.  (I have not yet tried clicking those hyperlinks from emails with Adblocks disabled.)

 

Firefox is not the default browser.  I keep Internet Explorer as the default because that's what Windows expects.  This would now seem to be a choice to make; or is it?



#7 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 6,032 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:41 AM

Posted 06 April 2015 - 08:00 PM

.. go to menu > options > advanced > general > warn me when websites try to redirect or reload the page. Uncheck the box.


Condobloke ...Outback Australian  fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

 GcnI1aH.jpg

 

 


#8 cafejose

cafejose
  • Topic Starter

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 06 April 2015 - 11:56 PM

.. go to menu > options > advanced > general > warn me when websites try to redirect or reload the page. Uncheck the box.

I just tried testing that on an alternate computer, and so far, that option seems to work...  next is to test it on the affected computer.



#9 RolandJS

RolandJS

  • Members
  • 4,533 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:01:41 PM

Posted 07 April 2015 - 09:48 AM

"...Firefox is not the default browser.  I keep Internet Explorer as the default because that's what Windows expects..."

Ahhh, ok, I did not know IE was your default browser; I thought FF was.  Disregard my previous XPI comments, they do not apply.


"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#10 cafejose

cafejose
  • Topic Starter

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 08 April 2015 - 01:00 AM



.. go to menu > options > advanced > general > warn me when websites try to redirect or reload the page. Uncheck the box.

No good.  Still fail!  Continuing to need to click the Allow button.

Yes it works (as long as I remember to uncheck that option).


Edited by cafejose, 08 April 2015 - 01:05 AM.


#11 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:07:41 PM

Posted 12 April 2015 - 07:03 PM

One of the easier ways to get your computer infected with malware is to open links in e-mails willy-nilly. This is a fairly important feature in a browser in that it allows you to have second thoughts 'Do I really mean to open that link?'.

 

No argument, it's your computer and you can set it to run the way you want it to. My advice would be to leave this feature alone and accept the relatively minor inconvenience.

 

Chris Cosgrove



#12 cafejose

cafejose
  • Topic Starter

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 13 April 2015 - 12:54 PM

One of the easier ways to get your computer infected with malware is to open links in e-mails willy-nilly. This is a fairly important feature in a browser in that it allows you to have second thoughts 'Do I really mean to open that link?'.

 

No argument, it's your computer and you can set it to run the way you want it to. My advice would be to leave this feature alone and accept the relatively minor inconvenience.

 

Chris Cosgrove

Another way to deal with this is to turn off the blocking while I use the particular email account, and then put back the blocking when I'm done.  I tried setting an exception for the links but Firefox does not seem to respond to the set exceptions and still blocks the link with the Allow button interruption.  (Warn when site tries to redirect...)


Edited by cafejose, 13 April 2015 - 12:55 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users