Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Missing Icons and Files


  • Please log in to reply
17 replies to this topic

#1 addonexus123

addonexus123

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 01 April 2015 - 07:40 PM

Earlier today i went afk from my computer and when i returned alot of my desktop shortcuts had disappeared, not only this but my taskbar was missing shortcuts and my libraries had all been emptied. I have out my computer into safe mode and performed a virus/malware scan with both malwarebytes and microsoft security essentials, both turned out negative for viruses, and i tried using an unhide tool i found in this thread. http://www.bleepingcomputer.com/forums/t/405109/unhideexe-a-introduction-as-to-what-this-program-does/ but this was also unsuccessful. Is there any suggestions as to what i should do, thanks in advance.


Edited by Orange Blossom, 01 April 2015 - 08:41 PM.
Moved to AII from Windows 7. ~ OB


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 01 April 2015 - 08:27 PM

Hello, and Welcome

 

Do you have the ability to do a System Restore to a date just previous to the problem?



#3 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 06:40 AM

My first response to seeing my icons disappear was to perform a virus scan, nothing came up so i restored it to the 30th of last month when i knew it was working. After this me and a friend tried a few things that he could think of as he did computing in college and knew the basic troubleshooting but we had no luck. Thats when i tried what i put in my first post.



#4 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 02 April 2015 - 07:29 AM

I am not sure about the missing files in libraries but do your missing desktop and Taskbar icons appear when logging into a new user account?

#5 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 07:31 AM

No, i created a new user to test that and unfortunately i only had the same icons as on my main account



#6 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 02 April 2015 - 08:00 AM

Have you tried doing sfc /scannow at an elevated command prompt? Type CMD in the search box. Right click > Run as Administrator. This will search for any missing or corrupt system files.



#7 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 08:38 AM

My friend helped me do some things whilst i screen shared, the commands he tried where sfc/ scannow, gpupdate /force and a full disk error check. 



#8 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 02 April 2015 - 09:02 AM

Did your friend say if there were any errors after sfc /scannow or the disk check?

 

Edit: Other than the missing icons and libraries, is the computer running fine? Did your friend do any malware scans on the computer?


Edited by JohnC_21, 02 April 2015 - 09:17 AM.


#9 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 09:24 AM

He found nothing wrong with any of the scans, he didn't do a malware scan as malwarebytes and Microsoft security essentials didn't pick up anything.

Apart from the icons and libraries the computer is still useable, i noticed that all my gamesaves etc have all been deleted but the games are fully playable from the beginning and when i try to play  League of Legends the program shuts itself down. This has been the only program i noticed this with  however



#10 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 02 April 2015 - 09:46 AM

I would do a scan with the following in order but I do not think you would get your libraries back.

 

Adwcleaner

 

Junkware Remover

 

Run Rkill, do not reboot then do a scan with Malwarebytes

 

Hitman Pro

 

Post the logs



#11 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 12:09 PM

The malwarebytes came back negative but it did take a while. 

I'm unsure how to link the logs as attachment.



#12 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 02 April 2015 - 12:25 PM

You can copy and paste them into your next post unless they also came up clean.

 

Libraries are only placeholders for the actual files so you should still have your files available.

 

https://technet.microsoft.com/en-us/library/ee449413%28v=ws.10%29.aspx

 

 

What happens to my files when I remove a folder location from a Library?

When you remove a folder location from a Library, you remove only the Library view of that folder. Removing a folder location from a Library doesn’t actually delete the folder or its files.

What happens to my files when I delete a Library?

When you delete a Library, you only remove the Library from the Navigations pane of Windows Explorer. Deleting a Library doesn’t actually delete the folders that it aggregates.

 

 

As far as the missing icons on the Taskbar, see if rebuilding the icon cache helps. This is usually for icons that do not display properly, not ones that have gone missing. When you say your icons are missing, is there a icon of a page where the icon used to be on the taskbar or are the icons completely gone?

 

k1WIJ.png



#13 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 01:14 PM

the icons have gone completely, the icons that are still there are layed out like they where before but there is now gaps where some went missing.

 

Rkill 2.7.0 by Lawrence Abrams (Grinler)
Copyright 2008-2015 BleepingComputer.com
More Information about Rkill can be found at this link:
 
Program started at: 04/02/2015 04:07:23 PM in x64 mode.
Windows Version: Windows 7 Home Premium Service Pack 1
 
Checking for Windows services to stop:
 
 * No malware services found to stop.
 
Checking for processes to terminate:
 
 * No malware processes found to kill.
 
Checking Registry for malware related settings:
 
 * No issues found in the Registry.
 
Resetting .EXE, .COM, & .BAT associations in the Windows Registry.
 
Performing miscellaneous checks:
 
 * No issues found.
 
Checking Windows Service Integrity: 
 
 * No issues found.
 
Searching for Missing Digital Signatures: 
 
 * No issues found.
 
Checking HOSTS File: 
 
 * No issues found.
 
Program finished at: 04/02/2015 04:08:32 PM
Execution time: 0 hours(s), 1 minute(s), and 8 seconds(s)
 
 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Junkware Removal Tool (JRT) by Thisisu
Version: 6.5.1 (04.02.2015:1)
OS: Windows 7 Home Premium x64
Ran by craig on 02/04/2015 at 16:03:51.51
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 
 
 
~~~ Services
 
 
 
~~~ Registry Values
 
 
 
~~~ Registry Keys
 
 
 
~~~ Files
 
 
 
~~~ Folders
 
 
 
~~~ Event Viewer Logs were cleared
 
 
 
 
 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Scan was completed on 02/04/2015 at 16:06:35.28
End of JRT log
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 
HitmanPro 3.7.9.240
www.hitmanpro.com
 
   Computer name . . . . : CRAIG-PC
   Windows . . . . . . . : 6.1.1.7601.X64/4
   User name . . . . . . : craig-PC\craig
   UAC . . . . . . . . . : Enabled
   License . . . . . . . : Free
 
   Scan date . . . . . . : 2015-04-02 18:01:00
   Scan mode . . . . . . : Normal
   Scan duration . . . . : 4m 1s
   Disk access mode  . . : Direct disk access (SRB)
   Cloud . . . . . . . . : Internet
   Reboot  . . . . . . . : No
 
   Threats . . . . . . . : 0
   Traces  . . . . . . . : 32
 
   Objects scanned . . . : 1,369,722
   Files scanned . . . . : 19,832
   Remnants scanned  . . : 269,435 files / 1,080,455 keys
 
Cookies _____________________________________________________________________
 
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:2o7.net
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:ad.360yield.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:ads.avocet.io
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:ads.creative-serving.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:ads.stickyadstv.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:adtech.de
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:adtechus.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:advertising.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:at.atwola.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:bs.serving-sys.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:casalemedia.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:doubleclick.net
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:fastclick.net
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:googleadservices.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:media6degrees.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:mediaplex.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:pcworldcommunication.122.2o7.net
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:revsci.net
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:ru4.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:serving-sys.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:smartadserver.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:tribalfusion.com
   C:\Users\craig\AppData\Local\Google\Chrome\User Data\Default\Cookies:www.googleadservices.com
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\0KWACZ79.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\CUQYZ5CP.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\JUUUK5YJ.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\PUYULKZB.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\RV9QP2ZB.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\U18HMSN4.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\UD5TJG77.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\UUV2UZ1E.txt
   C:\Users\craig\AppData\Roaming\Microsoft\Windows\Cookies\VV4NIB5D.txt
 
 
 
 
# AdwCleaner v4.200 - Logfile created 02/04/2015 at 15:55:26
# Updated 29/03/2015 by Xplode
# Database : 2015-03-29.1 [Server]
# Operating system : Windows 7 Home Premium Service Pack 1 (x64)
# Username : craig - CRAIG-PC
# Running from : C:\Users\craig\Documents\Downloads\adwcleaner_4.200.exe
# Option : Scan
 
***** [ Services ] *****
 
 
***** [ Files / Folders ] *****
 
File Found : C:\END
Folder Found : C:\ProgramData\apn
 
***** [ Scheduled tasks ] *****
 
 
***** [ Shortcuts ] *****
 
 
***** [ Registry ] *****
 
Data Found : HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyOverride] - *.local
 
***** [ Web browsers ] *****
 
-\\ Internet Explorer v11.0.9600.17689
 
 
-\\ Google Chrome v41.0.2272.101
 
 
*************************
 
AdwCleaner[R0].txt - [789 bytes] - [02/04/2015 15:55:26]
 
########## EOF - C:\AdwCleaner\AdwCleaner[R0].txt - [847 bytes] ##########
 


#14 JohnC_21

JohnC_21

  • Members
  • 24,636 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:23 PM

Posted 02 April 2015 - 01:26 PM

The computer looks clean. I would do a scan with TDSS killer and see if that detects anything. If not, then the problem may have resulted from some kind of file corruption.

 

I would run the following tests.

 

Download Seatools for Windows for checking your hard drive and do the short test. If it passes, do the long test.

 

SeaTools for Windows User Guide - Seagate

 

Download the iso of Memtest+, burn it to disk by right clicking and selecting Burn Disk Image, and run a test on your RAM. Let it run for at least 6 passes. Overnight would be best while you are sleeping.


Edited by JohnC_21, 02 April 2015 - 01:27 PM.


#15 addonexus123

addonexus123
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:01:23 AM

Posted 02 April 2015 - 03:06 PM

I know what caused this now, a little to late though :/ 

http://forum.botoflegends.com/topic/57215-official-information-regarding-deleted-files/

i now cant restore any data my restore points where deleted earlier. If you know any way to restore restore points (pretty sure is impossible) or any other methods of recovering data it would be appreciated. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users