Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

processor maxing out intermittantly


  • Please log in to reply
18 replies to this topic

#1 godzilla1347

godzilla1347

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 30 March 2015 - 02:24 AM

I'm running a dell system with 2 GB of memory. All of a sudden I notice in Task Manager that the processor is using 1.90 GB and that little circle keeps turning, meaning the system is working but nothing is happening.  Everything stalls at this point. Eventually, it goes back to normal and everything works as usual but it's very strange that this happens in the first place--even if I'm not loading new programs at the time.  I guess I can't get any more out of this processor without reclocking it (and I don't want to fool around with that). I just don't understand what's happening or is anything I can do about it given the limitations of this processor memory.

 



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,891 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:19 PM

Posted 01 April 2015 - 05:34 PM

It is possible that some internal process like defrag or a security scan has just decided to start running - both of these use a fair amount of memory.  But your real problem is that you only have 2GB of RAM which most people would consider to be at the bottom end of what you need to run Vista. Any chance of finding another 2GB if you have a spare slot?

 

Overclocking would not solve your problem in any case, all that does is make your processor run faster (and hotter). It does not provide any extra capacity.

 

Chris Cosgrove



#3 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 01 April 2015 - 05:44 PM

Thanks, I can purchase another 2 GB and I'm sure you are correct. I notice that when the system hangs, Task Manager's Processor performance tab idles around 1.93 MB and once it drops down to about 1.5, everything runs normally, so that further validates what you are saying.

 

It's amazing how quickly these systems get "old."  I remember being on the XP thread for some time and loved XP, but for security reasons, had to move on. This Vista computer was given to me and I'm sure it was a "hot shot" computer in its day but clocks move faster with computers and it's at that point where it is close to maxing out. 2 more GB of memory will throw it a life saver but I'm probably going to have to think a new computer sometime this year after Windows 10 has proven itself.



#4 Willy22

Willy22

  • Members
  • 945 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Planet Earth
  • Local time:12:19 PM

Posted 01 April 2015 - 06:27 PM

- Do you use Chrome ? Then perhaps this thread offers a solution:

http://www.bleepingcomputer.com/forums/t/571227/computer-runs-very-slow-for-hour-every-morning/



#5 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 02 April 2015 - 08:00 AM

Thanks, I have Chrome but rarely use it as Firefox is my default browswer. I never use IE as it is as slow as it gets. I suspect I simply need to buy more memory as has been suggested.



#6 Willy22

Willy22

  • Members
  • 945 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Planet Earth
  • Local time:12:19 PM

Posted 02 April 2015 - 08:17 AM

- You're missing the point. Chrome has installed a job in Task Scheduler and then it will run the Auto-Update everytime you start your system. No matter whether you use it or not.

- You can change when Chrome will run by changing some settings in the Task Scheduler job. Instead of running every day you can set Auto Update to be run every week or only every month. Every time you install a new version of Chrome you need to change that setting.

- Or better: If you don't use it then remove Chrome.

- Install PcWinTech Cleanmem. It reduces memory usage every 15 minutes and that increases overall system performance. And let it clean the file cache as well. It postpones the moment you need to buy more memory.

- Keep us posted. I am curious whether or not Chrome is slowing down your system.



#7 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 02 April 2015 - 03:42 PM

Interesting! The thing about computers is "you don't know what you don't know." I had no idea that Chrome did this. I am running Ccleaner to get rid of garbage piling up. Is PcWintech cleanmem a similar type of program?

 

The other thing is where do I find the Task Scheduler. I went to Chrome settings and didn't find it. I then went to advance settings and didn't find it. Obviously, it's in front of my nose somewhere but I can't locate it.



#8 Willy22

Willy22

  • Members
  • 945 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Planet Earth
  • Local time:12:19 PM

Posted 02 April 2015 - 04:31 PM

- Cleanmem is a memory usage reduction program.

- Task Scheduler (TS): http://www.dummies.com/how-to/content/how-to-open-windows-task-scheduler.html. I hope Chrome allows you to make changes.

- TS is powerful but not too simple. It took me also some time to learn on how to make changes. Just a matter of "trial & error".



#9 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 02 April 2015 - 05:22 PM

Thanks. So what you're saying is that this is a Windows adjustment but somehow you then have to make an adjustment to it in Chrome?



#10 Willy22

Willy22

  • Members
  • 945 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Planet Earth
  • Local time:12:19 PM

Posted 02 April 2015 - 05:53 PM

- Task Scheduler (TS) is a feature/part of Windows and one of the programs that uses it is Chrome (upon start up). Open TS, find the task/job Chrome added and change when the task/job is run (set it to run e.g. every week or month). GOOGLE it, for more instructions.

 

E.g. http://www.wikihow.com/Use-Task-Scheduler-(in-Vista)


Edited by Willy22, 02 April 2015 - 05:54 PM.


#11 marcoose777

marcoose777

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:19 PM

Posted 03 April 2015 - 05:16 AM

I have a work laptop - dell latitude, and had a similar issue i.e. all cores at 25-30% with no applications running ? Wow. Anyhow had a rummage around processes, and checked dell forums for advice. For me updating all the firmware at dell's website and disabling Intel's rapid storage technology (RST IAStorMgrserv) at start up cured my issue and I'm now at 0-5% per cpu core with firefox running !!WTF. That may work for you =)

 

dell driver update UK : here

or begin here


Edited by marcoose777, 03 April 2015 - 06:04 AM.


#12 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,891 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:19 PM

Posted 03 April 2015 - 04:48 PM

When I made my first reply to this topic I wasn't aware you had Chrome installed, even if you don't use it much. I was informed by another topic on BC that if you have Chrome it attempts to keep certain services open, even if you have closed it, and that these can use quite a lot of memory.

 

I was also informed that the way to solve this problem is to go into Chrome's settings and change one of the advanced settings.

 

Click on the barred symbol in the top right corner and choose 'Settings'. Go to the bottom of the 'Settings' page that appears and select 'Advanced settings' and the page extends. About third or fourth item up from the bottom of the extension you will see an entry 'Allow Chrome to run services in the background' or similar wording and the default is 'Allow'. Untick this box and when you close Chrome these services will stop running.

 

Chris Cosgrove



#13 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 03 April 2015 - 05:19 PM

I just opened Chrome>settings>advanced settngs but I don't see any entries saying "Allow Chrome to run services in the background' or similar wording" unless you mean the entry under System that says "continue running background apps when Google Chrome is closed." Assume that is what you had meant and I had unticked that box. I'll now see if my system "hanging' intermittantly has stopped.  It is interesting that a browser would set up an invasive process like this to affect other browsers as well.



#14 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,891 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:19 PM

Posted 06 April 2015 - 04:22 PM

That is what I meant !  Unhappily I was working from memory and on a system that didn't have Chrome installed so I couldn't check before I opened my mouth.

 

Chris Cosgrove



#15 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:07:19 AM

Posted 06 April 2015 - 06:41 PM

Unfortunately, even after unticking that box, my system still hangs intermittantly. It is very annoying too. Once I get that "no response" message in the title bar and that infernal circle keeps spinning, I get nowhere. Then it just stops and all is fine. What a pain! I do notice that I can't bring up Task Manager when that happens but when it was up and this happened, I had noticed that the processor is using 1.92 GB of the 2 GB available.  I assume, then, that buying another 2 GB (that will max out this system) would probably resolve this issue.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users