Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Hosts File Issues


  • Please log in to reply
No replies to this topic

#1 brillo

brillo

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Location:Terrebonne, Oregon
  • Local time:02:10 PM

Posted 30 June 2006 - 03:09 PM

Go to "So here's the deal..." at the end if you're in a hurry. This first part is just history.

Several months ago, Randy Knobloch's (aka: Siljaline's) blurb, "Blocking Unwanted Parasites with a Hosts File," at http://www.mvps.org/winhelp2002/hosts.htm, convinced me to protect my new computer with a HOSTS file. I did as directed, "Click here to download the HOSTS file." Being an average kind of guy, I went immediately to check out my brand new HOSTS file.

I didn't read just before that, "Click here to view the HOSTS file in plain text form. (458 kb) (opens in IE)." I didn't read further down the page where it said, "[Important Notice - 2K/XP Users] In most cases a large HOSTS file (over 135 kb) tends to slow down the machine. This only occurs in W2000 and XP. Windows 98 and Windows ME are not affected." I certainly didn't put the two together.

And so, obviously, I also failed to read, "To resolve this issue (manually) open the "Services Editor"
Start | Run (type) "services.msc" (no quotes)
Scroll down to "DNS Client", Right-click and select: Properties
Click the drop-down arrow for "Startup type"
Select: Manual, click Apply/Ok and restart."

See the problem? (I added big red words in case you possibly missed it.) Right out of the box, the HOSTS file was almost four times the size that "tends to slow down a (XP/2K) machine" and, as I understand it, the HOSTS file continued to grow every time I went online. So my machine got slower and slower. Everything after pushing the "ON" button got very, very slow. Not all the time, interestingly, but most of the time. My read/write benchmarks (Everest) almost halved, latency doubled. The many system scanners, analyzers, monitors, evaluators I tried showed the problem, but none pointed me to the source, or I was not clever enough to see it in the data.

A few days ago, Scotty (Winpatrol) started barking and showing requested changes to the HOSTS file. I just denied them and went on, but it started me wondering so I took a look at the HOSTS file. I don't know what I was looking for. It was there, no blood squirting, no bones sticking out, so not a problem. I should have looked at how big it was. I need to mention I HAD Webroot Spy Sweeper and it also added items to the HOSTS file I believe. WSS had not been working well lately, just locked up when I tried to run a scan. Last night I finally got sufficiently p#!%^d (peeved) that I dumped WSS and the HOSTS file.

Guess what? Speed like I haven't seen for a long time. IMMEDIATELY.

Today, I reread "Blocking Unwanted Parasites with a Hosts File", said a few more choice words, put the HOSTS file back in and did the "DNS Client" thing. It runs Great. I think the HOSTS file just eventually became a monster in a tiny cage and it did the only thing it could, shut me down. Changing the "DNS Client" setting made the cage bigger, I guess.

So here's the deal, two questions:

A. My HjT log shows:
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer = http=127.0.0.1:9022
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = ;127.0.0.1;<local>
The first line is normal, the second one is new. What's up with this? Is the second line "overriding" the HOSTS file in the first line? I tried to delete the second line, no soap. It's back with the next startup, I think before that actually.
B. WSS is gone. How do I get it back?
Yes, I know it is not the greatest security program, but it has its charm. Webroot won't respond as the full-meal program came with the (Dell) machine, so it's Dell's responsibility. I think I saved the registration key somewhere, but haven't found it. And Dell? Well, I don't know about those guys lately. What's up over there? Toll calls to talk to a human? Encourage me please.

p.s., Suggestion to Siljaline, use big red words if you want people to read stuff.

Rob

Edited by brillo, 30 June 2006 - 03:38 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users