Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't ping in the LAN


  • Please log in to reply
25 replies to this topic

#1 Pantodynamos

Pantodynamos

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 22 March 2015 - 01:22 PM

Hello,

I was trying to ping another computer running Ubuntu in my LAN, from Windows, but for some reason instead of getting the local address like it used to, the ping utility came up with '218.93.250.18'. Similar results when pinging Windows from Ubuntu. I searched around the Internet, and saw http://www.linuxquestions.org/questions/linux-networking-3/url-in-browser-redirecting-to-another-adress-4175440450/; following the suggestions there I typed

 

nslookup www.sdfsdf.ba 8.8.8.8

into a command prompt. Here's the result:

 

Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    www.sdfsdf.ba.?a?t?d??a╡??
Address:  218.93.250.18
 

Similar results on Ubuntu. Note that .?a?t?d??a╡?? is probably a malformation of Παντοδύναμος, the 'Primary DNS suffix' on the Windows computer.

 

Could anybody help me understand

  1. what exactly this 'Primary DNS suffix' thingie is
  2. why can't I ping other computers properly across the LAN?


BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:12 PM

Posted 23 March 2015 - 01:12 PM

Could you post a screen shot of the ping you are doing?

I take from what you write you are pinging the local ip address not a domain name, correct?

 

Might run the command ipconfig /flushdns to make sure you don't have any flaky entries in your cache.  Than try your ping by ip address again.



#3 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:12 PM

Posted 23 March 2015 - 01:21 PM

BTW there is no www.sdfsdf.ba

.ba is for Bosnia and Herzegovina

 

C:\Users\>nslookup www.sdfsdf.ba 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

*** google-public-dns-a.google.com can't find www.sdfsdf.ba: Non-existent domain

Are you running your own dns server?



#4 Pantodynamos

Pantodynamos
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 23 March 2015 - 01:43 PM

Voilà:Attached File  bleep.jpg   49.22KB   0 downloads

Taken after executing ipconfig /flushdns

Yes, cardamom is the name of the Ubuntu computer, not a domain name. It used to work perfectly before.

And I am aware that www.sdfsdf.ba is non-existent; I don't know why I'm getting such a result, I'm not running my own DNS server.



#5 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:12 PM

Posted 23 March 2015 - 02:02 PM

OK.  Lets see the results of a ipconfig /all



#6 Pantodynamos

Pantodynamos
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 24 March 2015 - 06:13 AM

 

C:\Users\Admin>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Pantodynamos
   Primary Dns Suffix  . . . . . . . : πα?τ?δ??αµ??
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : πα?τ?δ??αµ??

Wireless LAN adapter Wireless Network Connection 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
   Physical Address. . . . . . . . . : 00-1B-B1-AD-C7-47
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Bluetooth Network Connection 4:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
#4
   Physical Address. . . . . . . . . : 00-0B-6B-65-3F-5D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom 802.11n Network Adapter
   Physical Address. . . . . . . . . : 00-1B-B1-AD-C7-47
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::3945:d6e4:e33c:86dd%17(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.8(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 23 March 2015 1:01:24 AM
   Lease Expires . . . . . . . . . . : 25 March 2015 4:31:04 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 419437489
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-83-EB-7C-E8-11-32-3D-C5-B6

   DNS Servers . . . . . . . . . . . : 120.138.96.18
                                       120.138.98.18
                                       192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Marvell Yukon 88E8040 Family PCI-E Fast E
thernet Controller
   Physical Address. . . . . . . . . : E8-11-32-3D-C5-B6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 22:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:18d2:ac5:3f57:fef7(Prefe
rred)
   Link-local IPv6 Address . . . . . : fe80::18d2:ac5:3f57:fef7%34(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{6748A505-8CE3-4DC7-BCC3-DCD91471E052}:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.8%38(Preferred)
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : 120.138.96.18
                                       120.138.98.18
                                       192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{B98359AC-BE1B-42B4-939C-A08A85B7ABE1}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{2BD3BBA3-D7BF-4B52-A64C-1B4E31EAE31C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #6
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{5F5D29FA-F55D-4DD3-832A-A64808D47839}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #7
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
 



#7 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:12 PM

Posted 24 March 2015 - 12:08 PM

Your name servers check out as OK and valid.

 

Go into your tcp/ip properties/ ipv4/advanced button/dns tab and remove any listed dns suffix's.

Go here to run the tcp/ip fix

https://support.microsoft.com/en-us/kb/299357#LetMeFixItMyselfAlways



#8 Pantodynamos

Pantodynamos
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 26 March 2015 - 01:11 AM

I ran the fix, no change.

However, during an internet connectivity problem, I managed to ping 'cardamom' successfully. Yet when the problem was resolved, and everything in the LAN had internet access once again, I still couldn't ping properly.



#9 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:12 AM

Posted 26 March 2015 - 09:34 AM

So if you don't have an internet connection it works? Interesting. You should test that. Just unplug, at the modem or the router, whatever wire your internet comes in on and ping. I assume you can ping with the IP address no matter what?


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#10 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:12 PM

Posted 26 March 2015 - 04:52 PM

Starting to sound like you are using someone else's registered domain name.

 

What does cardamom end with as in cardamom.?


Edited by Wand3r3r, 26 March 2015 - 04:54 PM.


#11 Pantodynamos

Pantodynamos
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 27 March 2015 - 01:13 AM

So if you don't have an internet connection it works? Interesting. You should test that. Just unplug, at the modem or the router, whatever wire your internet comes in on and ping. I assume you can ping with the IP address no matter what?

Yes, tested it; pinging works, albeit after a pause when I execute the command without an internet connection. Also, pinging by IP address definitely works.



#12 Pantodynamos

Pantodynamos
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 27 March 2015 - 01:17 AM

Starting to sound like you are using someone else's registered domain name.

 

What does cardamom end with as in cardamom.?

Sorry, I don't understand. Cardamom is the name of the ubuntu computer. I'm not really an expert, so may I ask if anything should come after cardamom? Before I noticed this problem, I could ping it by typing just 'ping cardamom', and that was that.



#13 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:12 PM

Posted 27 March 2015 - 09:54 AM

since we can't see what this is

Primary Dns Suffix  . . . . . . . : πα?τ?δ??αµ??

My thought was your cardamom was a dns or domain name.

 

Have you rebooted your router?

When you looked at the dns tab in tcp/ip properties did you see any suffix's listed?



#14 Pantodynamos

Pantodynamos
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 27 March 2015 - 02:54 PM

No, I saw no suffixes listed. And yes, I have restarted the router.



#15 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:12 AM

Posted 27 March 2015 - 03:07 PM

So your IPv4 properties, the DNS is set to obtain Auto? if not, try that and try the ping again.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users