Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

epson


  • Please log in to reply
6 replies to this topic

#1 trevorcork

trevorcork

  • Members
  • 346 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ireland
  • Local time:02:33 PM

Posted 16 March 2015 - 09:43 AM

epson expression home xp 305,i have been trying to add this printer to vista but it wont install,i am using the cd that came with it but it gets stuck on final screen checkin connection from laptop to printer?



BC AdBot (Login to Remove)

 


m

#2 trevorcork

trevorcork
  • Topic Starter

  • Members
  • 346 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ireland
  • Local time:02:33 PM

Posted 16 March 2015 - 10:46 AM

i can install the printer on another windows 7 machine and i can install a brother priner on the lapto but i cant install the printer on this laptop it says its installed but a communication error



#3 trevorcork

trevorcork
  • Topic Starter

  • Members
  • 346 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ireland
  • Local time:02:33 PM

Posted 16 March 2015 - 11:55 AM

drivers etc are correctly installed



#4 bludshot

bludshot

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:02:33 PM

Posted 16 March 2015 - 04:29 PM

How is the Vista computer connected to the printer? USB? Network?



#5 trevorcork

trevorcork
  • Topic Starter

  • Members
  • 346 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ireland
  • Local time:02:33 PM

Posted 16 March 2015 - 05:21 PM

its connected with the usb cable,i thought it might be the usb cable so i tried another cable,i uninstalled everything then re installed it again i done that a dew times,it would copy and scan but wouldnt print at all, mayb its an issue with vista



#6 bludshot

bludshot

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:02:33 PM

Posted 16 March 2015 - 05:39 PM

What I would do is use the latest driver from here: http://www.epson.eu/ix/en/viewcon/corporatesite/products/mainunits/support/11536/

 

Then, do not connect the printer with the usb cable at all, instead, add the printer as a network printer. If you haven't set that up on the printer yet, it should be fairly easy to connect your printer to your router, it even has wifi. I have dealt with pretty much the exact same situation where a computer could not add a printer via USB (the driver would install but it would never connect to the printer at the end of the driver install), but could add the exact same printer as a network printer.


Edited by bludshot, 16 March 2015 - 05:39 PM.


#7 trevorcork

trevorcork
  • Topic Starter

  • Members
  • 346 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ireland
  • Local time:02:33 PM

Posted 17 March 2015 - 05:08 AM

ok thanks ill try that,if that doesnt work would you think its a vista issue? vista is bad anyway






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users