Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Shared files and folders


  • Please log in to reply
16 replies to this topic

#1 gdnr

gdnr

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 March 2015 - 11:05 AM

Hi,

 

I am having problems turning off the Shared Files facility in 8.1. I do not need to share any information between computers, am not part of a domain, and don't need this facility, so would prefer that it was turned off.

 

I have had the same problem on another computer using Windows 7 Starter, and have posted details in the 7 Forum. The problems with Windows 7 computer now seem to be resolved (thanks to Aura and reast82) but I’ve tried to apply the same ‘fixes’ in Windows 8.1 and this is not yet resolved.

 

The fixes I have tried are these:

 

I've followed the path: Start > Computer Management > Shared Folders > right-click on any folder > clicked on ‘Stop sharing’, but I cannot change this option. It still says ‘Stop sharing’ and cannot be changed.

 

I tried another method using a command line  (Start > All Programs > Accessories > right click Command Prompt > run as Administrator) and typed:

 

 net share <sharename> /delete

 

 (the sharename being the name of the file you want to stop sharing). This didn’t work.

 

I have tried to disable network discovery and then tried to disable the shares, following this link:

 

http://windows.microsoft.com/en-us/windows/enable-disable-network-discovery#1TC=windows-7

 

While it was possible to select the option to turn off Network discovery and file and printer sharing, when I checked these options a few minutes later, they had reverted to ‘on’.

 

Are there any other locations where it is possible to globally change sharing options, or are there any other solutions?

 

I'm not quick at replying but thanks in advance for any help.



BC AdBot (Login to Remove)

 


m

#2 dicke

dicke

    Paraclete


  • Members
  • 2,176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:12:37 AM

Posted 13 March 2015 - 08:36 AM

Are you using an administrator account [username] to try to make these changes?


Stay well and surf safe [stay protected]

Dick E


#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 29,991 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:37 PM

Posted 13 March 2015 - 10:57 AM

 
Right-click the item you want to stop sharing, click Share with, and then click Nobody.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#4 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 13 March 2015 - 01:41 PM

Hi Paraclete and Arachibutyrophobia. Thanks for your replies.

 

I am using an Administrator account to make these changes.

 

I have tried right-clicking the files and under 'Share with' I do not have 'Nobody' as an option.

 

The option is 'Stop sharing' and I click on this to open another box, which gives the options to 'Stop sharing' or 'Change sharing permissions'.

 

This 'Stop sharing' option does not work; and the changing permissions option opens a list of people to share with (it only lists my other account on that computer. But here, I am unable to even change the sharing options for my other account; it is as if the screen function is disabled. Also if I go in via the other account, I have the same problems with shares). 

 

So this last box allows for more sharing but not stopping sharing. The result is that the original 'Stop sharing' option cannot be changed.

 

Just for clarity (hopefully) all of the files are 'shared' in this way (without my permission) but the  'Properties' of the folders suggest folders are not shared. (The files within them are, though.)

 

Thank you again for any thoughts!



#5 dicke

dicke

    Paraclete


  • Members
  • 2,176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:12:37 AM

Posted 13 March 2015 - 02:53 PM

Are any of these in 'protected' mode so that their attributes cannot be changed?


Stay well and surf safe [stay protected]

Dick E


#6 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 14 March 2015 - 06:29 PM

Thanks Dick E.  I do not know how to access 'protected' mode for files. Is this the same as 'Permissions'?



#7 dicke

dicke

    Paraclete


  • Members
  • 2,176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:12:37 AM

Posted 14 March 2015 - 07:52 PM

Check here for information;

https://www.google.com/webhp?ie=UTF-8&rct=j#q=protected+mode

I have received Word documents that are in that mode and have to change it so that editing is allowed.

Using an administrator account I wouldn't think that there are any files or folders that you cannot access. Unless, they are the property of another administrator and you do not have permission to play with them.

Another resource

http://nortonsafe.search.ask.com/web?q=protected%20mode%20for%20documents&o=15527&prt=NSBU&chn=retail&geo=US&ver=22&locale=en_US&tpr=111


Stay well and surf safe [stay protected]

Dick E


#8 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 15 March 2015 - 08:49 AM

Thank you. That is very interesting. The first link refers to protected mode for Internet Explorer. I'm using Firefox 36.0.1 so I don't think this will apply.

 

Some of the links via the second link refers to protection for individual documents to prevent editing. I've looked at the settings for my documents via:

 

Review > Protect document > Restrict permissions.

 

The 'Unresticted access' box is ticked on my docs so that they are open to editing, so I think this means their attributes can be changed. (For info, it also says that 'protected view' is also known as 'read mode' or restricted mode'.)

 

So I should still be able to select 'stop sharing' as these documents are not protected, but the 'stop sharing' function is still disabled.

 

Thank you I am learning!



#9 dc3

dc3

    Bleeping Treehugger


  • Members
  • 29,991 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:37 PM

Posted 15 March 2015 - 12:24 PM

See if this article sheds some light on this.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#10 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 15 March 2015 - 06:58 PM

Thank you. I looked at the link which led me to further search to this link:

 

http://superuser.com/questions/30668/how-to-run-firefox-in-protected-mode-i-e-at-low-integrity-level

 

- which says that Firefox does not run in 'Protected Mode, Low Integrity Level' (aka Low Mandatory Level)

 

- unlike IE and Google Chrome, which run in Medium Mandatory Level. (Though Firefox can be forced to do so, but does not react well.)

 

As far as I understand, 'low integrity' means that Firefox would have more 'rights' on my computer than a browser running on 'medium integrity', so my computer could be more at risk.

 

I am not clear on whether Firefox could influence the 'share' facility on files.

 

So I'm wondering if this is a red herring? The problem I have is with all of the indiviual files on my computer, which will not switch out of 'stop sharing' mode, and files are not locked for editing.

 

Thank you again for your help dc3.



#11 dicke

dicke

    Paraclete


  • Members
  • 2,176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:12:37 AM

Posted 15 March 2015 - 08:08 PM

[SWAG]

In W7 -> Network and Sharing Center -> Advanced Sharing Settings

I see    File and printer sharing

            File sharing connections

            Public folder sharing

might they be present in W8.1 and have some influence on your situation?

 

Dick


Stay well and surf safe [stay protected]

Dick E


#12 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,190 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Quebec, Canada
  • Local time:12:37 AM

Posted 15 March 2015 - 09:05 PM

Alright so I think it's time for me to jump in this thread for once post, to share what I found while digging around my own computer and one of my VM. I think that I need to post here since I was the one who helped gdnr with this issue under a Windows 7 computer, however I don't know if my reply will be helpful or not.

So when you go in Computer Management -> Shared Folders -> Shares, you can see that the C: drive is listed as the C$ share, and so will any other device you have connected to your computer. You'll also notice that the description for these shares is called "Default share", which means that this share is set by default on any Windows installation and there's a reason for that. When you right-click on one of these shares and try to stop it, you're being prompt with the following message:
 

This share was created for administrative purposes only. The share will reappear when the Server service is stopped and restarted or the computer is restarted. Are you sure you wish to stop sharing C$?


From there we can understand that it doesn't matter how many times you try to stop one of these shares, as soon as you'll restart your computer, they'll be enabled again. Hence why I brought my attention towards the "Server" service that was mentionned. Moving on to Computer Management -> Sservices and Applications -> Services, I found the service Server with the following description:
 

Supports file, print, and named-pipe sharing over the network for this computer. If this service is stopped, these functions will be unavailable. If this service is disabled, any services that explicitly depend on it will fail to start.


Basically, you could disable that service (set it to "Disabled" in the start-up type), and then it would allow you to stop once and for all these shares. But then I had a thought "What if that service was quite important and required?" So I took a look at the system components that depends on this service, and I found two, Computer Browser and HomeGroup Listener.

Gj9b1mF.png

Both of these are related to Windows being on a domain (like Active Directory) or a WorkGroup/HomeGroup. If your Windows system isn't configured to be on any of them, it's safe to disable that service without any consequences. Finally, I decided to test it myself, and it worked. I set the Server service start-up type to Disabled then I went back in the Shares panel and used the Stop sharing option on my C: drive to be greeted with an error message saying that the resource couldn't be accessed since the Server service wasn't running. Just to make sure it was working "right", I restarted my computer to find out that the Server service was still disabled and I still couldn't access the Share control panel, which means that my default share of the C: (C$) is now disabled.

Hence your solution would be to set the start-up type of the Server service to Disabled and restart your computer for it to take effect.

Edited by Aura., 15 March 2015 - 09:05 PM.

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#13 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 16 March 2015 - 04:01 PM

Dick and Aura, thank you for your replies.

 

When I open Network and Sharing Center in W8.1  > Advanced Sharing > Settings, there are options under the networks Private, Public and Guest to turn on/off network and sharing; and turn on/off file and printer sharing. I have tried setting each of these to ‘off’ but they revert to ‘on’.

 

But I think Aura has found a workaround for this problem (thank you!)

 

It doesn’t fix the initial problem but prevents it from being possible because ‘Share with...’ is no longer listed.  So ‘Stop sharing’ and ‘Share with...Nobody’ (or a Home group etc.) are not possible.  I can still access the internet, download emails and print wirelessly after disabling Services.

 

What I have on my computer is slightly different to your post, so I have included it here in case anyone is interested or has further comment:

 

Under Computer Management > Shared Folders > Shares, I see something slightly different. Under the ‘Description’ column I do not see only ‘Default Share’ but also ‘Remote Admin’ and ‘Remote IPC’.

 

Share name        Folder Path          Type                Client Connections          Description

 

ADMIN$              C:\WINDOWS        Windows             0                                     Remote Admin

C$                      C:\                           Windows             0                                     Default Share

IPC$                                                  Windows             0                                     Remote IPC

Print$                 C:\WINDOWS\system32\spool\drivers

 

When I right-click on any of these I do not get a message but get a drop-down menu that reads:

Open

All tasks

Refresh

Help

 

(There is one exception to this: when I right-click the IPC$ line the menu just says:

Refresh 

Help)

 

If I click ‘Open’ I get the contents of that destination. E.g. if I click C$ it opens: This PC > Local Disk > © and lists the details of each file.

 

‘All tasks’ leads only to ‘Open’.   ‘Refresh’ and ‘Help’ do what you would expect.

 

Default Share > Open leads back to: This PC > Local Disk (C:) and the listed file details.

 

But I have turned off Services and got rid of  ‘sharing’ so Many Thanks to everyone who has helped!



#14 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,190 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Quebec, Canada
  • Local time:12:37 AM

Posted 16 March 2015 - 04:05 PM

I have the same options and items listed as you, I just left them out as they weren't relevant to the current issue you were having :) And no problem, glad that you finally got it fixed!

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#15 dicke

dicke

    Paraclete


  • Members
  • 2,176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:12:37 AM

Posted 16 March 2015 - 07:23 PM

We'll be here when you need us

Til then

Stay well and surf safe

 

Dick


Stay well and surf safe [stay protected]

Dick E





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users