Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No Internet from the DHCP


  • Please log in to reply
16 replies to this topic

#1 bslevin

bslevin

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 08:04 AM

Ok I just set up a brand new 2012 R2 standard server, I have done this many times, the only difference is this is the first time I am using an AT&T fiber circuit.

 

The problem I am having is I configured the DHCP and I can connect from a computer to the server but none of the connected computers can get internet. The server has internet but not any of the connected computers.

 

I have checked and check the settings everything seems fine, but I am also looking too hard and may be missing something.

 

The only difference is I was a little confused by the settings for AT&T and making sure I have the right settings for the NIC card and DHCP.

 

AT&T provided me with 6 IP's, so I used one of the provided IP's ad the server IP, I used their default gateway and their subnet mask. then in the dns I used my ip as the primary and their default gateway as the secondary.

 

When I do a test from the computer it tells me "the default gateway is not available".

 

Any ideas I have tried just about everything I can think of. I am sure it is just something I am overlooking...



BC AdBot (Login to Remove)

 


#2 ChaseWheeler

ChaseWheeler

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:57 AM

Posted 07 March 2015 - 10:11 AM

This is probably a networking issue, but I have a few questions that may help figure out what it is you want.

 

#1 Do you want all of the computers to have their own public IP's?

#2 What does your network look like (what networking devices and in which order) (See example below)

 

 

Network example:

(AT&T Internet) ----->Modem------>Router------->Switch

                                                                              | | | | |

                                                                             /  | | |  \

                                               2012 Server____ /   /  |  \   \__________Windows 7 client

                                      Windows 7 client_______/   |    \_________Business printer

                                                                   Wireless Access Point


I couldn't do this job without my coffee and vape.


#3 bslevin

bslevin
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 11:45 AM

#1 no everyone needs an internal IP form the DHCP which is what they get but for some reason they cannot get internet only internal network connectivity.

 

#2  At&T 10MB Fiber ---> AT&T provided Cisco Router ----> Switch ----- then yes to all, 2012 R2 Server, windows 7 machines, printers, Wi-Fi, etc...

 

It is just strange because I have done this many times and never ran into this problem, that is why I think I am just overlooking something..

 

The server has internet and If I connect a windows 7 client directly to one of the AT&T public IP's with all the static info and not the DHCP then it gets internet. But obviously that is not what I want, we have about 50 computers...



#4 ChaseWheeler

ChaseWheeler

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:57 AM

Posted 07 March 2015 - 11:51 AM

Ok a few more questions.

 

Does the Cisco Router have DHCP enabled or are you running DHCP from your 2012 server?

What internal network is it operating on (192.168.1.1/24 10.0.0.1/24 etc)


I couldn't do this job without my coffee and vape.


#5 bslevin

bslevin
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 12:35 PM

no the cisco router does not have DHCP. the internal network is 12.1.12.1 - 12.1.12.154



#6 bslevin

bslevin
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 12:44 PM

server.jpg

 

This is the tcp/ip for the server then I have the DHCP set to 12.1.12.1 - 12.1.12.154


Edited by bslevin, 07 March 2015 - 12:45 PM.


#7 ChaseWheeler

ChaseWheeler

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:57 AM

Posted 07 March 2015 - 12:45 PM

Hrm, 12.1.12.1 isn't a private address, so that may be an issue (I say may because I've never tried to NAT public addresses).

 

I'd recommend picking a network range in the Private Network Range.

 

Also can you show me an ipconfig /all from the 2012 server?(steps below)

 

Log into the server, hold down the windows key on the keyboard and press r. A "run command" box will pop up, type "CMD" in the box and press ok. In the command line (black box with white letters) type in "ipconfig /all" without the quotes.


Is that screenshot from the server?


I couldn't do this job without my coffee and vape.


#8 bslevin

bslevin
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 01:04 PM

ok I will check and get you that information, but I am not at the office right now, I will get it soon...

 

Yes that is a screenshot I had taken yesterday



#9 ChaseWheeler

ChaseWheeler

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:57 AM

Posted 07 March 2015 - 01:10 PM

Ok so that's one of your public addresses. You said that AT&T only gave you 6 addresses and you have over 50 clients, so you're going to have to run your internal network on a private network range through network address translation (NAT).

Do you have the ability to access the Cisco router and does it have a Web interface?

I couldn't do this job without my coffee and vape.


#10 bslevin

bslevin
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 01:13 PM

Yes I need the range through NAT, the router is managed by AT&T



#11 ChaseWheeler

ChaseWheeler

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:57 AM

Posted 07 March 2015 - 01:24 PM

OK so when you go into work get an ipconfig from the server and a workstation.

wait. .. so where did you configure dhcp?

I couldn't do this job without my coffee and vape.


#12 bslevin

bslevin
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 07 March 2015 - 01:29 PM

from the server, that was yesterday I am at home now...



#13 ChaseWheeler

ChaseWheeler

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:57 AM

Posted 09 March 2015 - 12:08 PM

Bslevin I should be home from work for the rest of the day. Whenever you get into the office post here so we can work through this!


I couldn't do this job without my coffee and vape.


#14 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:07:57 AM

Posted 19 March 2015 - 09:51 PM

"I just set up a brand new 2012 R2 standard server"

 

First issue is you should not be using public ip provided by AT&T on your server imo.  This leaves your server naked exposed to the internet. Your only protection is the AV/firewall software running on your server. That public ip should only be on your routers wan interface.  Unless you are trying to host public web pages than its a different story.

 

Second is you can't have a router with a public wan ip in the same subnet as your servers ip which is also a public ip or no NAT/routing can take place. I this is the case the configuration above is incorrect as there should be only the modem<>server and no router in between.

 

Next issue is did you configure the forwarders in MS DNS to point to your ISP or public dns servers? 



#15 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:10:57 AM

Posted 22 March 2015 - 12:42 AM

What model Cisco device did AT&T setup? It looks like the AT&T device is providing a gateway to the internet and not doing NAT. Your server has internet because you assigned an IP address on the ISP's network (the subnet mask is wrong it should be 255.255.255.248 for 6 IP addresses). Your computers can contact the server because they are on the same network (because of the incorrect subnet mask). They can't connect to the internet because they do not have a proper IP address for the ISP's network. You need a router/firewall between your network and the ISP's Cisco device. Second 12.1.12.1 is a public IP address you need to change your DHCP scope to a private IP address such as 10.1.12.X. Your router/firewall will need the static information AT&T provided, and proper internal LAN IP (10.1.12.1)When properly setup your Server Will have a static IP on your private Lan IE 10.1.12.250 Subnet mask 255.255.255.0, and a default gateway address of your router/firewall (10.12.1.1). The DNS should be set static to the server's IP address (assuming this server is the primary DC and providing DNS). Your DHCP should assign an address from the 10.1.12.1 Subnet (exclude your router and server), assign your server's IP for the DNS address, and your router/firewall IP as the default gateway.

Edited by Sneakycyber, 22 March 2015 - 12:44 AM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users