Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Linux Share


  • Please log in to reply
6 replies to this topic

#1 colinprowitt

colinprowitt

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 27 June 2006 - 10:06 PM

I am very new to linux and i'm not quite sure how to add my linux machine to my microsoft file and print sharing network. Do i need to use the samba server role or what..........

Please walk me through this........i have my machine connected to my LAN (switch/router which is serving up ip addresses.....DHCP). I already have two windows machines connected in a workgroup.

BC AdBot (Login to Remove)

 


#2 Joedude

Joedude

  • Members
  • 337 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sutton Coldfield, West Midlands, England
  • Local time:02:22 AM

Posted 28 June 2006 - 04:47 AM

what distro are you using?
If someone tells you to su rm -rf /
DON'T DO IT!!!!
Be in the know, Bash smart!

#3 colinprowitt

colinprowitt
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 28 June 2006 - 09:46 PM

actually i figured it out.

Next problem i can see my linux box on the list of workgroup computers but i cannot access it.

The error message says i have no permissions to access the share folder i created in the samba setup.
and also says network path not found

btw i have fedora core 4

#4 Joedude

Joedude

  • Members
  • 337 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sutton Coldfield, West Midlands, England
  • Local time:02:22 AM

Posted 29 June 2006 - 04:20 AM

Have you checked the permissions on your linux directories you want shared? You can do this in much the same way you did it in windows. Right click on the directory, goto permissions, and check them. That should do it. If not, let me know, we just may get to talk port forwarding.

Edited by Joedude, 29 June 2006 - 04:22 AM.

If someone tells you to su rm -rf /
DON'T DO IT!!!!
Be in the know, Bash smart!

#5 colinprowitt

colinprowitt
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 05 July 2006 - 10:34 PM

sorry took so long to reply

yes the permissions are set correctly i think. In the samba server settings i made the share folder be in my users home directory. should the share be in my root users home directory? or does it matter?

the permissions are set so that anybody can do whatever they want to the folder and files in the share also........

#6 colinprowitt

colinprowitt
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 05 July 2006 - 10:37 PM

if this makes any difference............

I can access my windows machine from my linux machine but i can't access my linux share from any machine.

#7 Joedude

Joedude

  • Members
  • 337 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sutton Coldfield, West Midlands, England
  • Local time:02:22 AM

Posted 07 July 2006 - 07:44 AM

typically, if it's a subdirectory your trying to share, then you have to set the permissions from the major directory down. Have you got a router or hub in between computers you want to talk to each other? Also, are you using any firewall applications on your linux box?
If someone tells you to su rm -rf /
DON'T DO IT!!!!
Be in the know, Bash smart!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users