Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cisco Router and Motorola Modem configuration help!!!


  • Please log in to reply
13 replies to this topic

#1 briggs&straton

briggs&straton

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:04:08 PM

Posted 27 February 2015 - 01:42 AM

Good day!

 

So here is the scenario, I have my Arris Surfboard SB6121 Modem connected to my Cisco 2821 Router on G0/0, for the time being I input the IP i get from "whats my ip".  I have also for the time being a DHCP Pool setup on G0/1 to pull DHCP from my the router on the switch.  I cannot figure out how to get my internet going using this router and modem.  

 

Below is my config from the router, please let me know if i missed any information you might need to help me figure this out.  Thank you! 

 

Current configuration : 1188 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.1.1 10.10.1.10
!
ip dhcp pool INTERNET
   network 10.10.1.0 255.255.255.0
   default-router 10.10.1.1
   dns-server 8.8.8.8
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description WAN
 ip address 72.x.x.x 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LAN
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
!
ip http server
no ip http secure-server
ip nat inside source list LAN-Address interface GigabitEthernet0/0 overload
!
ip access-list standard LAN-Addresses
 permit 10.0.0.0 0.0.255.255
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end
 


BC AdBot (Login to Remove)

 


#2 Nikhil_CV

Nikhil_CV

    Vestibulum Bleep


  • Members
  • 1,145 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:err: Destination unreachable! bash!
  • Local time:02:38 AM

Posted 27 February 2015 - 08:21 AM

Hi,
Are you sure about the IP set for your modem?
Thats a public IP you're trying to use on a private network of a cisco router and a motorolla modem.
The websites and online services can see only your internet facing IP which falls in public IP category. You cannot or should not configure that IP for your internal private network. It wont work once you are connected to internet.
What I would suggest is, log in to your modem configuration (either using browser or tool provided by vendor), set the DHCP pool and DNS there, (just two ips from 192.168.1.0/24 will be enough)
Now console into 2821 and interface configuration of G0/0, set the IP address as static (from 192.168.1.0/24 network) or tell it to obtain it automatically via DHCP. Set the DNS and other interface specifics like default router/default gateway etc, try pinging modem IP as well as any public IP like 8.8.4.4.
If both are success, proceed configuring the DHCP pool in 2821 for local networks on other interfaces and the firewall/access list rules, NAT traversal, routing table if any etc .
Exclude G0/0. Its your WAN port now.
Remember to ping to your modem after each config edit. That will help you rule out lot of false positives.
.
BTW, I am not expert in configuring cisco routers, still throwing in my free time for CCNA R&S.

Edited by Nikhil_CV, 27 February 2015 - 08:34 AM.

Regards : CV                                                                                                    There is no ONE TOUCH key to security!
                                                                                                                                       Be alert and vigilant....!
                                                                                                                                  Always have a Backup Plan!!! Because human idiotism doesn't have a cure! Stop highlighting!
                                                     Questions are to be asked, it helps you, me and others.  Knowledge is power, only when its shared to others.            :radioactive: signature contents © cv and Someone....... :wink:

#3 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:04:08 PM

Posted 27 February 2015 - 10:04 AM

hmmm, seemed like everything i was reading last night is that I need to put that G0/0 to the public ip i get from my ISP.  I will definitely try this when i get home, i also didnt know that you could log into the modem like that. :)



#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 27 February 2015 - 10:20 AM

interface GigabitEthernet0/0
 description WAN
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 
Change the IP address to dhcp for G0/0 because that is how your modem is getting it's IP address from your ISP. Unless you pay for a static IP. 
 
ip route 0.0.0.0 0.0.0.0 next hop IP address   <<--- ie the router your modem connects to on the ISP side. If you connect to your modem directly then your PC will be assigned the WAN IP, you might be able to see the address by doing a tracert somewhere. because it might show you the first hop which is what you need. If not you'll have to call and see if they will give you that info.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:04:08 PM

Posted 27 February 2015 - 10:30 AM

ok ill try putting it on DHCP, but it was pulling anything.  ill try it again.  ill see how it goes when i get home.



#6 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 27 February 2015 - 11:26 AM

Also, because your modem is just a dumb modem, you'll have to power cycle it for the router to get an IP address. unplug, count to 10 slowish, plug it back in. If you watch the console that interface should go down and up a few times, finally getting an IP address.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#7 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:05:08 PM

Posted 27 February 2015 - 12:05 PM

Is your Aris modem in Bridge mode?


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#8 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 27 February 2015 - 12:17 PM

That modem is just a modem. There is no configuration like that.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#9 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:04:08 PM

Posted 27 February 2015 - 01:41 PM

ya its basically a dumb modem like cavedweller2 said.



#10 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:04:08 PM

Posted 28 February 2015 - 12:01 AM

ok so it is a dumb modem, i can ping 8.8.8.8 from the router but i cannot pull internet on my computer.  i moved my dhcp server to an actualy dell server.  so here is my configs

 

Current configuration : 1020 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
ip dhcp excluded-address 10.10.1.1 10.10.1.10
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description WAN
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LAN
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 72.223.70.1
!
!
ip http server
no ip http secure-server
ip nat inside source list LAN-Address interface GigabitEthernet0/0 overload
!
ip access-list standard LAN-Addresses
 permit 10.0.0.0 0.0.255.255
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end


#11 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:04:08 PM

Posted 28 February 2015 - 01:15 AM

well i fixed, i really dont know what i did. did a couple write erase, reloaded modem and now it works...



#12 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 28 February 2015 - 01:33 AM

So your G0/0 got an IP address when you set it to DHCP and power cycled your modem?

 

permit 10.0.0.0 0.0.255.255 <<--- shouldn't it be 10.10.1.0 0.0.0.255 ?

 

Also I am seeing the ip route done with both next hop or the outside interface. Still looking into it. *scratches head*


EDIT: Great. lol NM all the stuff above  =)


Edited by CaveDweller2, 28 February 2015 - 01:34 AM.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#13 Nikhil_CV

Nikhil_CV

    Vestibulum Bleep


  • Members
  • 1,145 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:err: Destination unreachable! bash!
  • Local time:02:38 AM

Posted 28 February 2015 - 02:35 AM

Hello people :) ,
Can anyone help me understand why OP is having lines:
ip forward-protocol nd
ip route  0.0.0.0  0.0.0.0  
72.223.70.1
!
especially the 72.223.70.1 IP?
And
ip dhcp excluded-address  10.10.1.1  10.10.1.10
!
according to this context?
Thanks in adv...

Edited by Nikhil_CV, 28 February 2015 - 02:40 AM.

Regards : CV                                                                                                    There is no ONE TOUCH key to security!
                                                                                                                                       Be alert and vigilant....!
                                                                                                                                  Always have a Backup Plan!!! Because human idiotism doesn't have a cure! Stop highlighting!
                                                     Questions are to be asked, it helps you, me and others.  Knowledge is power, only when its shared to others.            :radioactive: signature contents © cv and Someone....... :wink:

#14 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:05:08 PM

Posted 28 February 2015 - 05:16 AM

The Ip route 0.0.0.0 0.0.0.0 72.223..70.1 is his route outside to his default gateway. It will allways point to the isp's Assigned gateway address which is the next hop router to the internet. It's a public ip because his Arris modem is just a gateway device (that I failed to notice first time I read it) it does not provide Nat. The dhcp exclude-address excludes those IP addresses from being assigned reserving them for network equipment.

Edited by Sneakycyber, 28 February 2015 - 05:17 AM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users