Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Unable to Start "Server" Service - ERROR 126

  • Please log in to reply
1 reply to this topic

#1 hslee5


  • Members
  • 31 posts
  • Local time:11:53 AM

Posted 25 February 2015 - 03:13 AM

Hi All,


Anyone could u please help me for this problem.


I just change my office internet modem. And after i change to the IP and DNS to obtain automatically, 1 of my computer was having problem connect to the server, we are using a "TP-Link Switch".  The computer is connected to the switch and able to connect to internet but failed to share files and folders.


When I tried to start the "server" services in services.msc, it show this error message.

>>Could not start the Server service on local Computer. Error 126: The specified module cannot be found<<

I  tried this method but also failed to fix it.

Error message when starting the Server service in Windows XP


Okay for this command,

expand CD drive:\i386\srv.sy_ %systemroot%\system32\drivers\srv.sys  


I stuck at "expand E:\i386\srvsvc.dl_ C:\Windows\system32\srvsvc.dll" 




BC AdBot (Login to Remove)



#2 s1lents0ul


  • Members
  • 544 posts
  • Gender:Male
  • Local time:11:53 PM

Posted 26 February 2015 - 08:55 AM

Do you have a Windows Xp disk?


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users