Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Shared files and folders


  • Please log in to reply
7 replies to this topic

#1 gdnr

gdnr

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:30 PM

Posted 24 February 2015 - 05:37 PM

Hello,

 

Can anyone help me with this please. I do not know what the text below means but the obvious interpretation is that files and folders are being shared with remote computers, which I do not wish to do. I always opt to share nothing on my computer. Or perhaps it means something different and is harmless.

 

In Windows 7 Starter, I opened 'Computer Management' and then

> Shared Folders > Shares. Listed under this are the column headings:

 

Share name       Folder Path        Type             Client Connections        Description

 

ADMIN$             C:\Windows        Windows       0                                    Remote Admin

C$                       C:\                      Windows       0                                    Default share

E$                       E:\                      Windows       0                                    Default share

IPC$                                              Windows       0                                    Remote IPC

 

Then under 'Export List' were listed 'Fax' and 'Scanned Documents' files.

 

I do not know why these drives (C and E) are under 'Default share' as I had elected to share no files/folders/drives. Perhaps this is not what it means.

 

On another computer running Windows 8.1, under Shared folders itself I found nothing listed, but under More actions > Export list, I found listed the Bluetooth Exchange Folder, and a folder of documents I had created.

 

Again, nothing should be 'shared' on the second computer.  I followed online instructions to 'stop sharing' using the command prompt on Windows 7, but the process did not work.

 

Thanks so much for any help.



BC AdBot (Login to Remove)

 


#2 reast82

reast82

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:30 AM

Posted 26 February 2015 - 12:17 AM

Those shares are hidden as indicated by the $. Try running \\localhost\admin$ at a run box on your computer to get an idea.

 

They are used by the system / domain to execute commands remotely mostly. For the most part, I'd leave them alone unless you are hyper vigilant on security and are not participating in a domain or accessing your machine remotely. I believe disabling the server service will get rid of the IPC$ share. Check this article for some more info on the effects of disabling the shares.
http://support.microsoft.com/kb/842715

 

Suppose you, the admin, need to access COMPUTERA from COMPUTERB, Well, since we have built in hidden shares you jsut connect to it by \\COMPUTERA\C$ and voila; after enetring the credentials you're in. Good for when KVM is out ofthe picture

 

BTW the E:\ drtive is most likely your system reserve



#3 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:30 PM

Posted 26 February 2015 - 08:38 AM

Thank you reast82. I have taken an initial look at the links and will investigate them further. 

 

I never need to access my computer remotely and do not participate in a domain, so there is no need for any remote sharing to be enabled.

 

Under Properties, no files on C drive are shared so I do not understand why any of these files should be listed for sharing under Computer Management. (Remote assitance is also disabled.)

 

Does 'Computer Management' list 

'Shared Folders'

under 'Shares'

or under 'Export List'

 

on all computers? Or do these sections sometimes contain no lists?

 

(That's a question for anyone!)

 

Thanks again reast82 for your help.



#4 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,586 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:30 AM

Posted 26 February 2015 - 08:42 AM

Hi gdnr :)

If you go back in the Computer Management under Shared Folders -> Shares and you right-click on C$ or E$, do you have the option "Stop sharing"? If so, when you click on it, what happens? Also, there's nothing wrong in these shares being enabled to be honest. Nobody can access it unless they have your computer's name and password, as if they try to access:

\\YOUR_COMPUTER_NAME\c$

They'll be prompted a Windows logon asking for username and password of an authorized account on that computer under the form of:

Username: YOUR_COMPUTER_NAME\AUTHORIZED_ACCOUNT_NAME
Password: PASSWORD

Unless someone have these informations, they won't be able to access your C: (C$) at all.

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#5 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:30 PM

Posted 02 March 2015 - 06:25 PM

Hello Alex and sorry for the delay in replying. Thank you for your help, it is reassuring to know that my computer is not accessible without username / password. As yet I've had no luck preventing the share function:

 

As you suggested, under Windows 7 Starter I right-clicked on C$ and E$ and found that there is no option to 'stop sharing'. The options listed are: Open / All Tasks / Refresh / Help. 

 

Under 'Help' I followed the instructions to 'Stop sharing a folder or drive', which I had also tried previously.  The first method involved using the Windows Interface. This did not work as, again, there was no option to 'Stop sharing'. I tried the second option, using a command line  (Start > All Programs > Accessories > right click Command Prompt > run as Administrator) and typing:

 

net share <sharename> /delete.

 

(the sharename being the name of the file you want to stop sharing)

 

This did not work either.

 

(By the way the list of Share names, folder paths etc. from ADMIN$ through to Remote PC, as listed in my first post, only appear when the computer is online.)

 

On the other computer running 8.1, opening Computer Management > Shared Folders, and right-clicking each folder listed (as you suggested I did with C$ and E$), there is an option to 'Stop Sharing' but selecting it makes no difference. It still says 'Stop Sharing'!

 

I may not be online for a couple of days so apologies in advance (but will try to check in).

 

 



#6 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,586 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:30 AM

Posted 02 March 2015 - 06:28 PM

What I would try to do is to disable the network discovery on your system and then try to disable these shares.

http://windows.microsoft.com/fr-ca/windows/enable-disable-network-discovery#1TC=windows-7

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#7 gdnr

gdnr
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:30 PM

Posted 11 March 2015 - 04:57 AM

Aura, a belated thank you for your help.  I followed the link, which is in French. The  link in English is below:

 

http://windows.microsoft.com/en-us/windows/enable-disable-network-discovery#1TC=windows-7

 

 

I went through this process several times, because when I turned off file and printer sharing and network discovery, they were turned on again when I checked a few minutes later.  But after several attempts, in Windows 7 Starter, it seems to be working. And by following the path: Computer Management > Shared folders > Export List (and right-click individual files): these files now read: Share with... ‘Nobody’.

 

I also found the equivalent link for Windows 8.1 and tried to make changes on the other computer. In the Network and Sharing Center, ‘file and printer sharing’ or ‘network discovery’ are turned on again next time I check.  Also by going into the individual files under ‘Computer Management’, these files still read ‘Stop sharing’ so they are shared and I’m unable to change this.

 

Is there any obvious global change that I could try to fix this; or should I re-post this question about 8.1 in the Windows 8 forum?

 

Thank you



#8 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,586 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:30 AM

Posted 12 March 2015 - 01:51 PM

Sorry I forgot to edit the link. Usually, I change the "fr-ca" for "us-en" to create a link to the English version of the article. I saw that you already posted a new thread in the Windows 8 and 8.1 section so I'll take a look.

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users