Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Error Code: 0xc0000000e


  • Please log in to reply
1 reply to this topic

#1 senseless

senseless

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:03:32 AM

Posted 22 February 2015 - 11:42 AM

Windows 8.1 update

120gb SSD with OS and software

2 1T HDD in RAID1 for data

1 1T HDD target for crashplan backups

8GB RAM

Intel quad core

Asus MOBO

 

My computer "encountered a problem" while online last night, went to a blue message screen and then shut down.  This happened once before, about a week ago.  ebay.  Last time, the problem eventually resolved after several reboots.  After that, I restored a recent image using Macrium, and it was fine.

 

So, it happened again last night, but would not resolve.  I tried restoring 2 different images using macrium, but windows will not boot.  Error Code: 0xc0000000e, device not found or corrupt.  Something to that effect.  Tried using windows image restore as well, no luck.  At this point, I have restored using the most recent macrium image, about 2 weeks old.

 

Some searching indicates that the MBR BCD may be the problem.  i tried automatic repair a dozen times, also from the install disc.  no luck.  Any help appreciated.  Thanks!

 

update1- booted from the install disc, ran bootrec/ScanOs from C prompt, and it does not see windows installation.  : 0

 

update2- unplugged 2 USB external drives and a USB hub that had a card reader attached.  Also unplugged the RAID1 drives from the MOBO and the 3rd storage drive.  Reboot and auto repair did not work.

 

update3- I got into safe mode.  Is there hope for this system?  I do not want to reinstall from scratch.


Edited by senseless, 22 February 2015 - 09:55 PM.


BC AdBot (Login to Remove)

 


#2 senseless

senseless
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:03:32 AM

Posted 24 February 2015 - 11:34 AM

update4- I cannot edit the original post so I am using reply.  Not intended as a bump. It was another typical windows CF and I am starting to hear the siren calls from other camps more clearly.

--mac, linux, and don't use motherboard RAID! --

In case somebody else is looking for answers, well, all I have is another story of woe.  2 days of fiddling and one lesson is clear, apologies for the obvious:

1- make regular backups.

 

After much initial research during which I found countless warnings about mobo/software RAIDS, I decided it was not a bad idea to run a RAID1 from the motherboard, just to make things easy in case of HDD failure.  I was not thinking this would function as pure backup, just a technique that might expedite recovery, and avoid workflow stoppage in the event of a hardware failure.  I also set up crashplan software to backup important files every day to a non-raid mobo drive.  In the past, I was doing manual file backups to a few external drives.  I continued that as well, with a small set of important files, and also hedged my bets by copying the crashplan folder periodically to another location.

 

Now I encountered something really weird and so far inexplicable.  After 2 odd crashes where I got the error message described above.  The first time the computer seemed to repair itself after several reboots.  The second time it did not come easy.  I am not fluent in computer systems, but I know how to read, and guess, and maybe in some cases, make a tangled mess even worse. This time, I found something weird.   My SSD (the OS and all software) had been copied onto one of my RAID drives.  And the SATA option in BIOS was set to AHCI.  I am 99% certain that I did not do this.  I did use Macrium to restore an SSD image, more than once, but the program default is to put the image back on the drive where it came from originally.  It takes some clicking and thoughts to change the target for the image restore.  I do not recall making that effort during the restore processes.  And I cannot imagine why I would change the SATA mode from RAID to AHCI in BIOS. Could Macrium do that if I (somehow) asked it to restore the SSD image to one of the RAID drives?  I don't know, but Macrium making a BIOS adjustment seems a little presumptuous to me.  It is possible that I did this when the computer crashed the first time, as I did a restore after that sorted itself out.

 

So, at one point I noticed the new partitions on one of the raid drives, and the second drive had all of the original data files and folders, and they were accessible.  What kind of raid1 is that? (Should have copied that stuff right then...) I deleted the partitions on the drive with the OS. Then I checked the bios and switched ahci back to raid, thinking the raid would rebuild from the complete drive...guess I didn't think that through!  everything disappeared!  Where are my adult diapers?  Back into bios, switched to ahci again, thinking maybe I would end up with one drive less F'd than the other.

Upon reboot, there was a message regarding the drive that gave a %timer and said it was being checked maybe that was chkdsk, I don't know.  But, the drives were blank.  That process ran several times during subsequent reboots and finally, some folders showed up on one of the drives.  It was not the complete set, like I had seen there just moments before, but encouraging. 

 

Another slide along the learning curve.  I am now very suspicious that this mobo raid setup might not go so smoothly as I imagined, if one of the RAID drives fails.  

It is not that much trouble to restore using Macrium, crashplan, or simply copying files, although USB 2 connection can take some time.  Since I am slowly getting better at navigating the restore options, I will take this opportunity to rebuild the mobo raid and see if I can freely add/remove drives without complications.  After that, I might scrap it.

 

I am left scratching my head regarding the raid getting switched to ahci, and the OS image appearing on my raid drive.  WTF?  The best fit explanation is that I did this somehow, unknowingly.  If it was the result of malware or remote manipulation of some kind, then what was the point?  I don't have a flipping clue, but am getting things back together and will keep a chastened eye on my keystrokes going forward.  If anyone has any idea about how this might have happened, I am very curious.  Even if it means hearing that I am a DOLT!  Other than that, thanks for watching, consider this CASE CLOSED!   The error code 0xc0000000e was almost certainly a result of this raid crapstorm.

 

UPDATE-

This might help somebody else.  I had trouble getting the RAID1 back.  I don't know how but my bios did get reset to AHCI mode and windows 8 just does not seem to allow switching back and forth between RAID mode and AHCI.  I looked in a lot of places online before I found the trick here:

http://blog.rolpdog.com/2012/03/enabling-ahciraid-on-windows-8-after.html

 

My registry had 3 likely keys iaStorA, iaStorAV and iaStorV, so I reset all of them to "0"  they were all set to "3"  It worked!  Entered bios, switched to raid mode, did the ctrl "i" raid setup and got my raid1 back.  I also set my sata plugs to hot swap mode and tested the raid by unplugging a drive, adding files to the other, shut down, plug in, reboot and rebuild etc works like acharm, seems useful for some situations if you don't like the idea of breaking stride if one of your drives fails.  I know it isn't likely to happen but if you are in the middle of a deadline, it could save some anxiety if nothing else, clients?  


Edited by senseless, 24 February 2015 - 10:14 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users