Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

downloading xampp


  • Please log in to reply
5 replies to this topic

#1 C_C_

C_C_

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 22 February 2015 - 10:04 AM

hello

 

      I am using Lubuntu and want to download xampp.  The only version of Linux I can find to  download xampp  is Ubuntu.  After  trying serval times to  download xampp Ubuntu I only got the save dialog box once selected  save and ok.  No  download.  Nothing happened.  A couple of questions. 

 

      Is Lubuntu compatable with xampp.  If so where can I get xampp for  lubuntu.  If I do manage to make head way with the download  and putting  this  rather unprofesionally.   Is there any type of syntax I need to enter  in any dialog box to get it to work.  I am coming from windows and Linux is different.  Thank you. 



BC AdBot (Login to Remove)

 


#2 shadow-warrior

shadow-warrior

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nicaragua
  • Local time:10:41 AM

Posted 22 February 2015 - 12:04 PM

I don't know much about Buntu linuxes.....but  maybe these articles will help

http://lubuntuhowto.blogspot.com/2014/06/how-to-install-php-mysql-on-lubuntu-1404.html

http://lubuntuhowto.blogspot.com/2014/06/how-to-start-stop-restart-xampp-on-lubuntu.html


Edited by shadow-warrior, 22 February 2015 - 12:05 PM.


#3 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 22 February 2015 - 04:36 PM

EDIT: I deleted my original posting after discovering a potential issue. Here is the updated post that corrects for a potential Mozilla Firefox issue caused by the use of Sudo when installing XAMPP.
 

The only version of Linux I can find to download xampp is Ubuntu.



You can download it manually direct from the XAMPP website ( https://www.apachefriends.org/download.html ). XAMPP is compatible with lots of distros, for example: Ubuntu, Debian, CentOS, Fedora, Gentoo, and Arch. Lubutu is a good choice, it's what I use for LAMP (Linux Apache MySQL PHP).

 

Is Lubuntu compatable with xampp.



Yes.

 

where can I get xampp for lubuntu.



You can download the .run installer for XAMPP on the official site for XAMPP ( https://www.apachefriends.org/download.html ).

 

If I do manage to make head way with the download and putting this rather unprofesionally. Is there any type of syntax I need to enter in any dialog box to get it to work.



Yes, I will include the steps below; basically you'll need to change the file permissions to allow execution, and then execute the installer. Once the installer is up and running it's much like any installation wizard on Windows, just click buttons, and check/uncheck option boxes.

Are you running Lubuntu 32bit, or Lubuntu 64bit? The steps below are for the 64bit version of Lubuntu, because that is what I have. You can adapt them for use on the 32bit Lubuntu if needed, as the only things that are different are the download url, and the filename of the downloaded installer.

How To Install XAMPP 5.6.3 On Lubuntu 14.04 X86-64:

Steps:
1. Firstly you need to download the installer. Open your terminal emulator and type "wget -t 0 -nc --waitretry=10 "http://downloads.sourceforge.net/project/xampp/XAMPP%20Linux/5.6.3/xampp-linux-x64-5.6.3-0-installer.run" ". The installer will be saved in your user directory.
2. In order to execute the installer your user will need to be granted execution permissions. In your terminal emulator type "chmod u+rwx ~/xampp-linux-x64-5.6.3-0-installer.run". Your user now has the ability to execute this file.

3. In your terminal emulator type "sudo -i". This will elevate you to root privilidges by simulating a root logon.
4. Now it's time to execute the installer. In the terminal emulator type "/home/example1/xampp-linux-x64-5.6.3-0-installer.run". You will need to substitute "example1" for your username.
5. The XAMPP setup will open. Click "Next" to proceed with the installation process.
6. On this screen of the XAMPP setup, uncheck the box for anything you don't want installed, and then click "Next". If you aren't sure, leave all the boxes checked.
7. On this screen of the XAMPP setup click "Next".
8. On this screen of the XAMPP setup, uncheck the "Learn more about Bitnami for XAMPP" box, and click "Next".
8. On this screen of the XAMPP setup, click "Next".
9. On this screen of the XAMPP setup, once the installation process for XAMPP has ended, uncheck the box for "Launch XAMPP", and then click "Finish".

10. Return to your terminal emulator and type "exit". This will un-elevate your user from root privilidges.
10. (This step is optional) If you wish to delete the XAMPP installer go back to your terminal emulator and type "rm -i ~/xampp-linux-x64-5.6.3-0-installer.run". When prompted to confirm the file deletion, type "y" then press "enter".

Notes:
- The XAMPP installer download is about 122.9 Mebibytes. (On Windows that would be labelled 122.9 Megabytes.)
- If your download gets stuck for a long time you can force quite Wget using "control" + "z". You will have to delete the partially downloaded file from your user's directory. When you try again to download it will start from 0%.
- Be aware that XAMPP won't create a shortcut in your LXDE menu. Use "sudo /opt/lampp/lampp start" to start XAMPP. If you prefer to work with the GUI use "gksu /opt/lampp/manager-linux-x64.run".

- The reason why I suggest unchecking the boxes for "Learn more about Bitnami for XAMPP" and "Launch XAMPP" is that both of these result in your web browser

being opened, and unfortunately XAMPP does this elevated which is generally something to avoid doing for security reasons.

- The reason why I suggest using "sudo -i" instead of Sudo directly to execute the XAMPP installer is that if you don't have a Mozilla Firefox profile yet for that user account, and you don't prevent XAMPP from opening Mozilla Firefox, when the web browser is opened Mozilla Firefox will create a profile, but because it's

running elevated it will use incorrect permissions. These permissions would prevent you from using Mozilla Firefox under that user account until corrected.

- REF: [ Search UUID: x92KSj%YlsVbZ&r&QZw6YnF!kYd@CRAvdIx2i9wROrBFJVgkK@97MnxDG0$djwxHHXNx ]

 

I am coming from windows and Linux is different.



Yes it takes quite a bit of getting used to. Linux distros aren't as user friendly as Windows, which is probably in-part why Linux's home user market share is smaller despite many Linux distros being free.


Edited by hollowface, 23 February 2015 - 12:23 AM.


#4 C_C_

C_C_
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  

Posted 23 February 2015 - 02:25 PM

hello

 

     I am having the same problem I had walking into the download.  I never get the save diolag box after the  download starts.   From I am seeing my only option is to double click on the blue download  arrow at the top of my screen.  When I start  the installer the blue arrow counts down the amount of time of  the downalod.   It stands between me and saving  the file. 

 

    After doudle clicking on the blue arrow I get the launch application diaog box.  In that box I select "choose" and than I beleive click ok  that  takes me directly where  my file are kept. They are for example.   Documents desk top and downloads........  In the download folder I see the xampp download file I started  when I began the installer.  It reads xampp - linux 54-5.6.3-0 installer. At the bottom of that box I can select open to open the file.  Which doesn't do much of anything either.   I am  using a 32 bit version of Lubuntu and my brower is  Mozilla Fire Fox.  So why is this happening that I am not able  download anything and is there an easy and  simple way to get this to work.  Thank you. 



#5 C_C_

C_C_
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 23 February 2015 - 03:55 PM

Sorry any confusion.  I didn't see you deleted you original  post. 



#6 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 25 February 2015 - 09:14 PM

I am having the same problem I had walking into the download.  I never get the save diolag box after
the  download starts.   From I am seeing my only option is to double click on the blue download  
arrow at the top of my screen.  When I start  the installer the blue arrow counts down the amount
of time of  the downalod.


The default settings for Mozilla Firefox do not prompt you to choose a save location, it will instead automatically download to your user's directory. If you would like to be prompted you can change your Mozilla Firefox settings to make that happen. I've included the steps below.

Set Mozilla Firefox To Prompt For A Save Destination:

 

Steps:
1. Open Mozilla Firefox.
2. In Mozilla Firefox click on "Edit", click "Preferences" in the menu, click the circle beside "Always ask me where to save files", and finally click "close".

 

1HTqEzl.png

- REF: [ Search UUID: naR2x&pO0n1SQLl8i3E3bI#PyMqD9bx5Glq@qd+W2=jMNyxWM4EW7#MTZk@E ]






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users