Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My computer will not recognize my flash drive or printer?


  • Please log in to reply
1 reply to this topic

#1 ewatt72

ewatt72

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:00 PM

Posted 04 February 2015 - 02:36 PM

I own a dell studio 1558 running windows 7 64 bit. Today I inserted my sandisk cruzer glide flash drive in my usb port & my cpu will not recognize it or my plug & play hp printer. I am getting the following error message:

 

"The drivers for this device are not installed. (Code 28)

There is no driver selected for the device information set or element.

To find a driver for this device, click Update Driver."

 

 

I have tried uninstalling the universal serial bus controllers, tried downloading new software for the drivers from my cpu & checked the internet for updated driver software. I also ran the computer's own driver troubleshooting software. No luck at all. The flash drive is plug & play & came without any software. I have 2 yellow exclamation points in my device manager which tells me something is wrong but I can't seem to figure this one out.

 

 

I would really appreciate any help I can get with this problem as it is quite frustrating. Thank You in advance...



BC AdBot (Login to Remove)

 


#2 Citizen_WD

Citizen_WD

    Authorized Western Digital Rep


  • Members
  • 138 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:00 PM

Posted 06 February 2015 - 09:44 AM

Hello, 
 
Most certainly there is a fault in your drivers. First of all - simply disconnect all USB devices, restart the computer and try again. If the same error still pops up this is the official Microsoft guide, take a look: http://support.microsoft.com/kb/310123?wa=wsignin1.0
 Anyway, these are the only know troubleshooting steps and, unfortunately, it is difficult to determine exactly which driver may be causing the issue. Take a screenshot of device manager, if you can. If the automatic driver update didn't work for you try to roll back the drivers to the version prior to your update or use System restore: 
 
I really hope that your problem will be solved soon, Citizen_WD





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users