Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Muting main speakers but not headphones


  • Please log in to reply
10 replies to this topic

#1 Michael91

Michael91

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:21 AM

Posted 01 February 2015 - 01:43 PM

Recently, my Lenovo Laptop running Windows 7 has stopped fully recognizing my headphones. I can still hear audio through them, but it won't shut off the audio on my laptop speakers. When I enable multi-streaming in Realtek HD audio manager, and open up the playback devices, I can see that the "Realtek HD Audio 2nd output" is labeled as not plugged in. This problem is consistent when I switch between headphones. I do not need to get this working though; I only need a way to mute my main speakers without stopping sound from coming through the headphones. However, when I disable the speakers, this stops volume from coming through the headphones too. Is there anyway I can mute just the laptop speakers without affecting the headphone output? Thanks a lot for the help.



BC AdBot (Login to Remove)

 


m

#2 JohnC_21

JohnC_21

  • Members
  • 21,596 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:21 AM

Posted 01 February 2015 - 02:04 PM

Hello, and Welcome.

 

Realtek has different HD Managers depending on the version and computer. You may have see this . Also check the link on the last post. Also check the Front Jack Detection Setting if you have it.



#3 Michael91

Michael91
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:21 AM

Posted 01 February 2015 - 02:22 PM

Hello, and Welcome.

 

Realtek has different HD Managers depending on the version and computer. You may have see this . Also check the link on the last post. Also check the Front Jack Detection Setting if you have it.

None of those solutions work for my computer/problem. The version of the HD manager I have (see attached image) only appears to have one option in its advanced settings, to  use classic or multistream mode. When I adjust the speaker volume there, it lowers it for my headphones too. Is there another way I might be able to shut off just my speaker volume? Thanks.

Attached Files



#4 JohnC_21

JohnC_21

  • Members
  • 21,596 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:21 AM

Posted 01 February 2015 - 02:46 PM

Other possibly a fn+Function key to mute speakers, no.

 

Is the Realtek driver the orginal that came with the computer. There are updates on Realtek's site than may give you a better HD manager.



#5 Michael91

Michael91
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:21 AM

Posted 01 February 2015 - 03:17 PM

Other possibly a fn+Function key to mute speakers, no.

 

Is the Realtek driver the orginal that came with the computer. There are updates on Realtek's site than may give you a better HD manager.

Thanks for the suggestion; however, like other methods to control the main volume, it mutes both the main speaker an the headphones volume. I have the latest Realtek driver installed (at least according to my computer when I request a search for an upgrade).



#6 JohnC_21

JohnC_21

  • Members
  • 21,596 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:21 AM

Posted 01 February 2015 - 03:55 PM

I would create a Restore Point and also create a System Rescue disk before you do this.

 

Download the Realtek driver here if you have an earlier version. I assume you have 64bit.

 

64bits Vista, Windows7, Windows8, Windows8.1 Driver only (Executable file) R2.75 2014/5/21 122738k

 



#7 Michael91

Michael91
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:21 AM

Posted 01 February 2015 - 04:36 PM

I would create a Restore Point and also create a System Rescue disk before you do this.

 

Download the Realtek driver here if you have an earlier version. I assume you have 64bit.

 

64bits Vista, Windows7, Windows8, Windows8.1 Driver only (Executable file) R2.75 2014/5/21 122738k

 

Hmm; the page doesn't seem to be working properly; it just keeps directing me back and forth. 



#8 JohnC_21

JohnC_21

  • Members
  • 21,596 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:21 AM

Posted 01 February 2015 - 04:39 PM

That is strange. It's doing the same thing for me.

 

Try this link.



#9 Michael91

Michael91
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:21 AM

Posted 01 February 2015 - 05:40 PM

After installing it, nothing seems to have changed. It seems like this should be a solvable problem; after all, it used to automatically shut off the computer speaker when the headphones were plugged in, so obviously the computer has the capability to do so. Not sure what to do from here though.



#10 JohnC_21

JohnC_21

  • Members
  • 21,596 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:21 AM

Posted 01 February 2015 - 05:43 PM

I am pretty much out of ideas on this, sorry. Do you have the option to do a System Restore to a date before the problem occured?



#11 OldPhil

OldPhil

    Doppleganger


  • Members
  • 3,734 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island New York
  • Local time:02:21 AM

Posted 01 February 2015 - 07:29 PM

My first thought is the socket is not breaking the circuit to the speakers, when you insert the headphone jack one of its functions is to lift the tab that supplies sound to the speakers.  I think you have a mechanical issue not system or software.


If you don't stand for the flag then you will fall for anything!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users