Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

cannot set password never expires (server 2012)


  • Please log in to reply
10 replies to this topic

#1 hansb1

hansb1

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 30 January 2015 - 05:04 AM

I have a stand alone server 2012.

I login as local Administrator.

I see the popup message:your password is expired in 1 day,you must change your password.

I open local security policy in server manager

I go to the object account policies->password policy->max password age

The age is set to 42 and is greyed out.I want to set it to 0 but I cannot change the value.

 

How can i change it to 0?

 

 



BC AdBot (Login to Remove)

 


#2 hansb1

hansb1
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 30 January 2015 - 06:39 AM

I've also tried gpedit.msc and tried to change the max password but all the security settings in computer configuration are greyed out and cannot be changed.



#3 sflatechguy

sflatechguy

  • BC Advisor
  • 1,996 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:54 AM

Posted 01 February 2015 - 01:47 PM

Go into Active Directory Users and Computers, find the user account you want to set to password never expires, open the Account tab, and under account options, select Password never expires.

 

Or, open the PowerShell for Active Directory module, and enter Set-ADUser -UserPrincipalName <enter the username here> -PasswordNeverExpires $true



#4 hansb1

hansb1
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 01 February 2015 - 03:35 PM

As I said it's a stand alone server and no domain controller.

I can log in a domain but I have no Active Directory Users and Computers in tools of server manager and if I had that I would not find there the local administrator account of the stand alone server.

In active directory is the domain administrator(of a external domain controller) I think.



#5 sflatechguy

sflatechguy

  • BC Advisor
  • 1,996 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:54 AM

Posted 01 February 2015 - 04:02 PM

If your options in the local security policy snap-in are greyed out, they have been or or being overriden by domain group policies.

 

Was this server ever joined to a domain at some point?

 

If not, check to see if User Account Control is disabled, and enable it.



#6 hansb1

hansb1
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 02 February 2015 - 12:52 AM

This server is a virtual machine.I did not install it.I copied the image from someone.So I didn't know if this server was ever joined to a domain.

I've checked user acount control and the registery value EnableLUA was set to 1 so its enabled.

In control panel the account control setting is set to notify



#7 sflatechguy

sflatechguy

  • BC Advisor
  • 1,996 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:54 AM

Posted 02 February 2015 - 08:11 AM

My guess is the server your image was copied from was joined to a domain. That's why you can't edit the local policies -- the domain policies were in force when the image was created.

#8 hansb1

hansb1
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 03 February 2015 - 08:10 AM

Do you mean on my server first the roll activ directory domain controller was added and then the role activ directory domain controller was removed and then I have copied the image?



#9 sflatechguy

sflatechguy

  • BC Advisor
  • 1,996 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:54 AM

Posted 03 February 2015 - 10:11 AM

I can't say when it happened, but at some point the server you created the image from was joined to a domain. That's why you can't change the local policies. The domain group policies are being enforced on your virtual machine.

#10 jdros

jdros

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 29 May 2015 - 10:54 AM

If the server IS a domain controller, you need to manage this through Active Directory Users & Computers.

 

Right click on Domain => Properties => Attribute Editor (last tab) => maxPwdAge

 

Default value is "42:00:00:00"

 

HTH



#11 sabrinau

sabrinau

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:54 PM

Posted 02 July 2015 - 06:24 PM

@hansb1, open a Command Prompt as the administrator mode, then run the following command:

net accounts /maxpwage:unlimited

Your password will never expire.






12 user(s) are reading this topic

0 members, 12 guests, 0 anonymous users