Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

chkdsk at every boot, but drive not "Dirty"


  • Please log in to reply
4 replies to this topic

#1 paul1149

paul1149

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:03:00 PM

Posted 28 January 2015 - 10:55 PM

Hi folks,

 

I've got an Acer netbook with a small SSD, running XP Home. It just started running chkdsk on every boot. No problems are ever found. I also checked the drive state using fsutil, and it is not Dirty.

 

I did some searching and found that chkdsk /f /x is supposed to resolve the problem. When I tried it, XP said it needed to do the scan upon the next boot. So I scheduled it. It didn't help. I also scheduled a chkdsk /r, to no avail.

 

Then I booted an offline WinPE disk and ran chkdsk /f /x from there. Again no problems were found, and again, the problem is not resolved.

 

I don't know what is next. I've got a drive that isn't dirty, which chkdsk finds no problem with, but which is checked upon every boot.

 

It's an 8GB SSD drive, and it has no page file on it.

 

Any insight would be appreciated.

 

Paul



BC AdBot (Login to Remove)

 


m

#2 YeahBleeping

YeahBleeping

  • Members
  • 1,258 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:00 PM

Posted 28 January 2015 - 11:24 PM

You are not supposed to run chkdsk on SSD's

 

I would exit out of the system checking and (it usually gives you like 10 seconds to exit)

 

To stop it from happening, go to the start menu, hit run, type in "cmd" (Excluding the quotation marks) and type in

chkntfs /x c:

If C is your main hard drive, and the only hard drive that it's preforming CHKDSK

 

SSD's do not have cylinders and sectors where files are stored like Hard Drives do.  The error correction and recovery is done by the SSD controller.  Chkdsk is NOT designed to run on SSD's get with the times microsoft and disable the chkdsk command if ssd is detected on the drive specified.


Edited by YeahBleeping, 28 January 2015 - 11:29 PM.


#3 paul1149

paul1149
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:03:00 PM

Posted 28 January 2015 - 11:35 PM

That certainly was easy. I had seen that command in my travels, but thought it wasn't for me because of the FAT32 system.

 

Working beautifully now. But I still don't understand what set it off, Hopefully the SSD isn't failing. Or why, if SSDs are not to be chkdsk'd, XP insisted on doing so.

 

Thanks very much,

Paul



#4 hamluis

hamluis

    Moderator


  • Moderator
  • 54,826 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:00 PM

Posted 29 January 2015 - 02:18 PM

https://www.google.com/#q=chkdsk+%2Fr+on+SSd

 

My experience is that it's defrag that should never be run on a SSD, while the value of running chkdsk /r on an SSD is debateable.

 

My experience (I run chkdsk /r on my SSDs) is that it's value may be questionable but running it does no harm to anything.  It's still a file system tool, not a hard drive tool and I'd be willing to guess that there are some file situations addressed, whether the files are on an SSD or a hard drive.

 

Louis

 

 



#5 paul1149

paul1149
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:03:00 PM

Posted 29 January 2015 - 03:29 PM

That was my thinking also, Louis. And that would explain XP performing chkdsk on the SSD.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users