Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Java or Firefox is blocking access to files in My Documents


  • Please log in to reply
No replies to this topic

#1 connie6121

connie6121

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 27 January 2015 - 12:27 PM

Firefox cllaims it is Java.  I can't find anyplace at Java to ask. 

I have a jigsaw puzzle routine that was given to me by the author, after digging deep to find him, and asking very nicely.  It's the same one as CastleMountains, except I can use it with my own pictures, without being online..  I am old, frequently sick, and sometimes in bed for weeks at a time.  This jigsaw program is the best game I have ever found to pass the time.  It starts from a file called 'index.html' and uses a file called 'puzzle.jar'. And an image file, of course/

 

After some update or other, I had to start manually allowing the Castlemountains puzzles to run.  After some other update, I had to edit the 'whitelist' (?) to allow it to run.

 

Plus, last summer my outside box (internet and phone) was hit by lightning and out for two weeks.  That was when I discovered that my personal jigsaw program no longer worked.  Since even on good days there's not much I can do, I spent a lot of time staring at my wallpaper.  I have since researched and found nothing I can use -it's all for java programmers, and for me it might as well be written in Greek.  I've added everything I can think of to the Exception list.  I have lowered every security setting as far as it will go.  And I still get AccessControlException every time I try to run it.  I can see the picture at the beginning, then I get asked if I want to run this program.  The only response that continues is 'yes', but where it goes is the picture disappears, replaced by 'error: click for details'.  That gives me the Exception, which says: Access denied ("java.io.FilePermission" "C:\Documents and Settings\Connie\ ~ \imagename2.jpg" "read").  At the end are 3 buttons:  Details, Ignore, and Reload.  I used toget another screen by clicking Details, but now all buttons do nothing.  My last update (yesterday) was to Java 8 u 31.  Using 7-most recent- before that.

 

I don't feel I can bother that mice man again, to 'fix' a jigsaw program he was probably done with at least a decade ago.  I can, I think, put my routine on a website and access it from there.  The problem with that is when I need it, the internet is not available for me to get to any website.

I hope someone has some kind of idea.

 

I tried posting at Firefox, and someone suggested I stop using Java because it's 'old technology and insecure'.  Unfortunately that advice doesn't help, and since I only really want it when I'm not online, I fail to see where the 'security risk' might be.

Thanks for lsitening, at least.

C



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users