Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SQL Server Express 2005 error 997 in UPS WorldShip 2015


  • Please log in to reply
1 reply to this topic

#1 gpence

gpence

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:44 PM

Posted 27 January 2015 - 12:24 PM

I'm trying to install UPS WorldShip 2015 to a new Dell Latitude E5440 with Win 7 Pro SP1. It gets to the SQL Server Express portion of the install and aborts with an error code 997 at Step 6 of 26. The error code says it is an "Overlapping I/O operation is in progress". I've researched this and found KB 2918614 and KB 3000988 -- both which have not solved my issue.  Here is, I believe, the relevant portion of the log file:

1/27/2015 8:23:48 AM: CIM:UpdateInstallSession - Executing step 6 of 26
1/27/2015 8:23:48 AM: Preparing to execute the SQL 2005 Express installation
1/27/2015 8:23:48 AM: Preparing to check Worldship SQL Express instance...
1/27/2015 8:23:48 AM: Registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\UPSWSDBSERVER\setup does not exists.
1/27/2015 8:23:48 AM: Fresh SQL Express install
1/27/2015 8:23:48 AM: Fresh SQL Express install
1/27/2015 8:23:48 AM: GetName returns service local system service name: NT AUTHORITY\SYSTEM
1/27/2015 8:23:48 AM: Preparing Execution (SQL Express) C:\Users\Public\UPS\WSTD\INSTALLATION_18_0_27_0\DB\SQLEXPRESS\SQLEXPR.EXE /qn  INSTALLSQLDIR="C:\UPS\WSTD" INSTALLSQLDATADIR="C:\ProgramData\UPS\WSTD" INSTANCENAME="UPSWSDBSERVER" ADDLOCAL="SQL_Engine" SQLAUTOSTART=1 SQLBROWSERAUTOSTART=1 SQLACCOUNT="NT AUTHORITY\SYSTEM" SECURITYMODE=SQL SAPWD="****" SQLCOLLATION="SQL_Latin1_General_Cp1_CI_AS" DISABLENETWORKPROTOCOLS=1 ERRORREPORTING=0
1/27/2015 8:23:48 AM: WOW64 key name does not exist 
1/27/2015 8:24:05 AM: Found C:\PROGRAM FILES (X86)\MICROSOFT SQL SERVER\90\SETUP BOOTSTRAP\SQLSVAL.DLL
1/27/2015 8:24:07 AM: Found C:\PROGRAM FILES (X86)\MICROSOFT SQL SERVER\90\SETUP BOOTSTRAP\MICROSOFT.SQLSERVER.NOTIFICATIONSERVICES.UPGRADEADVISOR.DLL
1/27/2015 8:24:07 AM: Found C:\PROGRAM FILES (X86)\MICROSOFT SQL SERVER\90\SETUP BOOTSTRAP\MICROSOFT.SQLSERVER.SSTRING.DLL
1/27/2015 8:24:07 AM: Found C:\PROGRAM FILES (X86)\MICROSOFT SQL SERVER\90\SETUP BOOTSTRAP\BPA\BPACMD.EXE
1/27/2015 8:24:07 AM: Found C:\PROGRAM FILES (X86)\MICROSOFT SQL SERVER\90\SETUP BOOTSTRAP\BPA\SQLSORT.DLL
1/27/2015 8:24:23 AM: Found C:\PROGRAM FILES (X86)\MICROSOFT SQL SERVER\90\SDK\LIB\X86\OPENDS60.LIB
1/27/2015 8:24:38 AM: Completed execution of (SQL Express) C:\Users\Public\UPS\WSTD\INSTALLATION_18_0_27_0\DB\SQLEXPRESS\SQLEXPR.EXE
1/27/2015 8:24:38 AM: C:\Users\Public\UPS\WSTD\INSTALLATION_18_0_27_0\DB\SQLEXPRESS\SQLEXPR.EXE completed with a code of  997
1/27/2015 8:24:38 AM: Preparing to copy SE log files into install log folder.
1/27/2015 8:24:42 AM: *******!!!!!!!!!!!! ATTENTION!!!! SE INSTALL DID NOT RETURN SUCCESS. THE RETURN CODE IS 997
1/27/2015 8:24:42 AM: PLEASE  CONSULT MICROSOFT ARTICLE http://support.microsoft.com/kb/290158 FOR ERROR CODES
1/27/2015 8:24:42 AM: Starting SE Instance
1/27/2015 8:24:42 AM: StartServer: Return Code =  -2147023836 Error Text = [SQL-DMO]Service Control Error:  The specified service does not exist as an installed service.

1/27/2015 8:24:42 AM: SEInstall.InstallExpress() - Start Server Reported Failure, still will try to connect
1/27/2015 8:25:32 AM: SQLServerInfo: Return Code =  -2147221504 Error Text = [Microsoft][ODBC SQL Server Driver][DBMSLPCN]SQL Server does not exist or access denied.
[Microsoft][ODBC SQL Server Driver][DBMSLPCN]ConnectionOpen (Connect()).
1/27/2015 8:25:32 AM: Abort - Failed to Connect to SE Server
1/27/2015 8:25:32 AM: Uninstalling SE Server
1/27/2015 8:25:32 AM: SEInstaller.InstallExpress() - Failed to install UPS Database Server.  Please restart your system and install UPS WorldShip again.

I called UPS Tech Support and they remoted into the laptop, but they couldn't get it to run either -- they chalked it up to a corrupt registry issue and said to wipe the disk and re-install from scratch.

 

Any ideas would be greatly appreciated!

 

Thanks,

gpence



BC AdBot (Login to Remove)

 


m

#2 gpence

gpence
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:44 PM

Posted 27 January 2015 - 03:49 PM

I decided to reformat the disk and deploy the image again. I loaded Win 7 Pro SP1 and ran Windows Update. I then ran the UPS WorldShip 2015 installer before installing anything else. It is well over 50% complete now (far past the earlier error with SQL Server Express) so it looks like it was either (1) some sort of corruption in the registry, or (2) a system modification made by one of our other applications (which had originally been installed prior to WorldShip, but which I have not installed yet).

 

I'll make a note to install WorldShip prior to other applications on future implementations and chalk this up to an unknown error which prevented a successful install.

 

gpence


Edited by gpence, 27 January 2015 - 03:50 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users