Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Permissions on files from recovered HD


  • Please log in to reply
4 replies to this topic

#1 Bob Follansbee

Bob Follansbee

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:39 AM

Posted 26 January 2015 - 09:12 PM

I'm not sure this is the correct forum, but...

Our old XP computer died about 2 days before we had planned to replace it with a new system. I salvaged the HD and bought a HD enclosure to create an external HD to retrieve some of the files from the older computer and maybe use it as a backup. I have plugged it into a couple of different computers now for which I am the admin, and it allows me access to some files and folders, but many folders and files seem to be blocked from me, e.g.,  "you do not currently have permission to access this folder." I have tried changing various sharing and security settings for each folder and file, but it doesn't seem to help. I'm not sure I really understand this whole process. Any ideas here?

 

Thanks.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:39 AM

Posted 26 January 2015 - 09:25 PM

You need to take ownership of the drive. See this video.

 

And Welcome to BC


Edited by JohnC_21, 26 January 2015 - 09:25 PM.


#3 Bob Follansbee

Bob Follansbee
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:39 AM

Posted 27 January 2015 - 02:25 PM

Thanks for the quick response, John. I think I had done most of the steps involved, and I followed the video this time, but maybe because it is for Vista, and I am using Win 8.1 (with an old XP formatted drive) - sorry I didn't fully specify that before, the tabs in the Advanced Security window did not have one for 'Owner.' Mine are: Permissions, Share, Auditing, and Effective Access. At the top of that Advanced window there are lines for:

 

Drive:

Owner:

 

Next to owner is the name of my computer (bobPC) which is listed as the admin: Administrators (bobPC\Administrators). This would seem to suggest that I AM the owner, no?



#4 JohnC_21

JohnC_21

  • Members
  • 24,033 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:39 AM

Posted 27 January 2015 - 02:40 PM

I would think that would be the case but then again I can't think of any other reason than an ownership problem on the drive. Did you give yourself full permissions when you right click a folder and check the security tab?

 

Type CMD in the search box > Right click run as administrator then type

 

takeown /F X: /R /D Y    X: is the drive letter of your external drive. Make sure you have the correct letter.

 

If that does not work I think you would need to use a live linux CD to do the transfer. You would need to disable SecureBoot in BIOS. Let me know if you want to go this way and I will give instructions.



#5 Bob Follansbee

Bob Follansbee
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:39 AM

Posted 28 January 2015 - 08:23 PM

John - I believe that 'takeown' (and then in concert with 'icacls') has done the trick. I'll know definitively when I have to access specific files that I haven't anticipated to now, but so far, so good. Thanks so much for your help with this.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users