Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

wkscli.dll and unable to run Chrome or Firefox


  • Please log in to reply
1 reply to this topic

#1 beckyb79

beckyb79

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:13 PM

Posted 26 January 2015 - 07:42 PM

A friend recently bought a new laptop and gave me her old one. I know she had problems with it in the past, and at one point she faced the "blue screen of death." She took it to get fixed, and the guy basically wiped everything off of it and updated it from XP to Windows 7. He also put Avast on it. Anyway, my friend didn't trust it anymore, so once she was able to afford another one she handed this one over to me. Within two days of having the laptop (and not really doing anything but browsing MSN's homepage), Avast started popping up notifications. The two I recall were pertaining to Yahoo Toolbar and Google Update... I think. Anyway, I just clicked for it to do the "recommended" option, and it deleted them. Then I proceeded to watch Netflix for about an hour, and everything seemed to be working fine... until I tried to close the screen and shut the laptop down. Everything froze and nothing seemed to help. I couldn't even get the Task Manager to come up, so I had to hold the power button down and force it to shut down. When I started the laptop again, I couldn't get Chrome or Firefox to load.

 

When I click to open Chrome it says: C:\Windows\system32\wkscli.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support." When I try to open Firefox, it says, "Couldn't load XPCOM."

 

I tried uninstalling Chrome and Firefox and redownloading them. Yeah, that didn't do anything. lol I still had the same problem. So, I deleted them and then...

 

So, this is where I decided to be stupid and try to fix it myself when I'm not familiar with the problem. I can fix some simple stuff, and Google and I have always been pals, so I figured I would Google a quick fix and have the laptop up and running in no time. Wrong! I found a blog where someone had a similar problem, so I decided to follow their steps. (Just wait, I get dumber.) They mentioned using a dll downloading website to download wkscli.dll and to save it to my desktop, Did that, then I was led to download and install UBUNTU, delete the corrupt wkscli.dll file and replace it with the one I've saved to my desktop. Yeah, that's no joke. Once I realized I had no idea how to access my Windows files while in UBUNTU, I knew I should call it quits. So I decided to remove UBUNTU from the laptop and realized it's not as simple as clicking uninstall. lol Everything I read said you had to have a Windows recovery media or installation CD. I don't have that. As I mentioned before, the laptop was a gift, so I don't have any CDs to go along with it.

 

Then I got the bright idea to do a system restore. :unsure: Dumb move, didn't help, and I still had UBUNTU. Although, it did resurrect Chrome and Firefox. I have no idea what I was thinking. Anyway, I found a guy on Youtube who (thankfully!!) gave me a relatively simple way to get it off of the laptop. After I finally was able to remove all of the UBUNTU stuff, I was still stuck with the original problem... along with a bunch of crazy new popups because Avast, apparently, HATES system restores. I finally was able to uninstall Avast (it was the only way to get the REPEATED popups from going crazy. No amount of closing them out would make them go away.) Anyway, now I'm stuck using Internet Explorer which, at least, that's something, but I really would like to get Chrome and Firefox up and running. Also, when I try downloading or updating anything, it often gives various error messages and closes out. Someone pleaaaaase help!
 



BC AdBot (Login to Remove)

 


m

#2 Go The Power

Go The Power

  • BC Advisor
  • 525 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:43 AM

Posted 29 January 2015 - 01:51 AM

Hello,

It is a good thing you didn’t try and replace that file manually.

Have you installed another AV since uninstalling AVAST?

Lets check your machine for corrupt files.

SFC /SCANNOW
  • Click on the Win7Orb_zps4dae3b32.jpg button. Inside the search box type in CMD
  • Right click on CMD => Choose Run as Administrator
  • Inside the Command Prompt windows copy and paste the following command SFC /SCANNOW
  • Please wait for this to Finish before continuing with the rest of the steps.
Convert CBS.log to CBS.txt
  • Click on the Win7Orb_zps4dae3b32.jpg button => Inside the search box copy and paste the following command:
    cmd /c copy %windir%\logs\cbs\cbs.log "%userprofile%\Desktop\cbs.txt"
  • Press Enter
  • Once this has completed please go to your Desktop and you will find CBS.txt => Please upload CBS.txt to this thread
Please Note:: if the file is too big to upload to you next post please upload via Dropbox or One Drive




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users