Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Server 2012 R2 looses connection to default gateway


  • Please log in to reply
15 replies to this topic

#1 Jeffmikers

Jeffmikers

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 26 January 2015 - 11:10 AM

Hi all. New forum member here... I'm hoping this brain trust can help shed some light on a weird issue we're having.

 

We have a relatively small server farm (~25 servers) running in a hosted VMware environment. We recently stood up our first instance of Server 2012 R2 (majority of the network is 2008).

 

The new 2012 R2 server loses connection to its default gateway on a fairly frequent basis; once every 24-36 hours. When investigating, the NIC is still enabled and the IP parameters are still correct, but we have no layer 3 connectivity to the local network, therefore no connectivity to remote networks. Running through the native troubleshooting/repair feature of Windows or rebooting temporarily resolves the problem.

 

Some facts about this case:

 

  • This is member server in a single domain/forest with a functional level at 2008 native
  • There is one local domain controller, one remote via a site to site VPN
  • Wireshark indicates layer 2 is still active (periodic broadcasts are received)
  • There are no significant Event Log entries indicating an error leading up to the issue
  • The routing table looks normal after the event has occurred

 

Some troubleshooting steps taken so far:

 

  • Added a new VMWare NIC and moved the IP address to it
  • Dropped/re-added the server from the domain

 

 

It should also be noted that the only real role/function of this server is IIS hosting a single and fairly low volume public web site.

 

Any ideas where I should go next?

 

 

 



BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:02 PM

Posted 26 January 2015 - 11:56 AM

Make sure you have turned off power management of the network interface or it will be "put to sleep" and lose connectivity.



#3 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 26 January 2015 - 01:42 PM

The server was set to "Balanced". I've changed that setting to "High Performance".

 

I'd be shocked if this were the actual cause. When the event occurs, we have to login to the Console via VMware. At that point, the system would no longer be "asleep".

 

I'm certainly open to ALL perspectives, though.



#4 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:02 PM

Posted 26 January 2015 - 03:59 PM

Changing the setting as recommended isn't going to hurt anything and its a well documented solution for systems that lose network connectivity as you describe.

Have you reviewed the event viewer logs?



#5 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 26 January 2015 - 04:27 PM

Yes. I've reviewed the Event Logs. Thoroughly. There is no log entry leading up to the loss of connectivity. I've changed the power settings and at this point, will sit back and see if it happens again.



#6 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:02 PM

Posted 27 January 2015 - 12:08 PM

Is the switch this server is plugged into a managed one?  If so you would want to be looking at the port stats for that connection.



#7 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 27 January 2015 - 12:15 PM

I'm sure the physical switch is a managed one, but this is a VMware guest hosted by a 3rd party. More over, if it was a network issue with the server as seen on the physical switch port, I'd likely see network issues on all VMs traversing that same path.

 

I stumbled across a setting on the NIC last night: Allow the computer to turn off this device to save power

 

This was enabled. I've disabled it and have had approximately 16 hours of uptime.... fingers crossed.



#8 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:02 PM

Posted 27 January 2015 - 01:11 PM

stumbled across the setting?  That is the one I was referring to that you were so skeptical about.

 

"if it was a network issue with the server as seen on the physical switch port, I'd likely see network issues on all VMs traversing that same path.."

How many VMs do you have tied to this physical port?

Are you once again being so skeptical you won't even check the port stats?



#9 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 27 January 2015 - 01:54 PM

If you would have read my post you would have seen that I was skeptical of a generic "High performance" power plan that makes references to shutting down the HDD, IE Java Script Timers, USB power settings, etc. Nowhere in those Power Options does it mention NIC availability. I said I was skeptical of finding a solution in the Power Options... Not once did I say I was skeptical of your suggestion. It wasn't until yesterday evening when I "stumbled across" the power management settings you referred to.

 

I'm not sure why you found it necessary to have a pointed and sarcastic response. This is a friendly forum on a topic that may be of use to people in the future. That be said, I'll bring the audience back to their regularly scheduled programming.

 

Approximately 25 guests. The support request has been opened requesting their analysis of the physical switch port.



#10 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:02 PM

Posted 27 January 2015 - 03:17 PM

:-)  "I'd be shocked if this were the actual cause."  I don't know how else to read this statement but as skeptical.

 

That aside, another place to consider checking is in the Bios power settings.  If enabled they can have the same effect.

How much ram does this server have?

How much memory allocated to the host and to the VM's?

 

Reason I ask is given the time period of 24 to 36 hours I have to wonder if the vm isn't getting properly swapped in memory leading to a memory leak/incomplete load.

 

If you find there are port errors the recommendation is to set the nic and port to static not auto.  For example both nic and port would be set to gig and full duplex so auto negotiate doesn't come into play.



#11 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:04:02 PM

Posted 28 January 2015 - 01:19 AM

Bios settings would be generic VMWare ones with the guest, very basic settings.

I cant for the life of me think why a default server setup would have the NIC set to sleep after certain times, it certainly wouldnt be 24-36 hour intervals, it would be at 90 minutes i would suspect.

 

Do you have heart beats enabled with the vsphere server enabled?

if there is other servers using the same physical NIC and to the same switch port then i doubt it to be a manged switch issue hey.

Sounds like a 2012 server vmware enviroment issue, what version of vmware are you using as the host mate?

 

I think Wanderer was talking about using ncpa.cpl in run and right click the Nic and goto properties/configure/powermanmagement?



#12 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 02 February 2015 - 08:38 AM

Seems like it was the power settings on the NIC. We've been trouble free for several days now. Why on earth would a server default to allowing the OS to shut down the NIC is beyond me, but I digress.

 

Case closed.

 

 

Thanks Wand3r3r!



#13 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:02 PM

Posted 02 February 2015 - 11:57 AM

Glad you worked it out. I have wondered about it and number of other aspects of Microsoft :-)  Best of luck



#14 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 07 March 2015 - 07:04 PM

Sigh.

 

This problem has surfaced again. The server seems to be dropping it's network connection to the default gateway again.

 

I verified the NIC has it's Power Management settings configured so the "Allow the computer to turn off this device to save power" feature is disabled.

 

For grins, I added a new virtual NIC, moved the IP config to it, and disabled the above setting. No joy.

 

I noticed when creating a new Ethernet adapter in VMWare I can choose "E1000, VMXNET 2 (Enhanced), and VMXNET 3".  I'm not sure what the difference is here. I'm setting it up as an E1000.

 

Any more ideas?



#15 Jeffmikers

Jeffmikers
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:01:02 AM

Posted 08 March 2015 - 02:49 PM

I found a promising lead here: http://hardforum.com/showthread.php?t=1757236

 

I'm changing the NIC to a VMXNET 3. Let's see if this works.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users