Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 home premium file permission issues


  • Please log in to reply
1 reply to this topic

#1 cbcac

cbcac

  • Members
  • 79 posts
  • OFFLINE
  •  
  • Local time:06:40 AM

Posted 25 January 2015 - 02:59 AM

Please help me I am about to pull out my hair out.  Warring if you are reading this and want to try it to fix your permission problems do not follow the directions below.  I do not suggest it at all!!!

My hard drive started to fail on my Dell XPS computer running Windows 7 Home Premium.  Dell sent me a new hard drive under warranty.  I was able to connect an external drive to my old drive and copy the items that I wanted.  Except my 7GB Outlook PST file which I really wanted.  It appears to be damaged and I was trying some different things to try to repair it (that is a long story).  If I ever get past this hump I still need PST help too. 

So here is what I did.  Please stick with me I know it is long.

 
1.  After backing up the files from the old drive I physically removed it from the system.

 

2.  I hooked up the new drive to my system and loaded all of the programs on it that I needed. 

 

3.  I attached the old drive and the new drive to the system to see if I could open/repair the Outlook PST file that was on the old drive using the new drive’s copy of Outlook. 

 

4.  I realized I didn't have permission to access the files on the old drive that I wanted so I did a lot of reading on Google.  I honestly can't believe that Microsoft made this sooooo impossible. 

 

5.  I found that I could run F:\Users>TAKEOWN /F F:\Users\Administrator\ /R /D Y (All refernces to F: are just a place holder for the drive letter I really used).  I ran it on the old hard drive from the new hard drive. 

 

6.  The document I found on Google said to say yes to the question "Do you want to replace the directory permissions with permissions granting you full control ("Y" for YES, "N" for NO, "C" for CANCEL)?"  I did a lot of reading about this before clicking yes but apparently not enough because I later read that wasn't the best choice. 

 

7.  Next it said to run this F:\Users>ICACLS "F:\Users\Administrator" /reset /T.  Here is where things get really bad.  I rebooted between these two steps and I ended up running just this part F:\Users>ICACLS "F:\Users\Administrator" /reset /T on the NEW drive from the old drive!!  I didn't realize it booted up the old drive first.   

 

8.  Next I went back and booted from the new drive which I was supposed to do before.  I noticed right away that my mistake had caused some errors.  I was sick but decided to try to finish my first project before trying to start a new repair process.  I ran F:\Users>ICACLS "F:\Users\Administrator" /reset /T on the old drive from the new drive.  

Now I am getting some strange behavior on bootup on the new drive due to it not having permission to access its own files (just makes me sick to type that to be honest).  I also can not open any files to speak of.  I can see that everything is here and even some file folders that would not open before on the old drive are now visible and they open but the actual files do not open due to permission issues..  I see thumb of pictures but can't open the pictures etc. 

I just don't know what to do now.  I AM WAY, WAY in over my head.  Even the files on the external drive seem to be locked which I don't understand because I didn't include that drive letter in anything I did when I ran the things in CMD.  Oh how I wish I would have unplugged those before I started all of this.  I am assuming all of this has to do with the modified permissions on my currently running C drive (the new drive).  I did some looking around in the file properties/security tabs and things look ok but many options are grayed out.  I was thinking about running F:\Users>ICACLS "F:\Users\Administrator" /reset /T on my new drive from the new drive but I think at this point I need to just stop and walk away.

I just don't know what to do now but ask an expert before I make things even worse. 

 

Please HELP me!!!
 



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,242 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:40 AM

Posted 25 January 2015 - 09:32 AM

Try following these steps to take ownership of the entire hard drive (scroll down to the first reply): http://answers.microsoft.com/en-us/windows/forum/windows_7-system/permission-are-mesed-up-need-help-to-fix-it/6146ccc1-c5a6-4e04-a674-9a7a13b08de3

 

If that doesn't work, you may have to reinstall the operating system on the new drive.

 

As for the .pst issue, when pst files get that large they are prone to become damaged or corrupt. If you can sort out the permissions issue, try these steps to repair the pst file: http://support2.microsoft.com/kb/272227






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users