Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 8.1 computer stopped communicating with LaserJet 4 printer.


  • Please log in to reply
2 replies to this topic

#1 McGyver_

McGyver_

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Los Angeles Area
  • Local time:12:03 AM

Posted 20 January 2015 - 03:03 AM

I have an HP LaserJet 4 printer connected to my new Dell 3646 desktop computer.  The printer worked for a few months but now it doesn’t work. When I try to print through Microsoft Word the Word print function screen shows the HP printer as “Ready” but the printer does not print.    Windows gives me an error message: “The printer couldn't print Microsoft Word document - Test.docx”.  When I look in the control panel printer page the status is: “Error – Printing.”  The result is the same when trying to print through Notepad or printing a test page from the control panel.

 

The operating System is Windows 8.1.  The connection cable is a Centronics to USB cable.  I tested the printer with this cable on another computer and it worked.  The other computer is a Sony desktop using Windows XP.  I bought a new cable and I tried every USB port but the result is the same.

 

During the period when the printer stopped working, I was installing new programs of all sorts to get everything installed on this new computer.  

 

I ran the printer installation program from HP many times.  The computer control panel says that the printer is installed.  I ran the Dell diagnostic program and it passed all of the tests except the DVD drive test, because there was no disk in the drive.  The Dell log file shows the HP printer as installed.

 

I called Dell.  They ran the computer in remote control and concluded that the computer is working properly and the problem must be an obsolete driver.  I have reloaded the drivers from HP several times.  I called HP.  They referred me to a forum post which said to make sure the printer port is “USB001 Virtual Printer port.”  I made that change and it did not change the result.

 

I’m stumped.



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,887 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:03 AM

Posted 20 January 2015 - 07:28 PM

 

I ran the printer installation program from HP many times.

 

You don't say if you uninstalled the printer in between these times. The best thing to do in the event of a printer problem like this is to completely uninstall the printer - drivers and any other software associated with it - if necessary using the Revo Uninstaller to remove any left over fragments. You can get Revo from BC, a free download, here -

 

http://www.bleepingcomputer.com/download/revo-uninstaller/

 

Then, once the printer is completely uninstalled, re-install it. One other associated point - if you haven't still got a copy of the 'Quick install guide' download a copy from the HP web-site and follow it. Printers are notoriously fussy about the the installation procedure being done in the correct order. Believe me, it matters !

 

Chris Cosgrove



#3 Windont

Windont

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:03 AM

Posted 26 January 2015 - 05:12 PM

Did you try printing a test page? Go to the desktop, in the charms menu on the right click on Settings, Control Panel, under Hardware and Sound click on View Devices and Printers, right-click the LaserJet printer and select Printer Properties and not Properties at the bottom of the menu, click the Print Test Page button. If nothing prints then I'd try restarting the the Print Spooler service. Press Windows key and R at the same time. In the Run box type services.msc and press Enter. Scroll down the list to the Print Spooler service, right-click it and select Restart in the menu. Go back and try printing another test page after the service restarts.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users