Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Recent Experience Installing Symantec Workspace Virtualization On Windows 8


  • Please log in to reply
No replies to this topic

#1 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 16 January 2015 - 08:38 PM

For anyone with Windows 8, that is thinking of running Symantec Workspace Virtualization, here is my recent experience attempting to do that.

 

MXSQL8L.png

I've used S.W.V. (Symantec Workspace Virtualization) on and off for years. When Windows 8 came out I got a new computer, and decided not to install it. Recently I've decided I want to starting using it again. It's a very cool program.

I started by installing version 7.5.522, but quickly noticed 2 issues: inexistent excludes resulted in error1089 (which prevented removal of any existing layers), and excludes that use a letter drive were ignored (making it very difficult to get data out of a layer because it was all getting redirected). The reason for the inexistent excludes issue is that apparently Symantec has changed how excludes are handled, letter drives need an associated GUID now. This issue is resolved in future releases by simply preventing the user from adding inexistent excludes (which kinda sucks since there was a reason everyone did that), and in this release can be resolved by removing exclude entries for inexistent letters. The other issue about letter drive excludes being ignored seems to be due to the fact that this version is pre-Windows 8.

To resolve my issues I tried version 7.5.538 HF1, but that didn't work because again it's for Windows 7.

Next I tried 7.5 SP1 which does support Windows 8, but it BSODs my machine, and Googling around it seems that some others have this problem too. The exact error is "DRIVER_PORTION_MUST_BE_NONPAGED (fslx.sys)". The system did still boot in safe mode.

Unable to solve my issues, I decided to revert to 7.5.522, not use inexistend excludes, and mount all drives as mount points in a folder on my OS drive so that no letter would be used in the exclude. This got around the ignored exclude issue, but resulted in layered applications unable to save data to my drives due to unresolvable permission issues. At this point I was pretty furious, and gave Symantec several unpleasant nicknames.

After days of Googling I stumbled upon another version 7.5.760 SP1 HF1 while reading about a case similar to mine. This is what I'm running now. It supports
Windows 8, doesn't cause BSOD, excludes with letter drives aren't ignored, and inexistent excludes cannot be added so there is no 1089error.  I've yet to notice any problems with this release. Of course I haven't had it up and running very long so it's possible there are issues yet to be uncovered. I really wish Symantec had this version easier to find.

If you plan to run S.W.V. on Windows 8, make sure to use a version that supports Windows 8, backup your OS first in case you get an unrecoverable error.



BC AdBot (Login to Remove)

 


m



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users