Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Web Deploy from Visual Studio is Unauthorized


  • Please log in to reply
2 replies to this topic

#1 kmccmk9

kmccmk9

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:09:14 PM

Posted 11 January 2015 - 09:06 PM

Hello all,

 

Sorry about the weird topic title, I was trying my best to sum it all up in one sentence. Alright so I have a successful installation of Windows Server 2012 R2 with Microsoft IIS installed. I have configured one website "Test Site". I have also enabled/installed the web deploy tool for IIS. The steps I then followed were to right click on the site I want to deploy to, hover deploy and choose to Configure Web Deploy Publishing. In the resultant dialog I have the following information filled in:

 

Username: WIN-MGQ8FQSB86P\Administrator

Publish URL: https://WIN-MGQ8FQSB86P:8172/msdeploy.axd

 

I then clicked Setup. I get a successful confirmation message and take the new file created over to my dev box. On my dev box, inside Visual Studio 2013, I right click my project and choose Publish. In the resulting dialog I choose to import my Publish Profile. After I locate the file it pre-fills the information for me except for the password. I put in the password and choose to Validate Connection. These are the results of that test:

Web deployment task failed. (Connected to the remote computer ("win-mgq8fqsb86p") using the Web Management Service, but could not authorize. Make sure that you are using the correct user name and password, that the site you are connecting to exists, and that the credentials represent a user who has permissions to access the site.  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_USER_UNAUTHORIZED.)

Of course I've gone to that link and tried just about everything. I guess on an interesting note, if I remove the 's' from https in the Publish URL it times out but doesn't necessarily fail. Or at least not for the same reason. Any help you can give is much appreciated. I've been trying to get this to work for a few days and I'm out of things to try.

 



BC AdBot (Login to Remove)

 


#2 x64

x64

  • Members
  • 352 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London UK
  • Local time:02:14 AM

Posted 12 January 2015 - 01:54 AM

Check that you have the "Windows Authentication" feature enabled in IIS (you do his through the main server Add Roles/Features  wizard).

 

x64



#3 kmccmk9

kmccmk9
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:09:14 PM

Posted 13 January 2015 - 11:21 PM

Check that you have the "Windows Authentication" feature enabled in IIS (you do his through the main server Add Roles/Features  wizard).

 

x64

Hi, thanks for the suggestion. I did enable Windows Authentication and restarted the IIS server. Unfortunately I am still getting the same error.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users