Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Enabling and disabling Java


  • Please log in to reply
4 replies to this topic

#1 JoeWatson

JoeWatson

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Local time:01:19 PM

Posted 03 January 2015 - 04:50 AM

I have  to use Freemind software which I understand is a desktop application. However , I have to install Java to use Freemind.

 

I've read so much about the vulnerability of Java I'm not sure what to do. My OS is Win 7 Pro and I use Firefox 34.0.5 and Google Chrome. I also have IE11 installed but rarely use it.

 

I would very much appreciate some advice  and guidance. I hope I'm in the right forum with my query!



BC AdBot (Login to Remove)

 


#2 rp88

rp88

  • Members
  • 2,983 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:19 AM

Posted 03 January 2015 - 02:58 PM

You can install it and then under the Java control panel (found under windows control panel once java is installed) you tick the "disable java content in the browser" box (or it might be untick the "enable java content in the browser" box i can't remember which way round the option is described). That way Java will only function as a desktop application for working with programs which you have installed and you will limit any vulnerabilities it causes. Also make sure to go through all your browsers and disable the java plugin juts incase the tick box alone was not enough. And keep Java up to date, you ought to change the settings on it's updater to check daily rather than the weekly or monthly which is set by default.
Back on this site, for a while anyway, been so busy the last year.

My systems:2 laptops, intel i3 processors, windows 8.1 installed on the hard-drive and linux mint 17.3 MATE installed to USB

#3 JoeWatson

JoeWatson
  • Topic Starter

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Local time:01:19 PM

Posted 04 January 2015 - 02:08 AM

Many thanks. I have unticked the enable Java content in the browser box and checked Google Chrome and IE11, The Enable box was cleared for each one..  There are a lot of boxes in the Java Control Panel which I have left alone with the default settings. I hope this is the right thing to do.



#4 rp88

rp88

  • Members
  • 2,983 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:19 AM

Posted 04 January 2015 - 11:53 AM

What you have done is good, but there is more you can do. Go into the java control panel again, put it's security level right up to maximum (it is usually somewhere in the middle by default).

On the page i have linked to scroll down to the section "How to Disable the Java Plug-in" and look at the picture of the control panel, make sure that the "Enable Java Content In The Browser" is not ticked and security is at "very high". Then go to the update tab and from there set the update settings to check daily. The second link gives more details of the same kind.

http://www.howtogeek.com/198300/oracle-cant-secure-the-java-plug-in-so-why-is-it-still-enabled-by-default/?PageSpeed=noscript
http://www.howtogeek.com/134353/how-to-protect-yourself-from-java-security-problems-if-you-cant-uninstall-it/?PageSpeed=noscript

Sorry, I misread your post, I notice you already have disabled from the browser via that option in the java control panel, but there is still the update setting you can alter.

Edited by rp88, 04 January 2015 - 09:13 PM.

Back on this site, for a while anyway, been so busy the last year.

My systems:2 laptops, intel i3 processors, windows 8.1 installed on the hard-drive and linux mint 17.3 MATE installed to USB

#5 JoeWatson

JoeWatson
  • Topic Starter

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Local time:01:19 PM

Posted 04 January 2015 - 08:36 PM

Just to know I've done everything I can to avoid problems with Java:  I have detailed the settings below:

 

Java Control Panel:

 

General:

 

Network settings:  Use browser settings

Temporary File settings;  Keep temporary files on my computer

Disk Space: Select the compression level for JAR files:  None

Set the amount od disk space for storing temporary files:  32768 MB

 

Update:

 

Notify me before downloading

Check for updates automatically

Advanced settings: Daily 7 pm

 

Java:

View and manage Java runtime version and settings for Java applications and applets: Greyed out

 

Security:

 

Enable is unticked

Security level for applications not on the Exceptions List:  High. (Unable to set at very high with the radio button)

Exceptions site list:  Do I need to add Freemind to this as it's a desktop application?

 

Advanced;

 

I have not done anything on the list.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users