Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Toshiba L850D AMD Graphics cards unusable/not detected by computer


  • Please log in to reply
1 reply to this topic

#1 Atrocious9

Atrocious9

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:02 AM

Posted 02 January 2015 - 12:37 AM

Hello, I own a Toshiba L850D laptop with the following probem:

My Graphics cards are essentially unusable and I can't play any games whatsoever. I'm not even sure if the computer itself detects them. When I attempted to play a video game of any kind, a general message appears telling me that my Display Adapters aren't quite up to snuff/ lack a required capability, regardless of me being able to play them in the past.

They dont detect any drivers I install and one Dispay Adapter in particular is bogged down with the message:

This device cannot start. (Code 10)

They have also both been renamed in the Device Manager as Standard VGA Graphics Adapter.  I don't take that as a good sign.

 

Specs:

OS: Windows 7 Home Premium 64 bit

CPU: AMD A6-4400M (Dual Core 2.7 GHz - 3.2 GHz, 1600MHz FSB, 1MB L2 Cache)

Graphics: Dual Graphics AMD Radeon™ HD 7610M 1GB + AMD Radeon HD 7520G (with switchable graphics)

Memory: 4GB RAM

Storage: 500GB Hard Drive (currently 372GB avalable)

Chipset: AMD Hudson M3

 

I've tried uninstalling and reinstalling the graphics drivers multiple times from the computer manufacturer (Toshiba), I had attempted to download them from AMD but later I had read from their website that Toshiba machines don't tend to accepted generic drivers and thus require you to download the drivers from Toshiba. I have also been using DDU (Display Driver Uninstaller) to ensure I have been properly uninstalling the drivers.  I have also tried Uninstalling the Display Adapters and reinstalling via the Device Manager, no luck.

Trying to Update the drivers via the Device Manager don't work either.

These problems have persisted depsite system restores and Factory Resets.

I used to get BSODs from trying to fix the problem but not any longer.  I take that as a good sign.

 

Any help or suggestions would be appreciated.


Edited by Atrocious9, 02 January 2015 - 12:47 AM.


BC AdBot (Login to Remove)

 


#2 Atrocious9

Atrocious9
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:02 AM

Posted 06 January 2015 - 12:47 AM

So I took it in to a repair guy for fixing.

And it's deemed unfixable, so Let's consider this topic closed.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users