Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

The possessed touchpad.


  • Please log in to reply
31 replies to this topic

#1 Kitty-Nin

Kitty-Nin

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 08:32 PM

Alright, so I have been having a very strange problem with the touchpad on my netbook. I have an old-ish ASUS Eee PC Seashell Series, with windows 7 starter on it. Since day one of owning it (from new) I've used a USB wireless mouse and have the setting for the built-in touchpad set to be disabled whenever a USB mouse is being used.

It has worked fine up until a few weeks ago, when the touchpad suddenly began giving me trouble (aka, working). The problem is that with this small computer and incredibly over-reactive pad (even with all the sensitivity settings turned to their lowest) the touchpad goes utterly nuts while trying to type. It's an ELAN Smart-Pad.

Anyway, so I've checked the settings in control panel>mouse and it's still set to be turned off when the USB mouse is in. I've also tried to disable it from those settings, and while it lets me check the box and hit apply, nothing actually changes.

A bit of googling gave me the idea of just deleting the drivers for the touchpad. The first time I did this it worked after restarting and worked fine for a week or so until I had to actually shut the computer down rather than merely hibernating it. Now, whenever I go in and uninstall the drivers from the device manager, upon the restart it automatically re-installs the drivers on its own.

I would really appreciate any input anyone has on fixing this, the issue is making my computer almost unusable. Typing this has taken at least twice as long as it should have due to the touchpad losing its mind constantly, and I'm out of ideas as to what to try next. I'm getting tempted to crack the thing open and try to unplug the touchpad from the motherboard, but this computer is really sealed up tight and I doubt that would go well.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 08:41 PM

Hello, and Welcome

 

Instead of uninstalling the device, Right click the touchpad in Device Manager and select Disable.



#3 Kitty-Nin

Kitty-Nin
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 08:55 PM

I do not have the option in my device manager for disable.

pni6vIy.png

 

I also have the settings under control panel>mouse set to disable, when the USB is plugged in, to be just plain old disabled period, and for the icon not to show in the taskbar (which it still does, with a big red X over it).

wvWnzWV.png


Edited by Kitty-Nin, 01 January 2015 - 08:55 PM.


#4 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 72,906 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:11:41 AM

Posted 01 January 2015 - 09:26 PM

See if THIS works.
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#5 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 09:33 PM

I don't know your exact model number but I looked at a Seashell manual and there are two ways to disable the touchpad. There is a button on the upper left of the computer above the Esc key that toggles the touchpad and also the Fn+F3 key combination.

#6 Kitty-Nin

Kitty-Nin
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 09:34 PM

Each time I press the Fn +F3 for the touchpad, it says 'Touchpad ON' every single time, it will not toggle to off. Also, no separate toggle button above escape for the touchpad on this model. Just the function key.

 

 

As for the second half of that article, I don't have a disable option under the properties tab, either. 

 

bGTtpJ3.png


Edited by Kitty-Nin, 01 January 2015 - 09:35 PM.


#7 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 09:40 PM

Can you disable it in BIOS?

#8 Kitty-Nin

Kitty-Nin
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 10:03 PM

@JohnC_21 I haven't tried that yet, unfortunately F2 does not take me to BIOS, it's taking me to the boot device selection screen. Will update if I figure out which key does take me to the BIOS.



#9 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 10:05 PM

When you get to the boot menu press Esc. Does that get you to BIOS? Edit: If Esc does not work press F2 again at the boot menu.

Edited by JohnC_21, 01 January 2015 - 10:06 PM.


#10 Kitty-Nin

Kitty-Nin
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 10:21 PM

Tried all of those, sadly. I found my model via command prompt, it's the 1015px, I'm currently looking through the manual to see if it tells me how the heck to get into BIOS on this thing.



#11 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 10:31 PM

What options do you get at the boot menu?

 

When the computer boots hold down a key. The BIOS may detect a stuck key and ask you to press F2 to enter setup.

 

Other people solved the BIOS issue by flashing the BIOS but that is a last resort as that can brick the computer if it goes bad. Is there a EZ-flash option in the Boot menu?

 

Edit: I looked up that model and Asus says to press F2 for BIOS.


Edited by JohnC_21, 01 January 2015 - 10:33 PM.


#12 Kitty-Nin

Kitty-Nin
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 10:40 PM

Finally did get into the BIOS, it took some real smashing on the F2 key (actually started doing it before it was finished shutting down this time, and that worked for whatever reason.) Anyway, my advanced tab looks slightly different, but it has a section for 'internal devices'. Sadly, there are only options for the USB 2.0 controller, LAN, and WLAN there. I checked every sub-menu n each tab just to make sure, but there are no options for pointing devices anywhere in my BIOS. Super disappointed, I thought for sure that would work. 



#13 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 10:45 PM

I'm out of ideas on this one, sorry. Hopefully somebody else can come up with some other ideas.



#14 Kitty-Nin

Kitty-Nin
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:11:41 AM

Posted 01 January 2015 - 10:52 PM

I hope so too. Thanks for trying.



#15 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:41 AM

Posted 01 January 2015 - 11:01 PM

I found this latest Elan driver but I can't confirm if it will solve the problem. I would create a restore point if you decide to install it. The latest version on the ASUS site for your ee-pc is Version V8.0.5.3

 

http://drivers.softpedia.com/get/KEYBOARD-and-MOUSE/Elantech/ASUS-Elantech-Touchpad-Driver-11509.shtml






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users