Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

System takes 15min or more at "Shutting down"...


  • Please log in to reply
16 replies to this topic

#1 latimer141225

latimer141225

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 26 December 2014 - 09:49 PM

This has only started in the last few weeks, and only happens less than 20 % of the time, and not at any particular time of day.

 

HDD activity falls to near-nil for most of the time, then picks up again before finally turning off.

 

I'm afraid this will happen when my father, with whom I share this system, wants to use it, and wonders why I didn't just, say, put it in sleep mode.

 

HP CQ2014, Win7 Home Premium x64, faithfully updated. HDD about 20-25% capacity.

 

B


Edited by latimer141225, 26 December 2014 - 09:55 PM.


BC AdBot (Login to Remove)

 


m

#2 Allan

Allan

  • BC Advisor
  • 8,477 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:08 AM

Posted 27 December 2014 - 07:42 AM

Here are some steps you can take to try to speed up Windows Shutdown. Before editing the registry, be sure to either create an image of your system partition or backup the registry. If you don't know how, please ask.

 1) Make sure "clear pagefile at shutdown" is not enabled:
start - run - regedit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

Set ClearPageFileAtShutdown value to 0


2) Start - Run - Regedit
Navigate to the following Registry key:
HKEY CURRENT USER\Control Panel\Desktop
Double click on the AutoEndTasks entry and replace the 0 with a 1 in the Value data text box

For the next two, if the dword value indicated does not exist, create it:

Double click on the WaitToKillAppTimeout entry in the right pane and change the Value data to 2000

Double click on the HungAppTimeout entry in the right pane and change the Value data to 1000

Reboot

3) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Right-click on WaitToKillServiceTimeout and change it to 2000


#3 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 29 December 2014 - 04:49 PM

So far, so good. Thanks for your help.

 

B



#4 Allan

Allan

  • BC Advisor
  • 8,477 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:08 AM

Posted 29 December 2014 - 06:23 PM

You're welcome.



#5 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 01 January 2015 - 10:00 AM

Hate to have to reopen this, but after updating several drivers, the system basically hung at "Shutting down..." again. ZERO disk activity. Manually turning it off and back on was the only (happily effective) solution.

 

Appreciate further help on this.



#6 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 AM

Posted 01 January 2015 - 10:25 AM

Could be a number of things -- a process or application that refuses to close, problems with drivers or the operating system, applications that are missing updates, etc. Try running through these and see if they identify the issue:

 

http://www.makeuseof.com/tag/windows-taking-forever-shut-try/



#7 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 01 January 2015 - 12:07 PM

Checked all of these, twice, except the hard drive's health for of which as of now I don't have, and can't remember, an application compatible with this system (unless of course the company doesn't allow SMART evaluation of its hard drives)



#8 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 AM

Posted 01 January 2015 - 12:09 PM

What sort of hard drive do you have? How old is it?

#9 Allan

Allan

  • BC Advisor
  • 8,477 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:08 AM

Posted 01 January 2015 - 01:41 PM

Does the same thing happen from safe mode? If not, try a selective startup to identify the problematic process:

 

Open msconfig and on the General tab choose "selective startup" (uncheck all three items) and reboot. Does the problem still occur? If not, start adding items back to msconfig one or two at a time, rebooting after each change, until the problem reappears and you'll have identified the offending process. This is clearly a time consuming procedure, but it is the best way to determine if some process loading with the system is the cause of your problem.
 
After you've isolated the cause, do not use msconfig to permanently disable the process. Instead, if it is a service go to START - RUN and type: services.msc (then press enter) and disable the service OR, if it a program, you can download & run a simple app such as Mike Lin's Startup Control Panel (http://www.majorgeeks.com/files/details/startup_cpl.html) to enable, disable, or otherwise manage startup programs.


#10 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 01 January 2015 - 03:33 PM

What sort of hard drive do you have? How old is it?

It's a Western Digital WD5000, and it came with the machine when we got it in Oct 2012.



#11 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 01 January 2015 - 03:38 PM

 

Does the same thing happen from safe mode? If not, try a selective startup to identify the problematic process:

 

Open msconfig and on the General tab choose "selective startup" (uncheck all three items) and reboot. Does the problem still occur? If not, start adding items back to msconfig one or two at a time, rebooting after each change, until the problem reappears and you'll have identified the offending process. This is clearly a time consuming procedure, but it is the best way to determine if some process loading with the system is the cause of your problem.
 
After you've isolated the cause, do not use msconfig to permanently disable the process. Instead, if it is a service go to START - RUN and type: services.msc (then press enter) and disable the service OR, if it a program, you can download & run a simple app such as Mike Lin's Startup Control Panel (http://www.majorgeeks.com/files/details/startup_cpl.html) to enable, disable, or otherwise manage startup programs.

 

It'll be likely tonight till I do this, as that's when this issue occurs most often (there was one time it happened during the day)

 

Mike's product looks familiar... I might have gotten it for a previous machine, and it doesn't mention compat with anything since WinXP. You or anybody test it on a W7?



#12 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:08 AM

Posted 01 January 2015 - 03:40 PM

I agree with Allan -- trying booting into safe mode and see if the shutdown problem occurs then.

 

If it does, I'd recommend a hard drive scan. Download the Western Digital diagnostics tool and run it: http://support.wdc.com/product/download.asp?groupid=612&sid=3



#13 Allan

Allan

  • BC Advisor
  • 8,477 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:08 AM

Posted 01 January 2015 - 06:29 PM

It does work with ALL versions of Windows (including 8.1). However, it's hard to find now. Any similar startup app manager is fine (Autoruns is probably the best anywhere - and it's free - but it's a bit more "all inclusive").



#14 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 01 January 2015 - 08:51 PM

I have Autoruns here... used it to find something stealth within the last few weeks.



#15 latimer141225

latimer141225
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 04 January 2015 - 09:11 PM

 

 

Does the same thing happen from safe mode? If not, try a selective startup to identify the problematic process:

 

Open msconfig and on the General tab choose "selective startup" (uncheck all three items) and reboot. Does the problem still occur? If not, start adding items back to msconfig one or two at a time, rebooting after each change, until the problem reappears and you'll have identified the offending process. This is clearly a time consuming procedure, but it is the best way to determine if some process loading with the system is the cause of your problem.
 
After you've isolated the cause, do not use msconfig to permanently disable the process. Instead, if it is a service go to START - RUN and type: services.msc (then press enter) and disable the service OR, if it a program, you can download & run a simple app such as Mike Lin's Startup Control Panel (http://www.majorgeeks.com/files/details/startup_cpl.html) to enable, disable, or otherwise manage startup programs.

 

It'll be likely tonight till I do this, as that's when this issue occurs most often (there was one time it happened during the day)

 

Mike's product looks familiar... I might have gotten it for a previous machine, and it doesn't mention compat with anything since WinXP. You or anybody test it on a W7?

 

It was OK, that time. Like I said, the chances of this occurring are small. Am I going to have to log when it occurs over a period of many days till anyone takes me up on this?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users