Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Not sure what's wrong


  • Please log in to reply
1 reply to this topic

#1 agpeters1984

agpeters1984

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:07:52 AM

Posted 23 December 2014 - 11:03 PM

I'm trying to play video games on my PC I've tried Sim City, Oblivion and Starcraft 2 but the DVD-RW drive doesn't read the disc. DVD-RW drive shows up and when I double click it it opens the disc tray and says Insert Disc even though there is already the disc in there. Also today, Q: Drive showed up and it has never been there before. What could be wrong?



BC AdBot (Login to Remove)

 


#2 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:07:52 AM

Posted 24 December 2014 - 12:47 AM

You drive could be going out. Some of them are poorly constructed. I had an LG Blu-ray burner that only lasted 1 year and it stopped reading discs and any time I tried to burn a disc it would fail. How old is this drive? 


Gavin Seabrook

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users