Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


NO DISPLAY after booting

  • Please log in to reply
3 replies to this topic

#1 spanda


  • Members
  • 2 posts
  • Local time:06:54 PM

Posted 16 December 2014 - 12:16 PM

Initially, there use to be some RAM problem with Long beep sound in my PC(home configured few years ago). I cleaned and reseated in it's slot. It worked fine.  
Later i found that  the integrated ethernet port did not function. I got a new ethernet card at PCI slot. The new one was working fine. But i do not know whats wrong with the integrated port.
Few days later, there was not display in the monitor when i switched ON. I found the OS(win xp sp3) boots well and its working fine. I tried to connect to this system via teamviewer and it was successful. 
Tried rebooting the system. Unfortunately I got the same old RAM Problem(long beep sound). Again i removed it, undusted it and reseated it. now there is no Beep sound, no display either.  Also, unable to ping the system from LAN. No idea whether it is booting properly or not.
Juz checked the connection of two wires (as instructed at some website - 2 yellow, 2 black) at MotherBoard, tried disconnecting and connecting of HDD, CD-drive, BIOS Battery(waited for more than 10 mins). But no solution. Till this point, i could see the POST is proper (NO DISPLAY at the monitor but with the blink of the keyboard LED). 
Just to check, i removed CMOS battery and started the PC. No result. Now put the battery back and to my frustration i could not see the POST (no indications at the keyboard) as well which was working previously. 
Configuration: Mercury pi865d7 version 2.0, Intel celeron, win xp, Integrated VGA. 
Monitor & VGA cable working fine with other system. As NO DISPLAY, how should i proceed further? Kindly suggest me.

Edited by spanda, 16 December 2014 - 12:17 PM.

BC AdBot (Login to Remove)


#2 KingdomSeeker


  • Members
  • 458 posts
  • Gender:Male
  • Local time:08:24 AM

Posted 16 December 2014 - 01:10 PM

One beep could indicate a problem with Display Curcuitry. Are you using an integrated or PCI graphics card? If it's a PCI you might want to try reseating it.

#3 spanda

  • Topic Starter

  • Members
  • 2 posts
  • Local time:06:54 PM

Posted 17 December 2014 - 02:22 AM

Hi Kingdom seeker,  I'm sure that the Graphics card is Integrated rather than PCI.


Do you mean that I would get one Beep sound if there is any problem with display circuit? But i do not hear any beep sound.

#4 zingo156


  • BC Advisor
  • 3,333 posts
  • Gender:Male
  • Local time:08:24 AM

Posted 17 December 2014 - 08:44 AM

Make sure you have the computer unplugged from power while removing or moving any hardware...


Try 1 stick of ram in 1 slot at a time (remove all other ram sticks). Move it to the next slot until you have tried that stick in all slots by itself. If you still have no post, try a different stick of ram in each slot by itself. If you have issues with the stick in 1 particular slot (a no post for example) the slot may be bad. It is also possible you have a bad stick of ram instead of the slot being bad, in this case the ram stick should cause the same problem all slots.


You may have a memory controller issue in which case if you have 4 slots, 2 may not work. With intel it should be 2 slots next to eachother channel 1 might be slot 0,1 and channel 2 might be 2,3. Trying with 1 stick at a time in all 4 slots is the best way to test everything.


If you never get a stable system with just 1 stick of ram in 1 slot (trying all sticks by themselves) try removing all non essential hardware to get into bios:


Disconnect pci cards, pci-e cards - except a video card unless you have onboard in which case use the onboard video and pull the video card, hard drives, dvd drives, disconnect all usb headers as well. You should only have the power supply, main board, 1 stick of ram in 1 slot, the cpu and cpu cooler connected. You can also plug in a monitor and keyboard. Now try to power on the machine. If at this point you have no post screen or video etc, unplug the computer and pull the stick of ram, power back on and listen for a post fault beep code, you will need to hook up a motherboard speaker to hear any post fault code.


If you get no response next: remove all of the components from the computer case and connect only non essential hardware outside of the case, place the motherboard on a non conductive surface, a wooden table will do fine. Then try to power on again, you can short the power button pins on the motherboard, don't worry this is exactly what the power button does. Just touch a metal item to both power button pins to try to power the mainboard when outside of the computer case.


While you have the computer apart, look for blown or bulging capacitors on the mainboard and video cards etc examples: https://www.google.com/search?q=bulging+or+blown+capacitors+motherboard&noj=1&source=lnms&tbm=isch&sa=X&ei=Iz_YU6aDLsS2yASnjoKwAQ&ved=0CAgQ_AUoAQ&biw=1031&bih=603 please report any caps you suspect may be bad, you can take a picture and post here if you are unsure.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users