Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can not run chkdsk


  • Please log in to reply
10 replies to this topic

#1 mikey11

mikey11

  • Members
  • 1,448 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Psychiatric Ward @ Beelitz-Heilstatten Hospital, Beelitz, Germany
  • Local time:04:41 PM

Posted 16 December 2014 - 09:12 AM

i am getting a corrupt file error messege and would like to run chkdsk,

 

i go to command prompt and type chkdsk c: /f /r after that i get.....

 

file system type is NTFS

can not lock current drive

chkdsk can not run because the drive is in use by another process

 

then something like, would you like to schedule chkdsk to run at the next startup, i type Y

 

it comes back and says chkdsk will run at the next startup,

 

i reboot the computer and chkdsk does not run,

 

i have tried many times and same result



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,014 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:41 AM

Posted 16 December 2014 - 09:38 AM

At a command prompt type the following, What was the output?

fsutil dirty query C:


#3 old rocker

old rocker

  • Members
  • 476 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:East Tennessee
  • Local time:10:41 AM

Posted 16 December 2014 - 09:48 AM

Hi

 

Try this...

 

Open a command prompt and type the following commands listed in bold

 

Type fsutil dirty set C:  press <enter> to execute the command.

 

Type exit  press <enter> to close the window.

 

This will set the volume as Dirty and chkdsk should run on the next reboot.

 

Reboot the computer.

 

 

 

Best of luck and Please keep BC posted!



#4 mikey11

mikey11
  • Topic Starter

  • Members
  • 1,448 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Psychiatric Ward @ Beelitz-Heilstatten Hospital, Beelitz, Germany
  • Local time:04:41 PM

Posted 16 December 2014 - 09:50 AM

 

At a command prompt type the following, What was the output?

fsutil dirty query C:

 

 

volume - c: is dirty



#5 JohnC_21

JohnC_21

  • Members
  • 24,014 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:41 AM

Posted 16 December 2014 - 09:55 AM

Follow old rocker's suggestion and set the bit to dirty. Then reboot.

 

Edit: I am not sure it will work because the OS has already set the dirty bit. There may be a way to force it but try old rocker's fix first.


Edited by JohnC_21, 16 December 2014 - 09:57 AM.


#6 mikey11

mikey11
  • Topic Starter

  • Members
  • 1,448 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Psychiatric Ward @ Beelitz-Heilstatten Hospital, Beelitz, Germany
  • Local time:04:41 PM

Posted 16 December 2014 - 10:11 AM

Hi

 

Try this...

 

Open a command prompt and type the following commands listed in bold

 

Type fsutil dirty set C:  press <enter> to execute the command.

 

Type exit  press <enter> to close the window.

 

This will set the volume as Dirty and chkdsk should run on the next reboot.

 

Reboot the computer.

 

 

 

Best of luck and Please keep BC posted!

 

 

still doesnt run :smash:



#7 JohnC_21

JohnC_21

  • Members
  • 24,014 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:41 AM

Posted 16 December 2014 - 10:23 AM

See if this works. Before doing this I would recommend you copy any important files to an external drive first. Even though it is rare, chkdsk can cause problems.

 

Download the Puppy linux 5.2.8 iso here if you do not have it. Burn the iso file and boot to the Puppy Desktop.  In the lower left of the desktop you will see your hard drive partitions labeled sda1... sda2.. if you have only one partition on the drive it should just be sda1

 

Open a Terminal (Rox) and type the following commands.

ntfsfix /dev/sdaX   <enter>  Where X is the partition number

Do this for every sdaX you have. After using the command, close out the terminal and exit Puppy. Reboot. Windows should start chkdsk.


Edited by JohnC_21, 16 December 2014 - 10:24 AM.


#8 old rocker

old rocker

  • Members
  • 476 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:East Tennessee
  • Local time:10:41 AM

Posted 16 December 2014 - 10:31 AM

If the above still doesn't get you any satisfaction...

 

Try this...

 

From a command prompt

 

Type: chkntfs /c C:\ press <enter> to execute the command

Type: exit press <enter> to close the window

 

This schedules chkdsk to be run at the next reboot if the dirty bit has been set

 

Reboot the system.

 

You can also refer here for more information...

 

http://support.microsoft.com/kb/160963


Edited by old rocker, 16 December 2014 - 10:32 AM.


#9 JohnC_21

JohnC_21

  • Members
  • 24,014 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:41 AM

Posted 16 December 2014 - 10:39 AM

Thanks for that old rocker. I remember chkntfs for disabling chkdsk but not for forcing it.



#10 mikey11

mikey11
  • Topic Starter

  • Members
  • 1,448 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Psychiatric Ward @ Beelitz-Heilstatten Hospital, Beelitz, Germany
  • Local time:04:41 PM

Posted 16 December 2014 - 11:41 AM

thanks for the help,

 

i managed to run chkdsk from hirens boot cd, although i dont know if that is as effective?

 

i will give the suggestions above a try after.....also good info to know for the future, thanks guys



#11 rhino1366

rhino1366

  • Banned
  • 524 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 25 December 2014 - 06:30 PM

Try setting a Check Disk scans from a Safe-Mode of your OS.

.....if not works - try one of special operating system CD's System folder re-complete scans to set. It can be Googled.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users