Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 Home Prem. won't connect to ethernet


  • Please log in to reply
3 replies to this topic

#1 josh_the_techie

josh_the_techie

  • Members
  • 93 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:08:37 AM

Posted 15 December 2014 - 10:57 AM

My desktop is currently connected to my network via ethernet and client bridge using DD-WRT. It has worked well in the past, but just recently, I have been having issues getting Windows to connect to my home network. I haven't changed any settings or installed new drivers. The client bridge is working fine and so is my home wireless router. I am at my witts end and can't seem to figure out what has happened. I've tried reinstalling my ethernet card drivers, which worked initially, but after starting up my machine this morning, I'm back at square one. It seems as if Windows cannot get an IP address for some reason. All other machines in my household are working fine and don't seem to be acting up in any way.

 

Here is my network setup:

 

Router ----(Wireless)----> DD-WRT Client Bridge ----(Ethernet)----> Desktop

 

I attached the following screenshots and information to help with diagnosing this problem.

 

Attached File  Capture1.PNG   31.64KB   0 downloads

 

Attached File  Capture2.PNG   26.1KB   0 downloads

 

Attached File  Capture3.PNG   26.1KB   0 downloads

 

Attached File  Capture4.PNG   36.53KB   0 downloads

 

Results of ipconfig /all >ipconfig.txt

 

Windows IP Configuration

   Host Name . . . . . . . . . . . . : AMD-DesktopPC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Win32 Adapter V9
   Physical Address. . . . . . . . . : 00-FF-4F-7E-B9-C6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 94-DE-80-C8-06-CA
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8834:89c1:de09:4614%11(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.70.20(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 244637312
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-C4-53-17-94-DE-80-C8-06-CA
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Hamachi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Hamachi Network Interface
   Physical Address. . . . . . . . . : 7A-79-19-92-4B-C1
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2620:9b::1992:4bc1(Preferred)
   Link-local IPv6 Address . . . . . : fe80::22:c98d:48db:d177%15(Preferred)
   IPv4 Address. . . . . . . . . . . : 25.146.75.193(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.0.0.0
   Lease Obtained. . . . . . . . . . : Monday, December 15, 2014 10:31:55 AM
   Lease Expires . . . . . . . . . . : Tuesday, December 15, 2015 10:34:01 AM
   Default Gateway . . . . . . . . . : 2620:9b::1900:1
   DHCP Server . . . . . . . . . . . : 25.0.0.1
   DHCPv6 IAID . . . . . . . . . . . : 360348125
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-C4-53-17-94-DE-80-C8-06-CA
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{D0431359-D508-4A8F-AC60-63BF8BD1B2E4}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D47658B2-944F-4974-84D1-6E1B7F8159AB}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{4F7EB9C6-9935-49C2-8E2B-283F44995C7C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
 

 

Thanks


Edited by josh_the_techie, 15 December 2014 - 10:59 AM.


BC AdBot (Login to Remove)

 


#2 technonymous

technonymous

  • Members
  • 2,474 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:37 AM

Posted 15 December 2014 - 04:04 PM

Your nic has ip 169.x.x.x and 255.255.0.0 subnet mask. Not sure why your adapter didn't pull a IP from the router. Is DHCP setup in the router? If I am not mistaken DDWRT gives out 10.0.0.0/24  Ip addresses. You want to disconnect from Hamachi VPN so you can test your connection. I would also temporarily disable Hamachi till you get your nic back up. Go to start type cmd and use the command ipconfig /release "Local Area Connection" then type the command ipconfig /renew "Local Area Connection" The router should assign an IP. When you disconnect from Hamachi you're computer is supposed to fall back to the local network nic, but since the IP is wrong you get no connection out.


Edited by technonymous, 15 December 2014 - 04:05 PM.


#3 josh_the_techie

josh_the_techie
  • Topic Starter

  • Members
  • 93 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:08:37 AM

Posted 16 December 2014 - 03:33 AM

Thanks for the reply. I rebooted the system and now it seems to be working now at the moment. I'll disable the Hamachi VPN until I can get this sorted out. DHCP is setup on the main router and I have DDWRT setup as a client bridge which basically makes the device into a wireless card (since my router is at the other side of the house). I've been assigned a 192.168.x.x IP and 255.255.255.0 subnet mask. Why would the 169.x.x.x IP be preferred as noted in the IPCONFIG readout? I know that's a self-assigned IP when the nic can't get an IP from a DHCP server, but I can't figure out why it's marked as preferred.



#4 technonymous

technonymous

  • Members
  • 2,474 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:37 AM

Posted 16 December 2014 - 06:30 AM

The "preferred" just means it prefers to use that since it timed out on automatically grabbing an ip from the dhcp server. So It will generate a random 169.x.x.x ip address. Also known as "APIPA" Automatic Private IP Addressing. So if you see one it means that there is something not configured right on the router, dhcp server, Or that no one has given it a static IP. Some info on it. http://compnetworking.about.com/cs/protocolsdhcp/g/bldef_apipa.htm






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users