Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Weird lag in all online games


  • Please log in to reply
1 reply to this topic

#1 alienwow

alienwow

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:58 AM

Posted 30 November 2014 - 05:00 PM

So, my internet works fine. I can browse and watch videos, but I can't seem to be able to play online games like TERA. I downloaded recently and when I log in I can't even move in-game. Also when tried Firefall, the lag was unbelievable.

 

These are my specs, and my anti-virus is Avast!

Alienware M17xR3
Windows 7 home premium 64 bit
intel core i7-2570qm cpu @2.20GHz
8 gb ram
AMD Radeon HD 6870M 4gb memory

 

Any help will be apreciated, thanks!



BC AdBot (Login to Remove)

 


#2 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:02:58 AM

Posted 01 December 2014 - 03:15 AM

Turn OFF (or snooze) the AV.

Turn OFF the firewall.

Close all background programs.

Use wired (not wireless) peripherals.

 

Try it now.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users