Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Acer Vista won't power up after beginning BIOS flash


  • Please log in to reply
3 replies to this topic

#1 !@@**##

!@@**##

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:04:44 AM

Posted 28 November 2014 - 03:44 PM

Acer 5715Z ICL50 with Vista OS

 

While trying to flash the BIOS, this computer appeared to lock up.  The user tried CTRL+ALT+DEL and nothing happened.  The screen continued to show the rolling icon.  After a long while, the user pulled out the power converter; there was no battery installed at the time.  Since then, the computer will not power on.  The user tried the discharging, holding down CTL+I/O button.  Still nothing.

 

There is no emergency/rescue disk.

 

How to proceed?

 

All help greatly appreciated.

 

Wilbur

 

 



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,009 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:44 AM

Posted 28 November 2014 - 04:03 PM

Take a look here. I would check the download of WinCrisis at virustotal.com to make sure it is clean. This site also has the BIOS download for the Acer 5715Z. You can also go to the Acer support site for the latest BIOS. Good Luck.



#3 !@@**##

!@@**##
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:04:44 AM

Posted 29 November 2014 - 12:27 AM

I believe I was able to get the rescue flash drive properly prepared and followed the directions for feeding it into the Acer.  But, I could not get it to power up and begin running.  It is like no electricity is reaching the unit--no sound, no light, just black silence.  I know the converter is ok, because I tested it with my VOM.



#4 JohnC_21

JohnC_21

  • Members
  • 24,009 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:44 AM

Posted 29 November 2014 - 09:00 AM

Not sure if it will work but try the following.

 

Remove the charger and battery. Hold the power button down for 30 seconds. Attach the charger but do not the main battery. Power on the computer.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users