Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wifi Hotspot not working when using netsh command, but working with Connectify


  • Please log in to reply
20 replies to this topic

#1 palanikumar32

palanikumar32

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 28 November 2014 - 02:25 AM

My android phone does not have internet access when i connected to wifi hotspot.But when I used Connectify to create hotspot everything is fine, i also have internet access in my android device.

Here is my steps what I was followed, I have run these below commands.

netsh wlan set hostednetwork ssid=[[Name]] key=[[Password]]
netsh wlan start hostednetwork.

And also I shared my internet connection from ethernet to wifi adapter(Network sharing center -> checked "Allow other network users to connect through this computer's internet connection and select the network connection")

  1. The net work hosted successfully.
  2. It shows "Internet Access" in Network and Sharing Center
  3. I can see that network in my android device.
  4. My Android device obtained IP and connected.

But problem is my android phone does not have internet access. But when I used Connectify to create hotspot everything is fine, I also have internet access in my android device.

So, If anyone have idea, why netsh command cannot share internet? and Connectify can do that?

Note: My PC connected with LAN with static IP.


Edited by hamluis, 28 November 2014 - 02:55 PM.
Moved from Win 7 to Networking - Hamluis.


BC AdBot (Login to Remove)

 


m

#2 splico

splico

  • Members
  • 157 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Croatia
  • Local time:09:29 AM

Posted 05 December 2014 - 06:40 PM

Try setting static IP to Android phone. Make sure you are using CMD run as administrator.


 "Helpdesk: There is an icon on your computer labeled "My Computer". Double click on it.
User: What's your computer doing on mine?"


#3 palanikumar32

palanikumar32
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 05 December 2014 - 11:51 PM

Try setting static IP to Android phone. Make sure you are using CMD run as administrator.

Already tried, not working.



#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:29 AM

Posted 06 December 2014 - 01:06 AM

What version of windows are you using?

 

http://community.spiceworks.com/how_to/show/897-how-to-set-up-virtual-wifi-in-windows-7 the steps in Win 7.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 palanikumar32

palanikumar32
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 06 December 2014 - 01:11 AM

What version of windows are you using?

 

http://community.spiceworks.com/how_to/show/897-how-to-set-up-virtual-wifi-in-windows-7 the steps in Win 7.

Thanks,
Windows 7 Ultimate, Version 6.1, Service Pack 1
I tried the steps from your link. Not working!
 



#6 splico

splico

  • Members
  • 157 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Croatia
  • Local time:09:29 AM

Posted 06 December 2014 - 07:46 AM

All I can tell you that it works with Samsung S4 but there are many posts on multiple forums reporting Android issues with wifi hotspot without any particular reason. You have 3rd party software that works why to change?


 "Helpdesk: There is an icon on your computer labeled "My Computer". Double click on it.
User: What's your computer doing on mine?"


#7 palanikumar32

palanikumar32
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 07 December 2014 - 06:49 AM

All I can tell you that it works with Samsung S4 but there are many posts on multiple forums reporting Android issues with wifi hotspot without any particular reason. You have 3rd party software that works why to change?

There are so many reasons to avoid 3rd party tool. My Antivirus and 3rd Party Softwares are getting conflicts, sometime systems show blue screen error, sometime hangs and need to restart and also 3rd party tool is costly.

So i try to troubleshoot the inbuild internet connect sharing feature.



#8 splico

splico

  • Members
  • 157 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Croatia
  • Local time:09:29 AM

Posted 07 December 2014 - 07:37 AM

Step1 : Configuring notebook:
 
1. You need to create an adhoc network:
 
Open network and sharing center on control panel
click on manage wireless networks then add , a windows is shown, select create an ad hoc network click on next then input a network name(for example name it 015) then choose the security type then check the box save this network.
 
2- now enter again in network and sharing center on control panel to change adapter settings.
 
Right click on your internet network and click on properties then select the tab sharing and check the "allow other network users to connect through this computer's internet connection" (choose wireless network, if multiple networks are shown).
check also the "allow other network users to control or disable the shared internet connection"
next click on setting and check all items..
 
3- Right click on wireless network connection and double click on "internet protocol version 4(tcp/ipv4)"
on the new window select use the following ip address 192.168.137.1
and subnet mask 255.255.255.0
now activate your new adhoc network (if not already) go to the network icon next to the clock and select it and connect.
Congratulation your laptop/pc is now configured .
 
-----------------------------------------------
Step 2 : Configuring the android device :
 
Now,  configure the android device to make it able to access this new adhoc network
Go to setting on the menu of your device
then wireless and networks then wi-fi settings then activate wi-fi .
Right click and choose advanced .
Check the "Use static IP"and fill in :
ip address: 192.168.137.5 (for example)
Gateway : 192.168.137.1
Netmask : 255.255.255.0
DNS 1: 192.168.137.1
DNS 2 : 172.168.137.1
then right click and save.
Finally, click on the adhoc network (and input password if you use WEP security) then connect.
 
This is the procedure that works on three Android devices I have by me at this moment. Do the same with netsh command and will work.

Edited by splico, 07 December 2014 - 07:54 AM.

 "Helpdesk: There is an icon on your computer labeled "My Computer". Double click on it.
User: What's your computer doing on mine?"


#9 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:29 PM

Posted 07 December 2014 - 07:42 AM

Is connectify (basic) not a free software anymore?


Tekken
 


#10 palanikumar32

palanikumar32
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 07 December 2014 - 09:08 AM

 

Step1 : Configuring notebook:
 
1. You need to create an adhoc network:
 
Open network and sharing center on control panel
click on manage wireless networks then add , a windows is shown, select create an ad hoc network click on next then input a network name(for example name it 015) then choose the security type then check the box save this network.
 
2- now enter again in network and sharing center on control panel to change adapter settings.
 
Right click on your internet network and click on properties then select the tab sharing and check the "allow other network users to connect through this computer's internet connection" (choose wireless network, if multiple networks are shown).
check also the "allow other network users to control or disable the shared internet connection"
next click on setting and check all items..
 
3- Right click on wireless network connection and double click on "internet protocol version 4(tcp/ipv4)"
on the new window select use the following ip address 192.168.137.1
and subnet mask 255.255.255.0
now activate your new adhoc network (if not already) go to the network icon next to the clock and select it and connect.
Congratulation your laptop/pc is now configured .
 
-----------------------------------------------
Step 2 : Configuring the android device :
 
Now,  configure the android device to make it able to access this new adhoc network
Go to setting on the menu of your device
then wireless and networks then wi-fi settings then activate wi-fi .
Right click and choose advanced .
Check the "Use static IP"and fill in :
ip address: 192.168.137.5 (for example)
Gateway : 192.168.137.1
Netmask : 255.255.255.0
DNS 1: 192.168.137.1
DNS 2 : 172.168.137.1
then right click and save.
Finally, click on the adhoc network (and input password if you use WEP security) then connect.
 
This is the procedure that works on three Android devices I have by me at this moment. Do the same with netsh command and will work.

 

My android device(Sony Xperia M2 Dual) is not capable to find the Ad hoc Network. In my phone wifi settings, I manually added the network and assign the static IP, but i can't connect to the network.



#11 palanikumar32

palanikumar32
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 07 December 2014 - 09:09 AM

Is connectify (basic) not a free software anymore?

No, connectify is not freeware.



#12 splico

splico

  • Members
  • 157 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Croatia
  • Local time:09:29 AM

Posted 07 December 2014 - 09:12 AM

I really didn't had to do any of these on video but I already do sharing network before using AD HOC maybe I did something from this video that I didn't realized.


 "Helpdesk: There is an icon on your computer labeled "My Computer". Double click on it.
User: What's your computer doing on mine?"


#13 technonymous

technonymous

  • Members
  • 2,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:29 AM

Posted 08 December 2014 - 08:20 AM

If you did everything correctly then I would suggest updating the wifi mini port adapter drivers. Go to start and type devmgmt.msc go to network adapters and right click and update.



#14 palanikumar32

palanikumar32
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Madura, India
  • Local time:01:29 PM

Posted 08 December 2014 - 09:11 AM

If you did everything correctly then I would suggest updating the wifi mini port adapter drivers. Go to start and type devmgmt.msc go to network adapters and right click and update.

Windows said, your driver is already up to date.
I hope there is no problem with device or driver software. Because it is working fine with Connectify tool.

Something blocks my internet connection to share, but not firewall or anti virus, because i already disabled and checked.



#15 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:29 PM

Posted 08 December 2014 - 09:43 AM

Note: My PC connected with LAN with static IP.

 

 

Have you tried reverting to automatic IP address on IPv4 then check the difference when using the DOS netsh command? Have only used auto IP address or DHCP on both virtual host using the netsh command and connectify so I am not sure if that is the case or difference with the netsh virtual host problem.


Tekken
 





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users