Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Linux Mint Mate - Tips & Tricks for 17 Qiana


  • Please log in to reply
20 replies to this topic

#1 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 25 November 2014 - 06:43 PM

When you are new to this Forum, and have installed a Linux Distribution, and then come looking for Help, one of the first things you will be told is eg:

 

"Enable your firewall (not on by default in many Distros). Go to Terminal  (Ctrl-Alt-t) and enter the following and press <Enter>.

sudo ufw enable

You enter your password etc and you can find the rest if you have not done so.

 

BUT (I always have a but) - with Linux Mint Mate Qiana, sure you can get to Terminal through Menu, but I (you the user) want to be able to access it quickly.

 

There is a workaround for having Terminal one click away with the Desktop, and it is as follows:

 

 

  • Click Menu
  • Ignore reference to Terminal
  • Click Applications - All
  • scroll down for Terminal
  • right-click
  • Add to Panel

It will appear left corner of your Panel - drag and drop to where on Panel you want it - then it is only a click away

 

I am reliably told by one source that in prior versions of LMM, Ctrl-Alt-t worked. I can't dispute that, I came in at 17. It DOESN'T work by default in 17.

 

HOWEVER (I often have a however following a but), you can take the following steps to override the default:

 

  1. Go To Menu > Applications > Preferences > Keyboard Shortcuts
  2. Browse to Desktop > "Run a terminal"
  3. Click on the Shortcut, and it shows "New shortcut..."
  4. Press Ctrl+Alt+T, and it shows Ctrl+Alt+T
  5. Click the Close button and try the new shortcut.

No need to reboot.

 

Works for me!

 

Keep Smilin' - I do

 

:wizardball:  Wizard



BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,377 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:08:04 PM

Posted 25 November 2014 - 07:14 PM

 

It DOESN'T work by default in 17.

Why did they do that?  How stupid most Linux users open terminal that way.



#3 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 35,512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:03:04 AM

Posted 25 November 2014 - 08:16 PM

Your choice wizardfromoz:

I can either merge this topic here: http://www.bleepingcomputer.com/forums/t/548703/new-to-linux-newbies-gurus-not-so-newbies-all-distros-tips-lore/

Or you can create a new one emulating the same content.

We do not need to create individual tips and tricks topics every time. When we have existing tips and tricks topics.

Let me know which way you want to go. If I don't get a response in a timely manner, I'll just merge it.

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+

#4 wizardfromoz

wizardfromoz
  • Topic Starter

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 25 November 2014 - 08:39 PM

Hi Animal, PM your way in about an hour or so, have some chores to do for my invalid wife. But will contain some pertinent questions before you act.

 

 

 

It DOESN'T work by default in 17.

Why did they do that?  How stupid most Linux users open terminal that way.

 

 

Nick I agree 105%, mate. I hadn't twigged to it until bmike1 mentioned it elsewhere.

 

We could email the Linux Mint Devs, but last one I sent them a couple of weeks ago about another matter went unanswered.

 

Suggestions welcomed, but hold off until we find a place considered appropriate by Admin.

 

Likewise more tips and tricks to come, once we establish that venue.

 

Keep Smilin - mine is getting a little lopsided :whistle:

 

:wizardball: Wizard

 

BTW - bet Cat knew this and he's been holding out :hysterical:



#5 Al1000

Al1000

  • Global Moderator
  • 7,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:11:04 AM

Posted 26 November 2014 - 11:03 AM

I'm pretty sure Ctrl+Alt+t doesn't work by default in Kubuntu either, as I recall creating the shortcut after I found it didn't work.


Edited by Al1000, 26 November 2014 - 11:03 AM.


#6 wizardfromoz

wizardfromoz
  • Topic Starter

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 27 November 2014 - 03:20 AM

Tks for that input, as always, Al1000. I have only used Ubuntu, of the 'Buntu flavours, and I know it works there.

 

If anyone else has a Distro, whether it be Debian-based, RPM-based or other (is there an other?) where Ctrl-Alt-T does not work, let us know, to enlarge our knowledge base.

 

:wizardball: Wizard



#7 wizardfromoz

wizardfromoz
  • Topic Starter

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 09 December 2014 - 03:30 AM

Actually, I've just done a little more research on Ctrl-Alt-T probs. Started with Googling "Ctrl-Alt-T does not work linux", then refined that, substituting for linux Gnome, KDE, Xfce &c.

 

Seems the problem is wider spread than I thought.

 

I said above

 

 

If anyone else has a Distro, whether it be Debian-based, RPM-based or other (is there an other?) where Ctrl-Alt-T does not work, let us know, to enlarge our knowledge base.

 

... but I would rather keep this Topic related to LMM17.

 

I am wondering whether Admin can give us some ideas? bmike1 too.

 

bmike1 has this Topic here, but no reference to the "does not work" in the Topic Title, which might be changed.

 

:wizardball: Wizard



#8 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,018 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:06:04 AM

Posted 11 December 2014 - 05:25 AM

CTRL ALT T is opening the Terminal fine on Linux Mint MATE 17.1. 

 

Maybe an upgrade is in order, which takes maybe 10 minutes. Easy Peasy. :thumbup2:

 

http://blog.linuxmint.com/?p=2725

 

Hope that this solves that issue for all whom are concerned, and most will have a better running OS, as long as there were no Ubuntu 14.10 PPA's added. In that case, maybe it'll take a clean install of 17.1. 

 

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#9 wizardfromoz

wizardfromoz
  • Topic Starter

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 11 December 2014 - 07:03 PM

Cheers for that update, Cat - might try Rebecca myself soon.

 

But I'd have to report my findings on it elsewhere, or I'd have to get this Topic renamed :lmao:

 

:wizardball: Wizard



#10 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,018 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:06:04 AM

Posted 12 December 2014 - 03:59 AM

 

 

... but I would rather keep this Topic related to LMM17.

 

Just a thought, it may be best to create a new Topic on 17.1 Rebecca, many has already upgraded, the easy way, and come long, few are going to be using Mint 17, except Xfce & KDE users, whom has no choice at the time. 

 

That may be because the Mint as no control over Xfce & KDE, unlike MATE & Cinnamon, which they wrote. It is because of Linux MInt that Ubuntu & others has MATE & Cinnamon options. 

 

Having a Topic on the latest is best, as few are not going to install 17.0 at this point. 

 

EDIT: It's best to keep this Topic centered on Mint 17, many won't upgrade until the next LTS is released in a couple of years, regardless of how many better features are added to the base OS, and bugfixes/patches released. Carry on.  :)

 

Cat


Edited by cat1092, 13 December 2014 - 12:33 AM.

Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#11 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,377 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:08:04 PM

Posted 12 December 2014 - 05:35 AM

 

it may be best to create a new Topic on 17.1 Rebecca,

It will be best. Not everybody is going to update.



#12 wizardfromoz

wizardfromoz
  • Topic Starter

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 12 December 2014 - 05:15 PM

 

It is because of Linux MInt that Ubuntu & others has MATE & Cinnamon options.

 

Mate you need to get on the payroll for Linux Mint, :lmao: - you are its best advocate, deadset. I have SO enjoyed my time with Mate, I am glad you put me on to it.

 

 

Maybe you can get a Moderator or someone up the chain to delete that word & the Topic will be valid for all of the version 17 releases. It's more or less a service pack to 17.

 

Bloody good idea - Hey Chris Cosgrove, are you out there? (or I could PM him)

 

Cheers

 

:wizardball: Wiz



#13 wizardfromoz

wizardfromoz
  • Topic Starter

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 12 December 2014 - 05:31 PM

TIP for today - pristine desktop

 

This may or may not suit your preferences. I like a tidy desktop (perhaps because of my OCD). Prior to yesterday, my desktop looked like this:

 

bSewzza.png

 

Computer and <User> Home are there by default, and removable and external media likewise, pop up by default when in use. The Terminal icon Update is my script for apt-get update, apt-get upgrade.

 

You can change this by the following method.

 

  1. Go to Menu - Applications - Preferences - Desktop Settings, then
  2. Untick Computer, Home & Mounted Volumes, (you will see the icons disappear one by one as you do so) then close the window.

The drive icons as well as Computer and Home icons will then disappear from the desktop. In my case that left me with "Update", which I then dropped into Home.If you had more icons, you could drop them into Home before you unticked the Home box.

 

Now my desktop looks like this:

 

obSMf0z.png

 

Neat and sweet! Works for me

 

Remember that you can always access the drives from Menu - Places, or retrace and reverse these steps.

 

:wizardball: Wizard



#14 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,018 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:06:04 AM

Posted 13 December 2014 - 01:31 AM

Wiz, in that post above, those pics, have you deleted the panels, or are they just left out of the screenshots? Seems like that's needed to access basic functions. 

 

BTW, that's beautiful scenery, I've used that background, and change up every few months. No way by looking at those, would one think there is an unanswered issue with the NVIDIA graphics card, I'm having the same issue with two computers (notebooks), one has Intel HD graphics & NVIDIA card, the other, just Intel HD graphics. 

 

Though the desktop looks fine when logged on, during login, only part of the screen shows. Have found no answer anywhere. Maybe a hit at one but nothing that was close to being 100% for sure, certainly not enough to warrant opening the Terminal, plus Leafpad, and adding 25-30 lines of code. This was also the case when trying Kubuntu 14.04, so know it's not just a LInux Mint thing. 

 

BTW, here's the desktop on the MSI, the one with both Intel & NVIDIA graphics. 

 

Screenshot-21.png

 

These notebooks, to include AIO PC's, which are for the most part assembled with notebook components, needs a way to disable the onboard graphics just as with a desktop, to force the discrete graphics card to do it's work if desired, there's a world of difference in Intel HD or GMA graphics & that of discrete cards soldered to the board. What good is it if not an on-demand feature? On Windows 7, I can avoid this, be right clicking on the browser & the option will be given as to which graphics processor I want to use (same with any Media Players/Center). 

 

It's not an obvious option on any version of Linux that I've ran, except on my desktop, where that Intel 4600 junk is disabled. They (Intel) calls that gaming worthy graphics, I don't think so, though it's a bit better than Intel 915GM/GMS cards of a few years back, and 1st gen Intel HD graphics (what's in the MSI above). That has to be the NVIDIA card kicking in on that one, have never seen Intel graphics look that good. 

 

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#15 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,377 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:08:04 PM

Posted 13 December 2014 - 03:27 AM

 

in that post above, those pics, have you deleted the panels, or are they just left out of the screenshots?

You can easily remove or restore them in settings/desktop/icons, By checking or un checking  the box besides the icon.

6715rp.png






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users